Windows 10: Why can't I rename or delete files and folders? Windows 10 home


  1. Posts : 4
    windows 10 home
       17 May 2017 #1

    Why can't I rename or delete files and folders? Windows 10 home


    Hi all,

    to start I am not particularly adept with computers so please bare with me.

    I am using an HP laptop running windows 10 home edition.

    Today from nowhere i suddenly started having this issue,

    When I try to rename a folder it tells me I cannot as folder is in use, even when i can find nothing using it or in any way connected, even directly after a restart. I then attempted to make a new folder and move the contents to the newly created folder with the correct name. This got about 40% through when it asked me to provide admin permission (which is not normal). I hit accept, it prepared to move files and then said I don't have permission, when this is my laptop and only has one account on it. I could not get it to continue so i cancelled to find half the files had moved and half had not. I was then found I was unable to further move any of the files, in either direction and also could not delete anything, always the same permission issue.

    Even trying to rename a folder via command line said i didn't have permission.

    "You require permission from DESKTOP-NFSUNT6\user to make changes to this folder"

    After searching every forum and website I could find, nobody seems to have had exactly this issue, though it seems similar ones were commonplace on windows 7 (I've never used it myself) and after the better part of a day wasted i'm out of ideas.

    I'm not sure if this is 1 issue or 2 separate ones but any help is greatly appreciated.

    thanks

    Hass
      My ComputerSystem Spec

  2.    17 May 2017 #2

    Make sure you restart the computer by clicking the restart option from the power menu. Then:

    How to take ownership of files and folders on Windows 10 | Windows Central
      My ComputerSystem Spec


  3. Posts : 4
    windows 10 home
    Thread Starter
       20 May 2017 #3

    Hi,

    I tried these steps a few times and in every variation I could think of.

    One issue is my user does not seem to appear on the list, so i tried a few different ones that should have been it.

    End result is no change from my original issue.

    thanks for the response but does anyone have any further ideas?

    regards
    Hass
      My ComputerSystem Spec


  4. Posts : 93
    Windows 10
       20 May 2017 #4

    Hi Hass123,

    If a program is locking the item you’ll need to identify and stop the program before you can delete the item.

    If it is a permission problem, please post the permissions for the item you have having trouble deleting.
      My ComputerSystem Spec


  5. Posts : 4
    windows 10 home
    Thread Starter
       20 May 2017 #5

    Click image for larger version. 

Name:	image.png 
Views:	2 
Size:	70.6 KB 
ID:	135806
    hope this helps
    thanks
      My ComputerSystem Spec

  6. TairikuOkami's Avatar
    Posts : 3,326
    10.5 Home 1803 x64
       20 May 2017 #6

    Just taking ownership will not do, you also have to take inheritance permissions, like this:
    Code:
    takeown /f "‪C:\Program Files (x86)\Steam" /a /r /d y
    icacls "‪C:\Program Files (x86)\Steam" /inheritance:r /grant:r Administrators:(OI)(CI)F /t /c

    You should not have Steam in Program Files anyway, that folder is triple protected.
    If you do not have other partitions to move it to, at least move it to C to prevent issues like this.
      My ComputerSystem Spec


  7. Posts : 93
    Windows 10
       20 May 2017 #7

    Ahh, the Steam folder. Yes, everybody has been having permission problems with this lately. Is this the folder you are trying to delete?

    Do TairikuOkami’s suggestion first. If that for some reason doesn’t work, you’ll need to do things manually…

    Attempt a delete operation on this folder, then navigate as far as you can into this folder until you can go no deeper. These child items will be the items that are preventing you from deleting the Steam folder branch. Try deleting these items individually and if you cannot then theses are the items you should be posting the permissions for.

    Make sure you extend the permission window to show all permission entries.
      My ComputerSystem Spec


  8. Posts : 4
    windows 10 home
    Thread Starter
       20 May 2017 #8

    thanks ill try that,

    sorry to be this basic but where do I input the code, I tried command windows opened from the folders but having no luck.

    thanks
      My ComputerSystem Spec


  9. Posts : 93
    Windows 10
       21 May 2017 #9

    Try entering it into an elevated command prompt. It is bound to fail though if NavyLCDR’s suggestion didn’t work.
      My ComputerSystem Spec


 

Related Threads
I recently deleted some mp3 files and folders, then when I emptied the Recycle Bin I inadvertently answered "no" to the "are you sure you want to delete these files" question. Now they are sitting on my recent files / frequent folders page and will...
Solved Can't delete files/folders in General Support
I have extracted some emulation files into my internal G: drive, and I decided they aren't what I needed and tried to delete them. Most of the files deleted but I have 3 folders and several files that will not delete. I can't delete the files (which...
Every time I get one of these involuntary updates from Microsoft, my PHOTOGRAPHS folder is renamed MUSIC. The folder icon changes also. Up to now it has merely been a nuisance. But after the most recent update, the RENAME option disappeared from...
When I try to rename or delete a file Windows Explorer freezes for an average of 20 seconds. I opened my running processes to see what I could find, and during this 20 second period it reads "Not Responding" next to Windows explorer (as seen in...
Can someone tell me how to delete all Thumb.db files on my network drive? I have Windows 10 Home, and want to delete thumbnail files in my folders that are on a Synology NAS. Windows error: thumbs.db file in use", so I can't delete it. ...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 19:03.
Find Us