You dont have permission to save to this location


  1. Posts : 455
    Microsoft Windows 10 Professional (x64) Build 19044.1706 (21H2)
       #1

    You dont have permission to save to this location


    "You don't have permission to save to this location. Contact the administrators to obtain permission. Would you like to save in the Documents folder instead?"

    This message randomly pops up when I am trying to save something to the desktop, like a newly created .txt file or .png.

    When it happened today, I selected "yes", it took me to my Documents folder, but instead of saving it there, I pulled down the menu, selected desktop, whereupon it saved it to the desktop, no problem.

    What's up with that??
      My Computer


  2. Posts : 3,677
    Windows 11 Pro 64 Bit 21H2
       #2



    1. In File Explorer Right-click on the C: drive

    2. Left-click on Properties.
    3. Click on the Security tab.
    4. In the first window click on Administrators (your computer name-PC Administrators).
    5. Just below the window click on Edit.
    6. Click on Administrators (your computer name-PC Administrators) again.
    7. Here's the key to making it work. If Apply is grayed-out, check a box in the Deny column. It will then bring up Apply.

    8. Check a box in the Allow column. It should check all of the boxes except the last one and uncheck all of the boxes in the Deny column.
    9. Click Apply. It should run a scan of the files in the drive. When the scan is finished, click Ok. The first box should still be open.
    10. In the first window, click on Users (your computer name-PC\Users) and repeat steps 5-9, of course clicking on Users (your computer name-PC\Users)
    instead of Administrators (your computer name-PC Administrators).
    NOTE: You may not have to click in the Deny column after the first scan is completed for step 10 as indicated in step 7.
      My Computer


  3. Posts : 455
    Microsoft Windows 10 Professional (x64) Build 19044.1706 (21H2)
    Thread Starter
       #3

    Thanks. But I don"t really want to change permissions for C:\. The only box that is currently not checked is "Full Control", and I don't mind having the "You'll need to provide administrator permission" confirmation message pop-up if I want to move something there.

    I think something else is going on.

    My "Desktop" already has all permissions checked, but that's where I get that "absolute" deny message, however, like I said, not all the time. Once in a while, with no discernible pattern.

    That's one strange thing.

    The other is that I just tried to do a "save as" to C:\ for a text file already sitting on my desktop. It saved without hindrance...no confirmation message.

    But when I went to look for it, it wasn't in C:\.. It was in "C:\Users\xxx\AppData\Local\VirtualStore". C:\Users\xxx\AppData\Local\VirtualStore\Program Files (x86)\IrfanView\i_view32.ini is there as well, and I have no explanation for that.

    Furthermore, I have no problem doing a copy/paste for that same text file (with the confirmation message) from desktop to C:\.

    I found this,
    I saved a file on C:\ and it put it where ? ! virtual store ? Solved - Windows 7 Help Forums

    Which led to this
    Process - See if running as administrator (elevated) - Windows 7 Help Forums

    But I'm still confused, and the Windows 10 task manager options are different than Windows 7

    EDIT: I found this

    How to See if Process is Running as Administrator (elevated) in Windows 10?

    Notetab.exe is enabled for UAC Virtualization (along with a couple other utilities, "Volumemouse" and "CPU Usage in Tray", both of which are older 32 bit programs and the only items I have set to launch when Windows boots) , but I don't know why. Maybe because it's the 32 bit? I still don't understand this virtualization thing.

    Does it have something to do with configuring compatibility?

    Should I just "disable" virtualization for all these items?

    Is this issue linked to my original question?
    Last edited by kitpzyxmsir; 10 May 2017 at 15:10.
      My Computer


  4. Posts : 2
    Windows 10 Home 64 bit
       #4

    I had this same problem. I fixed it. Found out my anti virus had file protection enabled. This is what was giving me this issue. I would get the popup saying I didn't have permission to save here, contact administrator. Check you anti virus or firewall for file protection and allow the programs you need to save files with. This should fix your problem.
      My Computer


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 03:26.
Find Us




Windows 10 Forums