Page 2 of 2 FirstFirst 12
  1.    13 May 2017 #11
    Join Date : Jan 2015
    UK, Midlands
    Posts : 10,953
    Win 10 Pro (1703)

    Are you actually launching regedit by rt clicking and 'Run as admin'?

    As to whether you'll get specific help, it may depend if someone who reads this has done it. I for one would be uncomfortable changing registry permissions to try it.

    And note: a fair number of threads started receive 0 answers 'cos people can't think of sthg helpful or don't have specific experience relevant to the issue.
      My ComputerSystem Spec
  2.    13 May 2017 #12
    Join Date : Jan 2015
    Posts : 58
    Windows 10
    Thread Starter

    Shouldn't need to right click and select 'run as...' as I am the administrator, and regedit does ask if I want to allow changes.
    I wasn't complaining about no response. I was just surprised as over the years on various Windows versions, these forums have always produced an answer!
      My ComputerSystem Spec
  3.    14 May 2017 #13
    Join Date : May 2017
    Posts : 95
    Windows 10 Pro

    not entirely true about being an Administrator...

    "Run as Aministrator" is just a command, enabling the program to continue some operations that require the Administrator privileges, without displaying the UAC alerts.Even if you are a member of administrators group, some applications need the Administrator privileges to continue running, because the application is considered not safe, if it is doing some special operation, like editing a system file or registry entries.
    If you execute the application with 'run as administrator' command, you are notifying the system that your application is safe and doing something that requires the administrator privileges, with your confirmation.



    Back to the issue and assuming this is a AIO printer scanner

    I had a smilar issue with a network scanner name and resolved this by creating a test Administrators account. The issue was not apparent in the new account so I assumed it was only a software glitch.

    Back in the original account,
    I turned off automatic setup of network connected devices in Advanced Settings within Network and Sharing CentreI removed all drivers especially from the PrinterServer properties type "Print Management" in Cortana, ensure you remove all printer driver packages. "You may need to turn of printer spooler in services manager "services.msc" and turn back on to allow you to delete all driver packages.

    Reboot the PC

    Installed the printer/scanner and it resoved my network name issue.

    worth a try, otherwise I am at a loss without hands on, sorry

    HTH
      My ComputerSystem Spec
  4.    14 May 2017 #14
    Join Date : Jan 2015
    Posts : 58
    Windows 10
    Thread Starter

    I am in serious danger of losing the will to live here!
    I tried everything you suggested, thanks for that, but to no avail.
    Creating a test admin account was interesting as the problem was not there. However, I did everything you suggested and still, no matter what, my AIO printer shows up in Scanners as 'Karas-iPhone'!
    See attached snip. The printer can be seen as 'HP4520 Maggie' in Devices, but when I select 'Start Scan' from right click, it shows as 'Karas-iPhone'.
    Again, I have removed all registry references to 'Karas-iPhone' but they just come back after a reboot.
    I have wasted so much time on this, and don't want to be beaten!
    Attached Thumbnails Attached Thumbnails rg.JPG  
      My ComputerSystem Spec
  5.    14 May 2017 #15
    Join Date : May 2017
    Posts : 95
    Windows 10 Pro

    Without being able to replicate the issue, I cannot add further comment except ....

    As the test account did not have the issue, why not create a new account, transfer your information and delete the old one ?

    or

    One last try, registry files are cache like and so a cached copy maybe the issue, try deleting the offline file cache or reset the offline file cache

    Good luck with your plight.
      My ComputerSystem Spec
  6.    14 May 2017 #16
    Join Date : Jan 2015
    Posts : 58
    Windows 10
    Thread Starter

    Solved it!
    The solution was on the printer itself. Somehow, the 'Host Name' was set to 'Karas-iPhone'. Changing that on the printer has sorted everything out! How that new printer got that name I will never know. I know that doesn't explain why the test account didn't have the issue, but....
    Anyway, thanks to everyone for their valued suggestions.
      My ComputerSystem Spec
  7.    14 May 2017 #17
    Join Date : May 2017
    Posts : 95
    Windows 10 Pro

    Glad you have it sorted.

    Cheers
      My ComputerSystem Spec

 
Page 2 of 2 FirstFirst 12


Similar Threads
Thread Forum
Solved Will any change to registry cause sfc /scannow to show corrupt?
Hello I am trying to find out if any changes to the registry will cause the sfc scan tool to say there are corrupt files. In my case I have changed the caps lock button to not function via the tenforums tutorial and also added registry editor to...
Performance & Maintenance
Customization Change Font for Registry Editor in Windows 10
How to Change the Registry Editor Font in Windows 10 System configuration information is stored centrally in a hierarchical database called the registry. You can use Registry Editor to add and edit registry keys and values, restore the registry...
Tutorials
Will this registry change help with high CPU usage?
I'm hoping coming back with a new, specific post on this item will get a response. No further responses to this particular question were forthcoming on my original post. I'm about to let someone remotely connect to my computer to go through it over...
Performance & Maintenance
Solved Administrator can change owner of registry key but not permissions...
I'm running 64-bit Windows Pro on an Asus P5Q-EM MB with an Intel E8600 processor with 8 GB of PC2-6400 Ram. I've had a couple of unexpected shutdowns and restarts lately. I've got several different error types in my event log. The only one...
User Accounts and Family Safety
Desktop rearrange / registry change
Hello, I've got a problem with desktop. After reboot/restart or even refresh desktop all icons are moved to left side of screen. I found this solution: In regedit go to those 2 destinations ...
General Support
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 16:24.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums