1.    05 May 2017 #1
    Join Date : Sep 2015
    Posts : 49
    Windows 10 Pro

    Moved drive to another computer - won't boot


    Hi all,
    I am trying to move a drive with Windows 10 Pro x86 from a dell 755 to a 7010. Win10 boots fine when I put it in a 745, 755, or 780, but not the 7010. The 7010 is set for Legacy ACHI. All I get is a blue logo and the spinning circle dots. Does the same in safe mode. There are no add-in cards or USB devices. I also tried the disk in an HP 6300, which has the same specs as the 7010, and it also does not boot. Tried start-up repair. Tried rebuilding BCD. Tried Reset PC - didn't run.

    I am out of ideas. Anyone?
      My ComputerSystem Spec
  2.    05 May 2017 #2
    Join Date : Mar 2017
    Posts : 471
    Win 10 Pro 15063.332 (ex-Insider)

    Did you originally do a UEFI install on the drive in question and what are the BIOS settings on the 745, 755, and 780 that work (UEFI or Legacy)?
      My ComputersSystem Spec
  3.    05 May 2017 #3
    Join Date : Sep 2015
    Posts : 49
    Windows 10 Pro
    Thread Starter

    Always been MBR Legacy ACHI. UEFI is not selected on the 7010, using legacy. the other systems are pre UEFI. The BIOS settings on the 745/755/780 are ACHI. My only thought is there is something different how a UEFI capable system boots even in Legacy mode. Also since I am using 32 bit OS, I have to use legacy. UEFI is not supported with 32 bit OS'es

    I even installed a fresh Windows 10 Pro x86 on the 7010, then tried to replace the C drive partition with the original drives C partition. Still spinning circle.
      My ComputerSystem Spec
  4.    06 May 2017 #4
    Join Date : Sep 2015
    Posts : 49
    Windows 10 Pro
    Thread Starter

    here's a twist. The drive will now boot if I unplug the DVD SATA drive. Happens with either HP 6300 or Dell 780 and 7010. I can leave the SATA port active, just pull the cable off the motherboard and then it boots. After I booted, I made sure all the drivers were current. Even tried the Rapid Storage driver but I don't think the system gets that far in the boot process.

    Next step I did was to upgrade Windows 10. I started with version 1607. Plugged in the SATA cable, then did the update to 1703. System restarted and applied the update but still does not boot when it was finished with the update with the SATA cable plugged in. Had to shut down, pull the SATA cable then reboot and it came right up. Happens on multiple systems, so it isn't a hardware issue. Even tried different disk drives.

    I even tried using an a PCIe SATA adapter (Marvell 91xx) and it does the same thing with the DVD plugged in. And yes I have tried different DVD/CDROM drives. One more thing. Works fine with a hard drive or SSD plugged into the motherboard SATA port, Just not with an optical drive.

    The original Windows 10 image came from a Dell Optiplex 745.

    UPDATE
    Problem solved. Had to fix the CDROM property class.
    HKLM\SYSTEM\CurrentControlSet\Control\Class\{4d36e965-e325-11ce-bfc1-08002be10318}
    Deleted the Upper and Lower filters and removed the additional cdrom drives.
    What I did was export the key from a working system and then Import the entire key into this one.
    Hope this helps any others who may run into this.
    Last edited by dcol; 06 May 2017 at 18:11.
      My ComputerSystem Spec

 


Similar Threads
Thread Forum
Moved ext data drive (XP machine) to new computer (win 10) Owner Issue
Hello from a new member and new win 10 user. I had an XP machine that died and replaced it with a new Win 10 pro machine. I moved the old external data drive to my new computer and now have had lots of "you're not the owner" and "contact the...
General Support
Allowing Computer to boot without secondary drive
All right, so I have an SSD and an HDD. Windows is installed to the SSD, but apparently Windows likes to create a boot partition on every drive that's connected when you install, which led to me not being able to boot without the secondary drive....
General Support
Solved Computer tries to boot from CD-Rom before hard drive. A problem?
I upgraded from Windows 7 to Windows 10, and now, whenever I restart my computer, it briefly gives a "Boot from CD-Rom" (or some such words to that effect) message, then gives a second message saying that it is now attempting to boot from the hard...
General Support
Can see only boot drive on networked computer
I am able to see my networked computer, but only the C: boot drive. How can I see the contents of other HDDs on that computer?
Network and Sharing
Hard drive won't boot on one specific computer
I have a Toshiba Satellite S55-A5294 laptop computer. It is running Windows 10. I had the drive encrypted using Jetico's BestCrypt full disk encryption. Several weeks ago, I was using Windows, put the computer to sleep, and when I came back an...
General Support
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 00:56.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums