My Windows Creators Not Working Very Well


  1. Posts : 50
    Windows 10 Home
       #1

    My Windows Creators Not Working Very Well


    I did a clean install using MS creators update the 1st day it was released. Install went very smoothly. No problems.
    The first week it ran like a champ, but then started slowing down and having some glitches.
    Haven't seen anything like this posted anywhere here and was wondering if I should start with another clean install. Have checked for malware etc. Have tried some fixes I've seen here, but they made matters worse.

    Thanks
      My Computer


  2. WOT
    Posts : 471
    Win 10 Pro 15063.332 (ex-Insider)
       #2

    I would do another clean install, and if the same glitches re-appear, report the specific occurrences in detail because generalizations will not get you much help.

    good luck,

    WOT
      My Computers


  3. Posts : 50
    Windows 10 Home
    Thread Starter
       #3

    WOT said:
    I would do another clean install, and if the same glitches re-appear, report the specific occurrences in detail because generalizations will not get you much help.

    good luck,

    WOT
    Thanks. I'll try that.
      My Computer


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 00:53.
Find Us




Windows 10 Forums