1.    28 Apr 2017 #1
    Join Date : Apr 2017
    Posts : 4
    Windows 10

    After enabling Microsoft login, can't start task/service on boot


    I've got a startup script to spin up my VMware server, as soon as the computer boots (not user login). Set this up in Task Scheduler, it worked great. With my local user account, not linked to Microsoft at all.

    Due to Microsoft's Store, or my own fat fingers, I'm now logging in with Microsoft.com credentials.

    Now my startup task doesn't run! I also can't find the event logs for Task Scheduler

    Could this be a permissions issue? Like, does a Microsoft.com account not function before the user actually logs in? I have the script set to run with my username, I entered the new password, and I have it set to run with the highest privileges. Any way to get this to work again?

    Is there any way to get this task running again??
    Is there a way to revert back to local account?
      My ComputerSystem Spec
  2.    28 Apr 2017 #2
    Join Date : Oct 2013
    Posts : 25,272
    64-bit Windows 10 Pro build 17046

    Hello AdmEEn84,

    Since you switched to a Microsoft account, this would have changed the credentials for your account.

    The task was setup using the credentials of your local account, so you may be able to just edit the task to update it with your current credentials to see if that may help.
      My ComputersSystem Spec
  3.    28 Apr 2017 #3
    Join Date : Apr 2017
    Posts : 4
    Windows 10
    Thread Starter

    Yeah I re-entered my password into Task Manager as soon as I realized, still no dice. I can run the batch just fine, and I can run the task while logged in.

    I think the problem is rooted in the need for this process to initiate a program that runs like a system service. But when/if I login I want to be able to interact with it, so I run it with my credentials. I've also checked 'run with highest privileges'

    Is it possible that my 'Microsoft user' account cannot run as LocalSystem account or something like that?

    Also, I can't even run this batch script on startup with group policy, either
      My ComputerSystem Spec
  4.    28 Apr 2017 #4
    Join Date : Oct 2013
    Posts : 25,272
    64-bit Windows 10 Pro build 17046

    If you like, you could switch back to a local account to have it work as before. Be sure to change the credentials back for the task again afterwards though.

    Switch to Local Account in Windows 10 - Windows 10 User Accounts Tutorials

    If you still need to sign in to the Store with your MSA, you can use the method in the tutorial below to do so without switching the account you sign in to Windows 10.

    Use Local account with Windows Store - Windows 10 Apps Features Tutorials
      My ComputersSystem Spec
  5.    30 Apr 2017 #5
    Join Date : Apr 2017
    Posts : 4
    Windows 10
    Thread Starter

    Thanks for the info! That's probably what I'm going to have to do. Not only having trouble running batch scripts, but all my devices that connected automatically to this computer now require a password every time. Click remember the password, doesn't matter; kinda sucks that I gotta enter it in every time.
    Maybe is there a Group Policy setting or something that would allow saved credentials to log in to this pc?
    I can see in the event logs that it used to authenticate with NTLM, but now it needs the Microsoft.com domain. Something about asking Microsoft for permission to login to my own pc... Yeah that just rubs me the wrong way

    Anyway, just for the record, I did some more research and there is a user Principle called 'Batch', apparently that's the security for batch files. Enabled read/write/exec for all the scripts, no luck without the user logged in
      My ComputerSystem Spec

 


Similar Threads
Thread Forum
Windows 10 boot/login slow and no start menu and notifications
Hey, when i turn on my computer, and type in my account password, i wait a minute to log in, but i have a ssd, and 3 days ago it took only a few seconds. Also, after i type in my password, i hear Windows 10 error chime every minute or two, until i...
AntiVirus, Firewalls and System Security
Explorer/Start menu/Task bar/Sound service problem
I've been experiencing problems with start menu. It won't load if I click. When it happens, it's the same problem with the task bar. Sometimes it's okay, I'm listening to a song and then the problem begins: sound stops, youtube crashes and won't...
Performance & Maintenance
Solved BitLocker after enabling boot to startup settings with winaero
Hi, I have a serious problem. I enabled the boot to startup settings option in winaero and now my computer boots to bitlocker. I checked online and I don't have the key for it. What can I do? (Computer is surface pro 3 i5 4g of ram)
General Support
Solved How do Local and Microsoft login effect my PC's login from a boot.
I should be grateful for any help. At the moment I have a Local login and I am considering changing to a Microsoft login. If I do, does this mean that when my PC starts from a boot, that instead of the pin that I use to login to my account on the...
Installation and Upgrade
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 08:15.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums