Page 1 of 2 12 LastLast
  1.    26 Apr 2017 #1
    Join Date : Mar 2017
    Posts : 69
    Windows 10

    Cannot add a Drive to Indexing Options


    Hi. I’m hoping someone can tell me how to get my E drive indexed for searching purposes. As you can see from the pic, it’s just not ‘addable’…

    I have an SSD dedicated to the OS and two HDDs (E and F). I recently had a problem with some files on the E drive in that I was denied permission to change their details so I changed the ownership/permissions. However, both E and F now have the same Owner/Permissions settings so it can’t be that (can it…).

    Any help is greatly appreciated.
    Attached Thumbnails Attached Thumbnails indexing.jpg  
      My ComputerSystem Spec
  2.    27 Apr 2017 #2
    Join Date : Jan 2015
    UK, Midlands
    Posts : 10,928
    Win 10 Pro (1703)

    Hi, have you tried deleting and rebuilding the search index since changing the permissions?
    And have you run the search indexing troubleshooter?
    Click image for larger version. 

Name:	Snap 2017-04-27 at 07.13.50.jpg 
Views:	4 
Size:	48.2 KB 
ID:	132178

    Yo could also try this program:
    Click image for larger version. 

Name:	Snap 2017-04-27 at 07.11.15.jpg 
Views:	22 
Size:	37.6 KB 
ID:	132177
    running the appropriate repair on your drive.

    Also you could try running chkdsk on it.
      My ComputerSystem Spec
  3.    27 Apr 2017 #3
    Join Date : Mar 2017
    Posts : 69
    Windows 10
    Thread Starter

    Yes (rebuild) and Yes (troubleshooter) - both had no effect. I'm currently running chkdsk E: /f /r /x which means a wait of 6 hours...
      My ComputerSystem Spec
  4.    27 Apr 2017 #4
    Join Date : Jan 2015
    UK, Midlands
    Posts : 10,928
    Win 10 Pro (1703)

    Worst case - which might be quicker- copy the data off, reformat the drive and copy it back.

    Have you actually checked the drive is good? E.g. Crystal Diskinfo (free) - SMART params - or sometimes better Hard Disk Sentinel (trial).
      My ComputerSystem Spec
  5.    27 Apr 2017 #5
    Join Date : Mar 2017
    Posts : 69
    Windows 10
    Thread Starter

    Properties/Tools/error checking immediately said it saw no problems. I'll wait for chkdsk to finish and then see what's what, I think. I'm sure the disk is good, too much of a coincidence for it to go just after I've clean installed Win10...
      My ComputerSystem Spec
  6.    27 Apr 2017 #6
    Join Date : Mar 2017
    Posts : 69
    Windows 10
    Thread Starter

    Twelve hours that took... No errors found. A reboot later and my situation is the same. Apart from the copy off/reformat/copy back suggestion (which I'll delay for now) is there anything else I might do? Thanks.
      My ComputerSystem Spec
  7.    27 Apr 2017 #7
    Join Date : Feb 2016
    Maribor, Slovenia
    Posts : 8,867
    Windows 10 (Pro and Insider Pro)

    It's a long shot, but you could try to rebuild MBR on that drive... I'm using Minitool partition wizzard for such tasks. It's free for home use.
    Click image for larger version. 

Name:	image.png 
Views:	3 
Size:	96.3 KB 
ID:	132277
      My ComputerSystem Spec
  8.    27 Apr 2017 #8
    Join Date : Mar 2017
    Posts : 69
    Windows 10
    Thread Starter

    I forgot to mention that I ran Tweaking.com – Windows Repair as suggested above. It had no effect.

    Hi AndreTen and thanks for the tip. I haven’t run the wizard yet as I’ve noticed something (possibly) interesting. When I did my clean-install a week ago, I unplugged the E & F drives and took the opportunity to do a UEFI install. I knew that this would change the C drive from MBR to GPT but look at the pic – my 4TB E drive is also GPT. I suppose it must always have been like that as I’ve never touched it.

    Could this be a clue as to why it’s not indexing? Seems unlikely to me as it’s never given me an indexing problem before.

    My continued thanks.
    Attached Thumbnails Attached Thumbnails wizard.jpg  
      My ComputerSystem Spec
  9.    27 Apr 2017 #9
    Join Date : Jan 2015
    UK, Midlands
    Posts : 10,928
    Win 10 Pro (1703)
      My ComputerSystem Spec
  10.    27 Apr 2017 #10
    Join Date : Mar 2017
    Posts : 69
    Windows 10
    Thread Starter

    OK, thanks. Is that partition wizard of any use to me then? If not, what else might I try?
      My ComputerSystem Spec

 
Page 1 of 2 12 LastLast


Similar Threads
Thread Forum
Indexing Options removed
I have been using Windows Index search for years. I have all my data in one directory on my D:\. I have set the indexing options to include this location and some others. Recently Windows has been dropping my selections and reverting to the...
Performance & Maintenance
Windows 10 Indexing Options Drive Missing
I recently installed Windows 10 on a computer containing 3 internal and 8 external hard drives. Although all the drives show up in Disk Management and File Explorer, one of the internal drives isn't listed under "Indexing Options" so I can't get the...
General Support
Indexing Options internals
Dear friends hallo, One day I noticed that the processes responsible for indexing were taking up too much process power. I noticed that this happened because I transferred my e-book collection to my PC. Windows was trying to index the contents of...
General Support
Search indexing is indexing my D: drive instead of C:
dual boot system 10 on C:, 7 on D: Search indexing insists on indexing drive D: instead of C: No matter how many times I uncheck indexing locations on D: and choose proper locations on C:, when indexing starts to rebuild it reverts back to D: I...
General Support
Indexing Options keeps reverting to default
Hi all, I have been trying to set my Windows 10 Home 64-bit computer to index only the Start Menu but not anything else (such as IE Favourites, Documents). I know exactly where all my documents are; the only time I use search is something like, I...
General Support
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 23:51.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums