Windows 10: Can't preview any font in Windows 10 recent install

Page 2 of 3 FirstFirst 123 LastLast
  1.    31 Mar 2017 #11

    Hmm... hard to tell whether that's related to your basic problem, or something else. It's definitely not what I'd expect.
    And we are fairly sure something in your registry isn't correct.

    Here's what I suggest.
    Download and run Tweaking.com's free cautious repair tool.
    Run it, observing the initial stages which include creating a registry backup and restore point.

    Run repair 01 (registry permissions).

    Now download and run Ccleaner.
    Click Registry, and select a couple of items. (We don't want to do lots of things, just see if it picks up these keys).
    E.g. try Fonts, then Application paths, for example.
    For each one you select Scan for Issues
    Don't bother about things that don't seem relevant- leave well alone.
    See if you can find these keys, then fix the problem for those only.

    Now it depends what's listed. It could be a lot, and this may not prove feasible.
    I'd just prefer to change the minimum.
      My ComputerSystem Spec

  2.    31 Mar 2017 #12

    I did as described, performed the Tweaking.com Windows Cleaner only for 01 (registry permissions, I did twice: one-reboot-one, always in safe mode), then I used CCleaner for these points but it only found one entry which made reference to a folder with some data I had in Desktop which I deleted yesterday.

    ContextEdit keeps giving the same error.

    Tweaking.com Windows Cleaner, during the initial stages, in the second one (Pre-Scan, which is optional) found some errors on 'Reparse Points' (I don't know what it is, neither if it is related to this problem, so I did not repair them yet).
      My ComputerSystem Spec

  3.    01 Apr 2017 #13

    Ok, continue with Ccleaner registry cleaning, selecting more options- I suggest 2 or 3 at a time to limit the number of results, as you feel.
    Or you could just select all the rest and see what happens. Sometimes there can be hundreds of results listed.

    I would accept Tweaking.com Repair Tools recommendations.
      My ComputerSystem Spec

  4.    01 Apr 2017 #14

    Ok, I did. I have not found the registry key in the CCleaner results. There have been some results but not about this key.

    I have executed the fixes suggested by Tweaking.com tool, though.

    In your registry, when you click on this key, are you able to see its contents or it says the same than me?
      My ComputerSystem Spec

  5.    01 Apr 2017 #15

    Hi, I only have these entries, one of which is the same as yours:
    Click image for larger version. 

Name:	Snap 2017-04-01 at 10.04.33.jpg 
Views:	13 
Size:	18.1 KB 
ID:	127543

    All right, let's try this a different way. Using ShellMenuView (free)
    Click image for larger version. 

Name:	Snap 2017-04-01 at 10.11.42.jpg 
Views:	6 
Size:	164.7 KB 
ID:	127544

    Considering your missing context menu entry - there you will see Shell, Preview, Command
    That should define your Preview command in the context menu.
    (Below it is the one for Print)

    You can check in Shellmenuview whether that exists, and whether it's been disabled, and from its entry, open Regedit (rt click on entry Open Regedit)

    From there, Nirsoft also offers this for extensions:
    .ttf Extension - List of programs that can open .ttf files
      My ComputerSystem Spec

  6.    01 Apr 2017 #16

    Hi,

    I have some news. Puzzled by the problematic entries in the registry I tried to learn a bit more about them and why I could not delete them neither even access their permissions tab.

    First I did try Registry DeleteEx but no success.

    Then I did found about SubInACL to reset the registry permissions (similar -I guess- to what Tweaking.com tool did), I launched and it 'restored' some hundreds of entries' permissions, but in the log I saw that it had problems as well in the same registry keys (all the {numbers&letters} as shown in my previous screenshot, except the one that dalchina also has in his registry, which I can access with no problem). For reference, I followed this procedure: https://www.youtube.com/watch?v=stykuu7kT_4

    Then I learnt that these problems could come from keys with 'null' values inside. It seems that 'null' values could not be set by user, but by failed install or uninstall processes (that makes sense for me, in my case), and in another topic/forum they suggested to use RegDelNull which would id the keys with null values and could delete them. So, I followed the procedure and voilą!, I could delete these keys (for reference, the link is: https://forum.sysinternals.com/regde...opic16958.html)

    Now, I can execute ContextEdit correctly! And this is what it shows to me:

    Click image for larger version. 

Name:	2017-04-01_12-21-35.png 
Views:	12 
Size:	92.9 KB 
ID:	127551

    Note:
    1-dalchina, if you want I can follow your last post comments, instead of resuming it from the ContextEdit one. As you think it is better.

    2-I hope there is no problem putting the link to another forum here. I did just to explain and help anybody that may have the same problem.
      My ComputerSystem Spec

  7.    01 Apr 2017 #17

    And the ShellMenuView & associated registry key:

    Click image for larger version. 

Name:	2017-04-01_12-37-42.png 
Views:	2 
Size:	173.0 KB 
ID:	127554

    EDIT: Showing the same key than in your sshot:

    Click image for larger version. 

Name:	2017-04-01_13-34-23.png 
Views:	1 
Size:	27.3 KB 
ID:	127562
    Last edited by Darkbluesky; 01 Apr 2017 at 06:35.
      My ComputerSystem Spec

  8.    01 Apr 2017 #18

    EDIT: The ContextEdit sshot belongs to launching the program in WIndows95 compatibility mode (I'm sorry, I left it like that when I did test it). Now without compatibility mode it shows this (SysWOW64 folder instead of System32), BUT I see that the fontext.dll points to system32... instead to the version inside the syswow64 folder...I dunno if that's correct though.

    Click image for larger version. 

Name:	2017-04-01_13-12-14.png 
Views:	2 
Size:	111.2 KB 
ID:	127557

    EDIT: By the way, open an elevated cmd windows and running fontview arial.ttf works, but fontview Foliar.ttf gives the same error as double clicking. Arial is installed in the system, but Foliar.ttf not.
    Last edited by Darkbluesky; 01 Apr 2017 at 06:47.
      My ComputerSystem Spec

  9.    01 Apr 2017 #19

    Hi, good work and initiative on the registry entries.

    Certainly there's a difference with yours using Syswow64. What difference that makes I've no idea. However, the obvious thing to try is changing that to System32.

    You should export the registry key first as a backup.

    You've two functional things to check
    1. The context entry for Preview
    (Remember to check in Shellmenuview it's not disabled e.g. rt click properties)
    2. Double clicking a ttf file.

    Oh, my comment a while back about fontview.exe not running as expected was wrong- I'd not formatted the ttf file name correctly. So
    %SystemRoot%\System32\fontview.exe bobcat.ttf
    works- including from a non-elevated command prompt.
      My ComputerSystem Spec

  10.    01 Apr 2017 #20

    And I guess it works even if bobcat.ttf is not installed in the OS, isn't?

    I have changed from syswow64 to system32, but no luck, keeps failing. The only thing changed is that using ContextEdit I did set 'preview' as default, then in the context menu of the ttf it appears first 'Vista previa' (aka Preview) and in bold, then 'Imprimir' (aka Print) below, in normal text. But they both fail when clicking on them

    Just to test, I associated ttf to notepad, then double clicking it open it in notepad (garbage characters of course), then associating back to fontview and it keeps failing. This is driving me mad...
      My ComputerSystem Spec


 
Page 2 of 3 FirstFirst 123 LastLast

Related Threads
I've got Indesign packaged files with their fonts from a client. As I usualy use Mac I double clucked on helvetica font file to start instalation. Option that came up was 'open with' so I chose Illustrator and Indesign as I was planing to use it...
If I remember correctly, the scaling issues with non-high-DPI-aware Windows applications being displayed as "blurry" were fixed in 1511 update (or around that time). My laptop has been set for 200% scaling and everything was working perfectly since...
it saids is ethernet unidentified network? no internet access sharing option is off. i try restarting the pc:( it use to work fine until the update bridging network cable
I have tried clear type, doing the reinstallation of the font packages, but none of them worked and I still have blurry font in games and it makes it hard to read. IF anyone can upload their font folders I would appreciate it. Because Mine are...
Font Change after Install in General Support
I am a CAD drafter. After install of Win. 10, All of my saved font styles were reverted to standard. I REALLY need a fix for this. I am currently working on about 6 projects and every page is incorrectly set up now. PLEASE HELP ASAP!!!!!!!!
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 00:38.
Find Us