Windows 10: Unable to remove a file Solved

Page 1 of 2 12 LastLast
  1.    26 Mar 2017 #1

    Unable to remove a file


    Hi there,
    I have noticed that during backups that one of my files can't be removed.
    It's actually an old short cut and when I right click on it I only get two options, "Print" and "Send to".
    When I hit delete, I get the error "source path too long"...."the source file name(s) are larger than is supported by the file system".
    The file name is 206 characters.
    Any ideas please?
    Thanks
    Paul
      My ComputerSystem Spec

  2.    26 Mar 2017 #2

    Hi, you need to reduce the path length. There are many references and solutions posted on the internet. Essentially try renaming elements of the path so the total path + file name is < 255.

    Here's just one:
    How to fix Path Too Long and File Name is Too Long errors in Windows 2016 - YouTube

    You can also use 3rd party tools to help e.g.
    7-zip:
    "Source Path Too Long": How to Delete, Rename or Move these files/ folders in Windows | Easy Tipz
    Robocopy:
    Clint Boessen's Blog: How to Delete Files which exceed 255 Characters Without 3rd Party Tools
      My ComputerSystem Spec

  3.    26 Mar 2017 #3

    Ok will try that but note that as far as I can tell, the name is only 206 long.
    Just saw that the path is included in the number and that would definitely make it over 255.
    Last edited by stevenson53; 26 Mar 2017 at 06:22.
      My ComputerSystem Spec

  4.    26 Mar 2017 #4

    It's the total path name size - that's all the folders + file name- that matters.
      My ComputerSystem Spec

  5.    26 Mar 2017 #5

    Thanks again dalchina and will have a go tomorrow now.
      My ComputerSystem Spec

  6.    26 Mar 2017 #6

    Hi Dalchina,
    Well that was a very easy fix! Just reduced the folder names to a single letter each and the shortcut deleted straight away.
    Thanks, again!
    Cheers
    Paul
      My ComputerSystem Spec

  7.    27 Mar 2017 #7

    Good. Seems sad we still need a workaround to deal with such things.
      My ComputerSystem Spec

  •    03 Apr 2017 #8

    Hi Dalchina,
    (sorry maybe I should have started a new thread)
    I have just found another folder with sub folders that I can't remove. I think it was an empty windows(old) folder.
    I have reduced the length of the path and that didn't work.
    The error says:
    "Could not find this item"
    "This is no longer located at C:\users\paul\desktop"
    "Verify the items location and try again"
    I have tried a few options from searches but not luck.
    I can cut and paste it from one drive to the other no problem which is why it's on the desktop.
    Please let me know if I should start a new thread.
    Thanks
    Paul
      My ComputerSystem Spec

  •    04 Apr 2017 #9

    Delete Windows.old Folder in Windows 10 - Windows 10 Installation Upgrade Tutorials

    If that's the Windows.old you're referring to.

    That would exist if you've done an upgrade to 1607 recently, or an in-place upgrade repair install. Otherwise it would automatically be deleted by Windows - 10 days after a 1607 upgrade.
      My ComputerSystem Spec

  •    04 Apr 2017 #10

    Yes I think it's an old Windows folder but from last year when I had a rebuild but it didn't delete automatically and I recall the folder was called windows(old) or something like that. I tried to empty the contents and then the folders but that just left a set of empty folders (8) that I can't get rid of.
    I just tried to transfer the folder set to a portable hard drive and it copied all folders but the last in the sequence call "shellext". It left the full folder set on my desktop but I could delete it on the portable drive.
    They are not doing any harm but it annoys me that I can't delete them.
    I also had a windows upgrade folder but I got rid of that by uninstalling the program windows upgrade assistant.
    Thoughts please?
      My ComputerSystem Spec


  •  
    Page 1 of 2 12 LastLast

    Related Threads
    **CAUTION THIS PERSON IS NOT THE BEST AT SPELLING OR GRAMMAR** Okay so I have a file on my desktop and can not remove it. I have already tried the general ways to remove it.. like dragging it to the recycle bin and right clicking the file and...
    Solved Unable to remove Window.old in General Support
    Tonight, I thought I might as well get rid of the Windows.old and the Windows10upgrade. First, I used Revo Uninstaller to take out Windows10Upgrade. When it came up to uninstall, I thought no, I'll do this later. So hitting the X up in the right...
    Unable to remove ethernet connection in Network and Sharing
    66470
    As a long time Mac user, I've recently acquired a Surface Book. As I'm in the UK, I use English (UK) as my display language, but the keyboard is US (the computer was purchased in the US). All this seems logical and I had the system working for a...
    After not being able to open links from Steam or Skype using Chrome, I tried to remove the program associations for Chrome. However, it appears that I cannot unselect boxes currently selected. http://i.imgur.com/wNS1nmf.png This bug also...
    Our Sites
    Site Links
    About Us
    Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

    © Designer Media Ltd
    All times are GMT -5. The time now is 21:42.
    Find Us