Windows 10: Missing Shared DLLs

  1. Posts : 480
    Windows 10 Home x64, V1709 (16299.64)
       20 Mar 2017 #1

    Missing Shared DLLs

    Long story short, new Windows 10 Desktop PC first time to boot up and accepted all the defaults. Problem was an installed free 30 day AV was only partially configured and in 48 hours I'd been infested with quite a host off unwanted things. Everything cleaned up, new AV software screwed down tight and I have a healthy machine now. Runs well, and I'm not having any performance or reliability problems.

    OK, I'm new to CCLeaner. After running it on my registry, it returns a series of Missing Shared DLLs. Checking each one individually and they are ALL present, just not in the indicated registry path CCLeaner is showing. I've done everything I can think of "testing" and as far as I can tell all is working like it should.

    My question is: Since they're not where indicated, there should be no problem having CCleaner fix the registry entries? Right? I'm in uncharted waters here.

    Thanks for your time and attention.
      My ComputersSystem Spec

  2.    20 Mar 2017 #2

    CWGilley said: View Post
    My question is: Since they're not where indicated, there should be no problem having CCleaner fix the registry entries? Right?
    Probably. Or you could ignore them.

    The best case anyone ever makes for CCleaner registry cleaning is "I've been running it for years and it hasn't broken anything yet". There is no tangible benefit to be gained.

    If your Missing Shared DLL are from .NET then Windows will put back the registry keys you delete anyway.

    It will probably not do any damage to delete them if you want to but I would not bother as the best case scenario is nothing gets broken. There is no upside.
      My ComputerSystem Spec

  3. Posts : 480
    Windows 10 Home x64, V1709 (16299.64)
    Thread Starter
       20 Mar 2017 #3

    You pretty sum up my reluctance to "fix" it. And yes they are all in the C:\Windows\Microsoft.NET\Framework\ sub-folders.

    Appreciate your input.
      My ComputersSystem Spec

  4. Posts : 3,922
    Win10 Home and Pro, Win10 Insider Preview, Win7 Home, Linux Mint
       20 Mar 2017 #4

    Many of the .NET items found by CCleaner [formerly named Crap Cleaner] will be for early versions such as 1.5, safe to remove.

    I have found a couple of instances where the browser couldn't get to a Web page and cleaning the Registry returned the capability so it can have a benefit, especially when nothing else seems to work.
      My ComputerSystem Spec

  5. Posts : 480
    Windows 10 Home x64, V1709 (16299.64)
    Thread Starter
       20 Mar 2017 #5

    These all appear to be in a new folder created 03/14/2017. Didn't check/compare the individual file dates. This is the kind of thing that works on me. Not knowing for sure what precipitated this is going to make me wonder for a long time.

    Also a list of ActiveX/COM Issues too that I need to figure out too.

    Thanks for the comments.
      My ComputersSystem Spec

  6. Posts : 480
    Windows 10 Home x64, V1709 (16299.64)
    Thread Starter
       20 Mar 2017 #6

    AH HA! A little more digging and the new folder is date/time stamped when I ran the last cumulative update. I've found my culprit.

    Still don't know if I'm going to do anything about the registry errors.
      My ComputersSystem Spec

  7.    20 Mar 2017 #7

    CCleaner lets you back them up first and then delete, if you're paranoid. But I trust CCleaner registry cleanup to the point that I rarely do that any more unless I recognize the entry and reason.
      My ComputerSystem Spec

  8.    20 Mar 2017 #8

    What free AV product did you get? I'm curious. And, almost any product can be set to quarantine rather than delete, giving you the option of returning known good material back into play.
      My ComputerSystem Spec

  9. Posts : 480
    Windows 10 Home x64, V1709 (16299.64)
    Thread Starter
       21 Mar 2017 #9

    LOL, paranoia is a good word for me in this. Being new to Win 10, I've got a lot to learn. I did perform a back-up when I started this process. I've cleaned up the entries, and after restarts, there's been no problems. So far anyway.

    The free trial AV was McAfee. Turned out two options C: and Images (I think that's them, I've slept since then) should have been enabled. Only C: was enabled.
      My ComputersSystem Spec


Related Threads
Cannot see my shared pc on network in Network and Sharing
Hello, i have a pc running windows 10 Home and i chose a name for this pc and entered the network workgroup name and restarted the pc... Now i have about 8-9 pcs running on windows 7 in this network...i can see all the networked pcs on my windows...
Dual Boot W10 + W8.1 installs using 2 SSDs. Any thoughts on why there are less partitions on SSD install #2? SSD 1 W10 (installed first) C Drive: - Recovery - System - Reserved - Primary SSD 2 W8.1 (installed last)
So, all of a sudden virtualbox seems to think all my system DLLs are unsigned. Is there any way to re-sign the DLLs? Tried sfc /scannow, no help.
Shared Drive Credentials in General Support
I've been experimenting with setting up an old PC (running 10) as a NAS, and I've created a few shared drives with specific ones allowing access to specific users. Most of the shared drives will accept my login info, which is the exact same on my...
From one of my Windows 10 machines I am unable to access the shared folders on the other. The troubleshooter says "One or more network protocols are missing on this computer" and "Windows Sockets registry entries required for network connectivity...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 17:57.
Find Us