Windows 10: Problem EFI partition Solved


  1. Posts : 2
    Windows 10 Home 64
       19 Feb 2017 #1

    Problem EFI partition


    So I just bought a new PC that came without an SSD. I placed one in it and installed the OS on it. I have two other drives on the system as well. The 2TB HDD that came with the PC and a 1TB external HDD connected through USB. I'm trying to clear the 2TB completely to use for backing up the C: drive and the external disk but there's an EFI partition that I cannot get rid of. Even using diskpart "delete partition override" or "clean" both fail. It's just bugging me because it is sitting right between two unallocated sections,causing a split in the available space on the drive. An image of this in disk management is attached.
    Attached Thumbnails Attached Thumbnails tmp_30346-20170219_203352-1908945088.jpg  
      My ComputerSystem Spec

  2.    19 Feb 2017 #2

    When you installed Windows 10 to the SSD, you still had the HDD connected as drive 0 and the UEFI firmware set to boot from it. Therefore, Windows used the EFI System partition on Drive 0 as the "system" partition that the computer boots from. What you should have done is connected the SSD to SATA port 1, left all other drives disconnected, install Windows 10, then connect the HDDs to SATA ports 2 and 3 and any DVD drives to port 4+.

    Notice this in step 2 of our tutorial for installing Windows 10:
    Windows 10 - Clean Install

    2. Temporarily disconnect all non OS hard drives until Windows installation has finished. This is to avoid Windows Setup from installing files on other hard drives by mistake.
      My ComputerSystem Spec


  3. Posts : 2
    Windows 10 Home 64
    Thread Starter
       20 Feb 2017 #3

    So I assume that I need to reinstall with the hdd disconnected? Wouldn't be a big deal if so since it's only been a few hours with the only thing I have done is update Windows.
      My ComputerSystem Spec

  4.    20 Feb 2017 #4

    Inexplix said: View Post
    So I assume that I need to reinstall with the hdd disconnected? Wouldn't be a big deal if so since it's only been a few hours with the only thing I have done is update Windows.
    Yes, and physically connect the SSD to the lowest numbered SATA port.
      My ComputerSystem Spec


 

Related Threads
Basically what I was doing is simply creating another partition for my hard drive, using Disk Management. The next thing I know: the program crashes completely, I just kill it with task manager. Then I restart a few hours later, and this is what I...
Partition table problem with Windows update in Installation and Upgrade
I've been trying to upgrade (not a fresh install) a Gateway desktop from Win7 to Win10 for weeks now, but the stumbling block is that SP1 is required, but I don't have it. I've been told that I can upgrade without SP1 using a DVD with the win10 iso...
Partition problem in Installation and Upgrade
hi; I purchased a used laptop with win 7 installed on a 300Gb hdd. I downloaded the win10 installation program and successfully installed 10. I tried repartitioning the hdd and foolishly deleted some necessary partitions. The installation...
I did a clean install on a new SSD that I had previously formatted and neglected to delete the partition ending up without a MSR partition. I've already installed lots of applications so starting over would not be something that I'd want to do. What...
Solved Recovery Partition (or lack of it) problem in Installation and Upgrade
Another day, another system. The one I asked about the other day where I deleted the Recovery Partition I fixed by running an in-place install. This one hasn't created the partition :( History - upgrade from Windows 7 Ultimate, Start Button not...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 06:49.
Find Us