Windows 10: A REGISTRY mystery - reg file doesn't import properly

Page 2 of 3 FirstFirst 123 LastLast
  1.    17 Feb 2017 #11

    Amended: Repetier Host a 3D printer program created the registry material...RegEdit did the exporting...
    I have no answer why RegEdit cannot accurately import its own previous export.
    I'm been in listening mode since this post, to learn from those who know far more than I
    Last edited by RolandJS; 23 Feb 2017 at 10:51.
      My ComputerSystem Spec

  2.    17 Feb 2017 #12

    The original keys were generated by Repetier. I have xfered these keys between my computers in the past without an issue. I don't believe the program changed RE this. The file I uploaded was a reg file that regedit created. Viewing the reg file with notepad showed the LF characters.
    Maybe it is something with notepad. I will redo it using ultraedit.
      My ComputerSystem Spec

  3.    17 Feb 2017 #13

    OK, I just exported the Repetier key with all the sub-keys. I then deleted one subkey in the registry and imported the reg file without opening it. All the gcode entries except the gcodeScript#name are missing from the subkey that I deleted. The rest of the entries are there.
      My ComputerSystem Spec


  4. Posts : 3,151
    10.5 Home 1803 x64
       18 Feb 2017 #14

    I have used reg, Kyhi has fixed, and all entries imported just fine. Try to use bat instead.


    Attached Thumbnails Attached Thumbnails capture_02182017_132420.jpg  
    A REGISTRY mystery - reg file doesn't import properly Attached Files
      My ComputerSystem Spec


  5. Posts : 1,981
    Windows 3.1 to Windows 10
       18 Feb 2017 #15

    Attachment 121731 here is your corrected reg file..

    I believe he had WORDWRAP enabled in notepad

    or now after reading the ( last page )which I failed to read..
    It may of been the program he used did not like spaces / or semi-colons

    Just a little FYI:
    Qoutes " " are wrapped around commands that have spaces...
    Otherwise the command breaks at the space..

    Example
    Cmd C:\New Folder > is seen as C:\New
    Cmd "C:\New Folder" > is seen a C:\New Folder

    Thus the give away hint in the first post = quotes all over the place
    Thus being read as several single lines of unknown code
    rather than a single line of code
      My ComputerSystem Spec

  6.    18 Feb 2017 #16

    @Kyhi
    thx, but if I export the key with regedit, delete the key in the registry, then clk the .reg file and import it, I have changed nothing in the .reg file that regedit (a MS program) created. Based on what I saw in notepad previously, I figured there was a problem with those lines, but MS created them, so who am I to question MS...........
    So this obviously is a newly created bug from GOD MS, since sometime in the past it worked fine.
      My ComputerSystem Spec


  7. Posts : 1,981
    Windows 3.1 to Windows 10
       18 Feb 2017 #17

    it's fixed now in the reg file...
    Enjoy!!
      My ComputerSystem Spec

  •    23 Feb 2017 #18

    well, this issue isn't resolved and the link to the "fixed" file doesn't work.
    The registry names that do not import contain CR CR LF at the end of each line in the value
    The value in the program that created the entry looks like this

    G1 Z5 ; lower bed
    G1 X50 Y260 f5000 ; move to back left
    G28 Z0 ; test Z0

    That is one value for a script name with CRs & LFs

    The reg file contains this:
    Click image for larger version. 

Name:	code.PNG 
Views:	20 
Size:	12.7 KB 
ID:	122429

    So the 0d 00 0d 00 0a 00 is terminating the " and since that makes it invalid the entry is dropped on import.
    So how does the program create it in the first place?
    and just eliminating those CR LF is not going to recreate what is in the program.
      My ComputerSystem Spec


  • Posts : 4,494
    Win10 Home and Pro, Win10 Insider Preview, Win7 Home, Linux Mint
       23 Feb 2017 #19

    Just to commiserate a bit, I was 'taught' early in my computing days to never use a word processor program such as Word, Wordpad, WordPerfect, WordPro, etc., to edit such files as the Registry or for programming such as .exe files as there's always hidden coding in the documents but to always use a Text Editor such as Notepad. I haven't tried yet with Notepad++.
      My ComputerSystem Spec


  • Posts : 3,151
    10.5 Home 1803 x64
       23 Feb 2017 #20

    I think the question is, what is software do you have registered to open reg?

    I have exported a long line, it exported cut by slashes, but it imports OK.
    In wordpad, it has added spaces, but even altered, it imports just fine.
    So it is most likely you have something messed up with reg classes.
    Attached Thumbnails Attached Thumbnails capture_02232017_093607.jpg  
      My ComputerSystem Spec


  •  
    Page 2 of 3 FirstFirst 123 LastLast

    Related Threads
    Mystery drive in File Explorer in Network and Sharing
    I have a "mystery drive" in the This PC section of File Explorer. It's called EZ and is mapped as the Z: drive. I am baffled by what this is and how it got there. It is *not* something I have installed, at least knowingly. When I click on it to see...
    Read more: Mystery file in preview build hints at Windows 10 subscriptions | ZDNet
    Brink, this one is another issue that you may already have a solution for on hand. I "Think" I have done it like this before in windows? XP? Not recently for sure. This will be for Windows 10 X64. I need a way to export a specific printer...
    I recenty migrated to Windows 10 from XP. Years ago, I made a batch file, ping.bat, to test my Internet connection and DNS server: ping 98.139.183.24 ping yahoo.com ping nytimes.com pause It works fine in XP, but when I run it in...
    Hi, here is my problem. I exported a key (ieshims) to document folder. I made corrections using Notepad++ to some paths and saved it. I imported the key back and everything went fine. The problem is that when I go back to look at my...
    Our Sites
    Site Links
    About Us
    Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

    Designer Media Ltd
    All times are GMT -5. The time now is 10:21.
    Find Us