Windows 10: Folder deletion impossible even with full permissions, Win10, SSD

  1.    12 Feb 2017 #1

    Folder deletion impossible even with full permissions, Win10, SSD


    Hello

    I'm having difficulty deleting files and folders on an SSD in Windows 10. The SSD is used for games, and most of the data is a Steam folder. The problem with file removal is worsened as the Steam folder is mostly a modded Skyrim installation, which requires frequent changes to the file system and makes safe booting - which i have used to remove a directory - a real pain. Even managing to delete the files leaves empty folders, which are treated as mods by the mod manager.

    I am the only user of the PC. There is only one account - the original admin account. The Windows 10 install is an upgraded Win7 registration, but is a fresh install from a Windows 10 USB stick. Despite this, there is a Windows.old folder on C: containing 1 file, igdkmd64.sys, presumably put there when I installed the onboard graphics to allow a dual display setup.

    I have switched the UAC to minimum - to no avail. I have edited the folder properties of the Skyrim folders, and the SSD as a whole, to allow permissions. Admin already had full permissions. I allowed full permissions for Authenticated Users, upon which Win10 spent a minute editing all the files on the drive - to no avail. I allowed full permissions for all users, upon which Win10 spent a minutes editing all the files on the drive - to no avail. I changed the ownership of the SSD from SYSTEM to my user name, both of which had full permissions - to no avail. I used a Take Ownership reg edit I researched on the internet to run a Take Ownership cmd from the right click menu - to no avail. I've tried running a take ownership command supplied in another thread on this forum. The commands were all confirmed happily by the dos session - to no avail.

    Every time I try to delete a folder the message "You'll need to provide administrator permission to delete this folder" appears; a click of the [Shield]Continue button gives the message "You need permission to perform this action - You require permission from THEPC\MyName to make changes to this folder".

    I am that person. That person there, the only one who has ever used the computer, using the only account on it, with full permissions.
      My ComputerSystem Spec

  2.    12 Feb 2017 #2

    I always find it easier to remove such folders and files using a live Windows/Linux distribution and booting up from a DVD/USB with it enables you to delete what you need. Of course the usual precautions apply such as a restore point or better still a system image taken before attempting to do it
      My ComputerSystem Spec

  3.    13 Feb 2017 #3

    Thanks for the response.

    That's a good tip for sporadic use, and good practice generally.

    It seems to be a permissions issue with the root Steam install. Modifying the permissions through advanced propertioes and icalc both worked but were soon reverted. Running Steam as admin only made it complain. I have removed the Steam install, reinstalled to a folder on a different drive to be kept empty and moved all the installed games to Library folders. Hopefully this will avoid the problem.

    Unfortunately in a modded Steam game installation file moves and deletions are required more often than tidying saves which can be and usually are kept elsewhere.
      My ComputerSystem Spec


 

Related Threads
When trying to rename, copy or delete certain files or folders, I keep getting the annoying "You need administrator permission" prompt. I then click the button and it's done. But it's totally annoying and it seems so random because those files are...
I recently bought a new Acer PC with Windows 10. The PC is just for me. There is only one account on it and I am not planning and creating any other accounts. I was pretty sure I am the administrator of the PC, but whenever I try to delete a...
Account Unknown(S-1-5-21-1345748419-2493160549-2943627078-1000) has full permissions in the "Advanced Security Settings" for my own user account on my Win 10 Pro 64-bit PC. What is it? Is this normal? If I go to C:\Users\ , it lists four...
On build 10586 I noticed a new Desktop Icon: 'desktop' - solid yellow icon. No need for that on the desktop so I put it in the Recycle Bin and to my amazement a popup appeared - "This folder is too big to recycle, do you want to permanently delete...
Found the problem. :) While you are still listed as the owner of each subfolder in the OneDrive folder, some subfolders no longer have inherited permissions enabled. If you Enable inheritance and OK for each affected subfolder in the OneDrive...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 01:31.
Find Us