Page 3 of 4 FirstFirst 1234 LastLast
  1.    09 Feb 2017 #21
    Join Date : Jul 2016
    Posts : 91
    Win 10 Pro x64
    Thread Starter

    Ran Tweaking.com's Windows repair program again the right way, but no improvement (plus, even unchecking file associations it still changed a bunch and left me with some reset permissions that have to be changed).

    Here's the Task Mgr screenshot in idle you requested and it shows something very not normal I hadn't realized is going on: Windows Explorer (explorer.exe) is running hot. Normally (last I paid attention was with 1511), it idles at 1-2%. I took that shot about two minutes after start up, with no Apps running but Task Mgr (apps show up top). As I write, it's nearing 15 minutes and it's still running the same way. Perhaps that's the clue we've been looking for to understand what's going on with the icons and why XYplorer sometimes goes not responding. I've added a System Explorer screenshot (~2350 handles). I also just turned off and disabled Windows Search, which I didn't realize had been reenabled, but that's not changing anything with explorer. I did run ESET and Trend Micro's scanners and they came up with nothing except a couple false positive PUPs.


    Click image for larger version. 

Name:	Windows Task Mgr two minutes after start up.JPG 
Views:	4 
Size:	147.3 KB 
ID:	120467 Click image for larger version. 

Name:	System Explorer with explorer.exe running high.JPG 
Views:	3 
Size:	250.0 KB 
ID:	120468
    Last edited by highstream; 09 Feb 2017 at 03:29.
      My ComputerSystem Spec
  2.    09 Feb 2017 #22
    Join Date : Jan 2015
    UK, Midlands
    Posts : 9,880
    Win 10 Pro (1703)

    Mm, if consistent, that's odd.

    1. Please also try to get a screenshot like that just after you've clicked a desktop shortcut as I described previously - I don't know if that will tell us more, but it's (relatively) easy to do although you may have to try a couple of times because of timing.

    2. Download and run Sysinternals Procmon (free). This captures all activity, and can filter (technically complex) the result.
    Here I'm hoping that since explorer is the dominant process, that capture will give some idea what its doing.
    Post a screenshot of anything interesting in what's captured.

    You can try that in both idle and after clicking a shortcut.
    In the latter case note the exact time you click the shortcut, so you know where to start looking in the captured result.

    Note: the capture is LONG, so spend a while looking through. It may or may not help.

    3. Now it's time to check at a basic level.
    For reference, boot to safe mode, and check near 0 CPU use.

    4. Now use msconfig (which you can set up in Safe Mode) to do a clean boot.
    Clean Boot - Perform in Windows 10 to Troubleshoot Software Conflicts
    (1st part)

    Please post a screenshot of the task man.

    Please use the numbers above in your reply to make it easier to follow - thanks.

    Note: you can organise the display- put highest CPU use at top by clicking the CPU tab.
      My ComputerSystem Spec
  3.    09 Feb 2017 #23
    Join Date : Jul 2016
    Posts : 91
    Win 10 Pro x64
    Thread Starter

    I did have a screenshot after clicking on Any Video Converter and it was exactly the same as what you see. To check if that was causing it, I rebooted, and clearly it's not the click but something else. Don't know if you saw my edits, but I added System Explorer screenshot, turned off and disabled Windows Search and mentioned having run ESET and Trend Micro's scanners in the last 48 hours.
      My ComputerSystem Spec
  4.    09 Feb 2017 #24
    Join Date : Jul 2016
    Posts : 91
    Win 10 Pro x64
    Thread Starter

    In ProcMon, what am I looking for? For example, there are a ton of Buffer Overflows but I don't know if that's important, since they are not under explorer.exe. With Explorer.exe, there are Successes, Name Not Found, a Cancel here or there and some File Locked With. Don't know what to make of any of that.
      My ComputerSystem Spec
  5.    09 Feb 2017 #25
    Join Date : Jan 2015
    UK, Midlands
    Posts : 9,880
    Win 10 Pro (1703)

    Procmon.. it depends if anything stands out. If not, move on to the other steps. Obviously the information is there, accessing it is another matter, unfortunately.

    I understand you to have noticed there's no change in explorer CPU use before and after clicking a shortcut, so we're down to why that CPU use is occurring.

    A clean boot and comparison with Safe mode allows the possibility of a process of elimination of cause- assuming you can reach a point where explorer is NOT using so much CPU time.
      My ComputerSystem Spec
  6.    09 Feb 2017 #26
    Join Date : Jul 2016
    Posts : 91
    Win 10 Pro x64
    Thread Starter

    Safe Mode = no problem with explorer.exe, very low cpu (still no desktop icons)

    Will try to get to clean boot over the weekend.

    User 2 (account you suggested I set up for test):
    - first click is responding on desktop icons (contrary to what I saw the other day)
    - explorer.exe (14.8%, 17.3%) and mailwasher (15.2%) running high cpu (screenshot)


    Click image for larger version. 

Name:	System Explorer in user 2.JPG 
Views:	4 
Size:	185.7 KB 
ID:	120470
      My ComputerSystem Spec
  7.    09 Feb 2017 #27
    Join Date : Jul 2016
    Posts : 91
    Win 10 Pro x64
    Thread Starter

    Really strange thing happened. I just went into Safe Mode to see if right clicking on the desktop and checking View Icons would free things up, but found I didn't have to. They were all there lined up in nice rows. Where did that come from?? And single click worked instantly on all! Then I checked Task Manager for explorer.exe and guess what... (in the screenshot there were actually two Windows Explorer entries, both running low). So here's your Safe Mode shot in idle. Not sure what to make of it all. Unfortunately, it didn't change the normal mode response.

    Click image for larger version. 

Name:	Safe Mode Win Explorer Desktop folder 2-9-17.JPG 
Views:	1 
Size:	138.5 KB 
ID:	120570
      My ComputerSystem Spec
  8.    10 Feb 2017 #28
    Join Date : Jan 2015
    UK, Midlands
    Posts : 9,880
    Win 10 Pro (1703)

    Ok, so proceed to clean boot. That Safe Mode (magically?) works suggests you have a chance of finding the culprit by elimination.
      My ComputerSystem Spec
  9.    11 Feb 2017 #29
    Join Date : Jul 2016
    Posts : 91
    Win 10 Pro x64
    Thread Starter

    Before the idea was to run the clean boot in Safe Mode, but since the icons work there now, is there a purpose to that? Instead, I've just run a clean boot using Brink's tutorial for selective startup in normal mode, and one click on icons gets the same results as before, i.e., 1-2 minutes to open. I'm not sure where to go from here short of a clean install except maybe running an in-place repair install and/or tweaking.com again and seeing if the second time is the charm.
      My ComputerSystem Spec
  10.    11 Feb 2017 #30
    Join Date : Jan 2015
    UK, Midlands
    Posts : 9,880
    Win 10 Pro (1703)

    Ok, so now you know something. Windows is not fundamentally damaged (Safe Mode ok).
    Your clean boot => the same problem.

    Now a clean boot is NOT the same thing as Safe Mode. For example, your graphics driver is running.
    And if you inspect what is running, you will find a number of of other services as well.
    So what you can do is reduce what starts up further.
    Inspect the msconfig options, and see what other options there are.
    Examine your running processes and services. What is not Windows- can you disable these?
    Have you disabled context menu options?

    Before the idea was to set up and run the clean boot in Safe Mode
    No, as stated that's a misconception. 'run the clean boot in Safe Mode' doesn't mean anything.
    You can set up a clean boot whilst in Safe mode, then restart.
    Or you can set up the clean boot whilst in Normal mode, then restart.
    Same result.

    Now the other major clue was explorer's CPU use. So keep an eye on that.

    Sysinternals Autoruns (run as admin) lets you disable many other things.

    Take due care- best to create a restore point or even a disk image before making all these changes, so you can get back to where you were easily and definitively.
      My ComputerSystem Spec

 
Page 3 of 4 FirstFirst 1234 LastLast


Similar Threads
Thread Forum
Can't delete Desktop Icons with a right click
Instead, I have to use the Delete button. Is this normal?
General Support
Difficulty opening Programs from shortcuts within folders on Desktop
I'm having a problem with a new build on Win10 Home, 64bit. I try to keep the desktop tidy by having folders for different types of programs and utilities. When I try to open some programs from within those folders - usually those needing UAC...
General Support
Taskbar: Can't right click app icons & can't left click system icons
Hi, After doing a lot of tweaking, I've came across a very weird problem at taskbar. When I right click pinned apps on taskbar nothing happens. But left click works. When I left click system icons like volume and network, nothing happens....
General Support
Linux VM's - User Desktop Icons for running programs
Hi there Sometimes you might like to have a desktop icon (like Windows) for running an application instead of a generic one. For example - This works on a KDE desktop but similar for GNOME etc - say you want to run an application you've...
Virtualization
Explorer: not responding when opening folder with exe file
I have a folder full of *.exe files. When I navigate to the folder to read its content (files listed in "tile" mode), Explorer hangs for a minute or two displaying in the title bar "not responding". Eventually, the files are displayed but it is a...
General Support
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 10:20.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums