Windows 10: The Directory Name Is Invalid

  1.    04 Feb 2017 #1

    The Directory Name Is Invalid


    OK, here's my situation. I have a Western Digital (WD) My Passport Ultra external USB hard drive. I use this as a media drive on my WD TV Live Plus media player. For some unknown reason, the media player will sometimes corrupt files on the My Passport drive. The net effect is that a file is somehow changed into a directory.

    The problem is when I attempted to delete/remove the corrupted file/directory, I receive a 'The directory name is invalid.' error.

    I've tried the following:

    • Run chkdsk /f; no errors found.
    • Run WD Drive Utilities diagnostics; no errors found.
    • Checked dir /x looking for an 8.3 filename; no luck.
    • Taken ownership of the directory; no luck.
    • Tried a few file unlocker utilities; no luck (not reported as locked and delete fails).
    • Even tried an NTFS disk editor; no luck.

    I've spent the last three hours googling a solution. Nothing!

    Anyone else ever encountered something similar and found a solution?
      My ComputerSystem Spec

  2.    04 Feb 2017 #2

    Well, I just tried IObit Unlocker and that successfully deleted the directory.

    I am still interested in knowing about any native solution that does not required a third-party utility...
      My ComputerSystem Spec


  3. Posts : 1,683
    Windows 10 x86 14383 Insider Pro and Core 10240
       04 Feb 2017 #3

    It used to happen in the old MSDOS days regularly - file and directory names would get corrupted and you had to do tricks with wildcard characters to get them deleted.

    Like with a file or folder that had one readable x in the 7th position of the 8 character filename, and the rest gibberish - sometimes it worked.
    ren *x?.* ffffffx?.*
    del f*.*
    rmdir or rd f*.* /s
    deltree f*.*
    etc.
      My ComputersSystem Spec


 

Related Threads
Solved the handle is invalid HELP! in User Accounts and Family Safety
Hey guys, So i just started up my laptop and i tried logging in but it won't let me. I type in my password perfectly, but it keeps giving the handle is invalid message. What is this. So basicly i can't get into my computer. Can't pass the login...
I am running Windows 10. I had a USB stick in the computer. After an update-restart, I ejected the USB drive, and now my computer is slow after idling and there was a nagging message that asserts itself. First it was something about what do you...
Long story short - Upgraded from windows 7 to windows 10 a few months ago, decided to backup Windows 7. Came to the realization that I wan't gonna downgrade and Windows.old was taking up substantial space so I decided to delete it via Disk Cleanup....
Invalid MS-DOS in General Support
Ive just done an update, and i can no longer delete anything or move anything on my desktop. So if i wanted to tidy up my desktop and put shortcuts into a folder i can no longer do this. I can no longer delete anything either. The message that comes...
I just upgraded to windows 10 from 7 a couple of weeks ago. Things were great until I tried to install a game. I put the DVD in the drive and got the following error. D:\ The directory name is invalid. I can see the DVD drive in explorer and...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 04:00.
Find Us