Windows 10: Issues with ejecting USB

  1.    01 Jul 2015 #1

    Issues with ejecting USB


    Is it just me or is there a known bug involving ejecting USB drives?

    Typically in 7 or 8 if I plug in my USB then transfer a file and close the window, I can easily eject it with no problems. With Windows 10 it seems like it holds the USB hostage for 5 to 10 minutes. Thoughts?
      My ComputerSystem Spec

  2.    01 Jul 2015 #2

    Which build are you using? Some have reported this problem in earlier builds, but the latest they have said it is fixed.. 10159.
      My ComputerSystem Spec

  3.    01 Jul 2015 #3

    10130, I may have taken myself off the fast ring, Im not sure. Was this reported in 10130?
      My ComputerSystem Spec


  4. Posts : 8,291
    Windows 10 Professional
       01 Jul 2015 #4

    gator said: View Post
    Is it just me or is there a known bug involving ejecting USB drives?

    Typically in 7 or 8 if I plug in my USB then transfer a file and close the window, I can easily eject it with no problems. With Windows 10 it seems like it holds the USB hostage for 5 to 10 minutes. Thoughts?
    Try adding an exclusion for it in Settings►Update & security►Windows Defender►Exclusions►Add an exclusion►Exclude a folder
      My ComputersSystem Spec


  5. Posts : 1,467
    W7 Ultimate SP1 (64 bit), LM 18.1 MATE (64 bit), W10IP VM, W10 Home
       02 Jul 2015 #5

    Have you tried restarting explorer.exe?

    Every earlier version of Windows I've used has had issues with USB HDDs.

    When I first installed W7 there were no problems.
    Around the time of SP1, I started to get the occasional useless "can't eject USB" message.
    Nowadays it happens around 50% of the time I use a USB HDD.

    I've never had any problems with Flash sticks though.

    I expect W10 to follow the same pattern.
    Currently I've had no problems in W10, but I expect they will start happening after a few hundred MB of updates have been installed.

    The Linux distros I've used have never displayed this behaviour (CentOS, Fedora, Linux Mint, OpenSUSE & Ubuntu).
      My ComputerSystem Spec


 

Related Threads
Anyway to fix USB issues? in General Support
Hey ho. Running build 10135 and playing with it - got my USB tethering working bueno (with Jolla, Äijänpäivänjärvi build, sailfishOS) yesterday until I was playing around with Asus AI suite. Everything worked until I removed AI suite and rebooted -...
SYSPREP issues in Installation and Upgrade
Hi, I am wondering if anyone is experiencing the same issues i am, after (apparently successfully) SYSPREPping a Windows 10 (clean) installation, and restarting it? BTW: i have used a very simple autoanswer file: <?xml version="1.0"...
Two Wi-Fi issues on separate pc's in Network and Sharing
On one laptop...Dell Latitude E6520, the Wi-Fi will just drop. I can go to networks and reconnect each time but it drops sporadically. On a custom built pc with a Wi-Fi adapter, it does not drop at all, but after a reboot, Windows does not...
Windows 10 issues in General Support
I have tried to share feedback but having a hard time finding a place I can had to go back to windows 7 cause I keep having the same problem and windows repair and safe mode plus the goto simpler graphics mode (forget what it is called) can't...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 03:59.
Find Us