Windows 10: Explorer.exe takes 13% of processor - constantly restarts

  1.    31 Jan 2017 #1

    Explorer.exe takes 13% of processor - constantly restarts


    I have one machine running 15014 (for some reason it hasn't downloaded 15019 yet even though I'm on the Fast Ring) - the machine has shown this problem since 15002. Essentially explorer.exe uses 13% of the processor all the time. If I right-click on the desktop, explorer.exe restarts itself. If I click or right click on the task bar, the same thing happens.

    I have done the following:

    sfc /scannow - dozens of times
    dism /online /cleanup-image /analyzecomponentstore
    dism /online /cleanup-image /checkhealth
    dism /online /cleanup-image /restorehealth
    dism /online /cleanup-image /restorehealth source:wim - and pointed it to a USB drive
    I have mounted an ISO image and used the source function.
    I have mounted a wim image and used the source function.
    I have used the Image Heath cmd that I downloaded from this forum.

    I've created a new user account - it didn't help.
    I've enabled the built-in administrator account - it didn't help.
    I've booted in safe mode and tried repairing things - it didn't help.
    I've booted into WinPE and tried repairing things - it didn't help.
    I've disabled all non-MS services - it didn't help.

    I have downloaded Tweaking.com's repair tool and repaired everything multiple times.

    I've run the troubleshooters for Windows Update, Windows Store Apps, BITS, etc.

    I've done the trick of turning off windows update, bits and crypto, renaming softwaredistribution, etc.

    I have done an in-place re-install, twice.
    I have done a install where I only kept my files, and allowed it to delete my apps.

    Nothing has fixed the problem.

    The event viewer shows a bunch of 7024, 7043, 10010's, 10016's, 7023's.

    I've systematically tried every repair for every error and nothing has fixed them.


    Is there anything else I can do, other than completely wiping the drive and starting over?

    Thanks,

    Paul
      My ComputerSystem Spec

  2.    31 Jan 2017 #2

    Hi, try a clean boot and see if there's any difference.

    If not, try using shellexview (free) and then ccleaner to disable context menu entries and compare.
    (Make sure to hide all MS entries when using shellexview).
    Note: Shellexview does not seem to expose all context menu entries theses days.

    If you still have problems, examine what explorer is doing and interacting with e.g. using
    process explorer (free)
    or failing that
    sysinternals procmon

    (Both now from MS)
      My ComputerSystem Spec

  3.    31 Jan 2017 #3

    I should have added those to my list of things I've tried.

    I have the SysInternals suite installed and have run both procmon and proc explorer and couldn't find anything unusual.

    I've already done clean boots and it made no difference.
      My ComputerSystem Spec

  4.    31 Jan 2017 #4

    Context menu? - shellexview/ccleaner?
      My ComputerSystem Spec

  5.    31 Jan 2017 #5

    After doing an install where I only kept my documents, not apps, there's nothing installed in the context menus. But, yes I've disabled everything previously in the context menus.

    In Process Monitor I don't see any "bad" errors, just lots of "NAME NOT FOUND" or "FILE LOCKED WITH ONLY READERS". I see a few RuntimeBroker.exe with INVALID PARAMETER, but that's about it.

    I was always under the impression that an in-place upgrade would fix most problems but it doesn't seem to be the case.
      My ComputerSystem Spec

  6.    31 Jan 2017 #6

    It won't fix some user profile corruption problems, and may well not fix issues related to installed programs of course.

    Is there any difference if you create a new user (for test purposes)?

    Beyond that, you are using insider builds, so hopefully someone using similar builds may be able to comment.
      My ComputerSystem Spec

  7.    02 Feb 2017 #7

    Creating a new user profile didn't fix anything either.

    It just seems very strange that doing a re-install and not keeping any apps still didn't fix the issue. Though since build 15002 I've had problems on more than one machine. Even my Surface Book is having trouble with things like, all my start screen tiles being dark & having exclamation marks on them.

    It's one thing if I'd just downloaded and installed some new software and the problem appeared, but when problems appear after a Windows update, it's frustrating.
      My ComputerSystem Spec

  8.    02 Feb 2017 #8

    What happens in Safe Mode? (Think graphics issues for example?)

    The thing is you're in risk territory with beta builds, which are likely to give rise to problems.
    You can check your event log, (Event viewer), and Reliability History, but these may not give diagnostic info.

    You might get more info using sysinternals procmon, if you've the patience.

    I'd suggest comparing notes with people with the same build - and try reverting to an older build. If that worked, suggests some obscure problem with the build if you're simply running Windows + drivers.

    Check News here:
    Announcing Windows 10 Insider Preview Build 15014 for PC and Mobile

    - Later threads on the newer builds of course.
      My ComputerSystem Spec


 

Related Threads
Hi, I've just updated to win10 build 1607 (or whatever the latest number is) this morning and when I completed the update, I noticed the task bar constantly refreshing every 3-5 seconds. I believe the issue to be related to Daemon tools pro which...
Hi, I've just updated to win10 build 1607 (or whatever the latest number is) this morning and when I completed the update, I noticed the task bar constantly refreshing every 3-5 seconds. I believe the issue to be related to Daemon tools pro which...
Hello All Before I start the question I dont have a problem with Acer as I have still got more that 3 acer products I use plus had many laptops in the past that have always been great bits of kit. That said I bought my last Acer from Amozon...
Windows Explorer takes up 40-50% CPU usage in Performance & Maintenance
Hello, I have this problem where after some hours of use (~3, for example) the windows explorer takes up 40-50% of the CPU causing major performance loss. I do not know what is causing this problem, as it does have to do with my activity, since...
I am having a problem with file explorer constantly crashing. If I click on the icon in the toolbar, file explorer will open, it will say "working on it," but then it crashes, the screen flashes, and it goes back to the desktop. If I try to open...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 01:21.
Find Us