Windows 10: "You don't have permission to save in this location" Solved


  1. Posts : 103
    Microsoft Windows 10 Pro 64-bit
       14 Jan 2017 #1

    "You don't have permission to save in this location"


    I installed a photo editing program program (DxO Filmpack 3) which I had previously used successfully on a different computer that also runs Windows 10. But on my new computer, whenever I try to save a photo to a folder on my Desktop using the program, I get the following error message:

    Click image for larger version. 

Name:	Error 1.jpg 
Views:	21 
Size:	23.2 KB 
ID:	117176

    When I click "Yes", it takes me to my Photos folder, but I get the same error message when trying to save there.

    After a quick Google search, I had found a page that stated that the way to fix this sort of problem is to edit the security permissions of the drive that you are having trouble with (drive C in my case). Here is the page in question:

    You don’t have permission to save in this location. Contact the - Microsoft Community

    So, I tried to edit the security permissions for my C drive according to the instructions on the page. I was given a warning (I could be misremembering, but think it said something like "change the permissions back to normal immediately if you know them to be incorrect"), and then, after that, I got this error message:

    Click image for larger version. 

Name:	Capture.jpg 
Views:	1 
Size:	57.0 KB 
ID:	117177

    Now, I'm afraid that I may have changed the security permissions on my drive in a dangerous way.

    1. How do I tell if my security permissions are all correct, and I haven't messed anything up? I want to make sure I haven't put my system in any danger, and would like to know how to make sure that all of my permission settings are safe. For instance, is there any Windows scan that can check whether all of my permission settings are optimal?

    2. DxO still has the same problem. On further reflection, I now think that it is not a system-wide problem, as I am able to save files to my Desktop, Photos folder, etc, using other programs (such as XNView and Opera browser) without incident. I've only ever had the problem with DxO. Do you have any idea what could be causing this problem or how to fix it?
    Last edited by hbenthow; 15 Jan 2017 at 02:30.
      My ComputerSystem Spec

  2.    15 Jan 2017 #2

    Hi, Tweaking.com's free cautious repair tool (easy to find) offers permissions repairs.

    Observe the cautionary steps and select only the relevant repairs.

    Note: before making changes to your system, always make sure you have the means to reverse them. We constantly recommend routine use of disk imaging (e.g. Macrium Reflect (free) ) + its boot medium + external storage for images. Many advantages.

    You can also try system restore if you enabled it and have useful restore points. (Note sometimes it fails to restore successfully).
      My ComputerSystem Spec


  3. Posts : 103
    Microsoft Windows 10 Pro 64-bit
    Thread Starter
       15 Jan 2017 #3

    dalchina said: View Post
    Hi, Tweaking.com's free cautious repair tool (easy to find) offers permissions repairs.
    Can it be used to merely check the permissions without actually changing anything?
      My ComputerSystem Spec

  4.    15 Jan 2017 #4

    Not that I know of. FWIW I've just tried exporting an image from DxO Optics Pro to my desktop- no problems.
      My ComputerSystem Spec


  5. Posts : 103
    Microsoft Windows 10 Pro 64-bit
    Thread Starter
       15 Jan 2017 #5

    dalchina said: View Post
    Not that I know of. FWIW I've just tried exporting an image from DxO Optics Pro to my desktop- no problems.
    I might use it if I can't find any other solutions. I'd like to be able to check whether anything is wrong before actually changing anything.
      My ComputerSystem Spec

  6.    15 Jan 2017 #6

    You could

    a. Create a new user for test purposes and compare.

    b. Reinstall.
    c. Do an In-place upgrade repair install.

    Or:

    d. Create a disk image. Use the tool. Using the tool means you have a system restore point.
    If you don't like the result you can revert to your present situation.

    Good luck
      My ComputerSystem Spec


  7. Posts : 103
    Microsoft Windows 10 Pro 64-bit
    Thread Starter
       15 Jan 2017 #7

    It turns out that DxO's attempts to save files was being blocked by the anti-ransomware element of my antivirus program (Bitdefender), as it apparently thought that DxO might be ransomware. That was what was causing the Windows error. I set Bitdefender to allow DxO to save files, and it now works fine.

    I turned on my old computer (which is failing, but can can work for a few minutes at a time), and checked the permissions on the C drive. They are identical to the ones I currently have on my new computer. The error message I got in the second photo I posted in the OP probably means that I fortunately wasn't able to change anything. Thus, everything is probably fine.

    Therefore, I am considering it solved.
    Last edited by hbenthow; 15 Jan 2017 at 18:56.
      My ComputerSystem Spec


 

Related Threads
I just reloaded Win 10 Preview Build 14951. I'm trying to set my default save locations (Settings, System, Storage) but the only two that I can change are Apps and Maps. The others give me error 0x80070005. Is there a registry location I can change...
Hi, In Windows 8.1 (and as far as I can remember in all previous Windows versions) I used to be able to do the following: In Windows Explorer: Open a .jpg file from anywhere in my file system, by right mouse clicking and choosing "edit" After...
Hi, as with many I have upgraded to Windows 10 today and it is going well except for the fact I am unable to save any files or create new ones in the Documents and Pictures folders or any sub-folders within these folders, and I have no idea why it...
I have recently upgraded to Windows 10. I loved the changes, until yesterday. I am signed in as the administrator of my account. I tried to save a simple spreadsheet to Documents in One Drive. I received this message: "You don’t have...
Am so eager to try the Technical Preview that I'm attempting while traveling to download it from Technet to my laptop. No matter where I try to save it to my SSD with 20gb available it generates an error within the Technet page to "Try to save to...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 22:16.
Find Us