Windows 10: Windows 10 "Invalid Value for Registry"opening JPEG

  1.    02 Jan 2017 #1

    Windows 10 "Invalid Value for Registry"opening JPEG


    My Windows 10 won't open JPEGs. I get the error message "Invalid Value for Registry" whenever I attempt to open JPEGs. I have tried virtually every procedure/suggestion to be found with recourse to the google search engine, but thus far I have had no success. Does anyone here know of a foolproof solution to this problem?
      My ComputerSystem Spec

  2.    02 Jan 2017 #2

    What are you trying to view the jpg's with, the Photos app or something else ? What photo viewer programs do you have ? The easy thing to try first is this -
    R-click a jpg/click Open with/Choose another app. In the window that opens, click on the app you want to use, tick Always use this app to open .jpg files/click OK.
    This should reset the default registry settings, if it's corrupted.
      My ComputerSystem Spec

  3.    02 Jan 2017 #3

    I get the "Invalid Value for Registry" error message when I try to open with Microsoft Photos.

    I get the "Remote procedure call failed" error message when I try to open with any other app.

    And I did as you said, i.e., selected a different app for always opening the JPEGs, but this left me with the wrror message "Remote procedure call failed".
      My ComputerSystem Spec

  4.    02 Jan 2017 #4

    There have been issues reported with the Photos app that some find uninstalling and re-installing sometimes fixes or sometimes not. What other program/app did you tick to test ?
    I use this freeware one, as do many members: FastStone Image Viewer 6.1-http://faststone.org/
      My ComputerSystem Spec

  5.    02 Jan 2017 #5

    KVADPhoto+ was the one I used. And I have already un- and re-installed the Microsoft Photos app, but the problem persists,
      My ComputerSystem Spec

  6.    02 Jan 2017 #6

    KVADPhoto+, the Store App or installed program from the developer site ? I see it's targeted at smart phone users. Try the FastStone program, very small and has tons of features, recommended by many Ten members, even if only to test your problem. If FastStone works, you may be having a Store Apps issue. Search troubleshooting in Control Panel and run the diagnostic.

    Click image for larger version. 

Name:	Screenshot_1.jpg 
Views:	1 
Size:	148.9 KB 
ID:	115746
      My ComputerSystem Spec


 

Related Threads
Since updating (1) Windows to 10, (2) Parallels to 12 and (3) the MacOS to 10.12 (Sierra), logging into windows takes about 10 minutes. First the machine gives me a blue screen with the large word "Administrator" (the only user I have, i.e. me) and...
working fine until recently started to fail. No changes that I recall. I can create an image backup, but file backup where I select the folders to backup gets the error. I have set it with and without image backup included.
Hello. I have all updates applied to the Windows 10 Professional x64 bit machine. Started Windows 10 this morning and tried to open a JPEG file, i.e., double click any.jpg. Windows 10 comes back with, "Class not registered". Cleaned all the...
Apparently it is my turn: Photos app no longer launches (clicking on the icon does nothing; no error report in Event Log). Trying to double-click image files associated with Photos results in "Invalid Value for Registry" message box. No explanation...
2890028900 help I had a virus and was forced to do a system restore to 5/august/2015 and when I tried to open .jpg file and "Invalid value for registry" happened I tried some fixes in PowerShell and Photos app and Store app weren't invisible anymore...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 08:20.
Find Us