Page 1 of 2 12 LastLast
  1.    23 Dec 2016 #1
    Join Date : Sep 2014
    Warsaw, Poland
    Posts : 62
    Win 10 Pro 64-bit (Creators 1703)

    Put "&" in the shorcut name?


    Here's an interesting (I guess) thing - is there any way to put the "&" symbol into the file/app shortcut name?
    Windows automatically converts it to the keyboard shortcut indicator and I'd like to avoid that.

    At the moment whenever the shortcut says e.g. "Tag & Rename" I'm getting "Tag Rename" instead...
      My ComputerSystem Spec
  2.    23 Dec 2016 #2
    Join Date : Oct 2016
    Caledon, Ontario, Canada
    Posts : 3,971
    Windows 10 Pro Build 1703

    Add an extra space. Tagspacespace&spacespaceRename
      My ComputerSystem Spec
  3.    23 Dec 2016 #3
    Join Date : Sep 2014
    Warsaw, Poland
    Posts : 62
    Win 10 Pro 64-bit (Creators 1703)
    Thread Starter

    I'm afraid it looks like this :
    Click image for larger version. 

Name:	tr.jpg 
Views:	31 
Size:	2.4 KB 
ID:	114561
      My ComputerSystem Spec
  4.    23 Dec 2016 #4
    Join Date : Aug 2014
    Forever West
    Posts : 3,922
    Win10 Home and Pro, Win10 Insider Preview, Win7 Home, Linux Mint

    Unfortunately there's just some characters that Windows simply doesn't allow in file names and it goes back a long way into the days of DOS/Disk Operating System. There's usually an error message when trying to use one of those characters and frequently shows the unallowed ones. Linux and macOS [formerly MAC OS X] operating systems have different rules, I was able to add the & to a shortcut [alias] name on my macOS Sierra desktop.
      My ComputerSystem Spec
  5.    23 Dec 2016 #5
    Join Date : Aug 2016
    S/E England
    Posts : 4,488
    10 Home x64 (1709) (10 Pro on 2nd pc)

    Quote Originally Posted by mikolajek View Post
    At the moment whenever the shortcut says e.g. "Tag & Rename" I'm getting "Tag Rename" instead...
    How (and where) are you creating these shortcuts? I'm at a loss trying to reproduce your problem.
    Click image for larger version. 

Name:	ampersand_links.PNG 
Views:	24 
Size:	104.1 KB 
ID:	114566
    Your example appears to be pinned on the taskbar. How did you put it there? What is it a link to? A folder, and executable or 'something else'?
      My ComputersSystem Spec
  6.    23 Dec 2016 #6
    Join Date : Sep 2014
    Warsaw, Poland
    Posts : 62
    Win 10 Pro 64-bit (Creators 1703)
    Thread Starter

    Quote Originally Posted by Bree View Post
    Your example appears to be pinned on the taskbar. How did you put it there? What is it a link to? A folder, and executable or 'something else'?
    Yes, you're right - well, almost... I'm using True Launch Bar which is effectively another taskbar toolbar/folder and the problem occurs there as I don't really keep any shortcuts on my desktop.
      My ComputerSystem Spec
  7.    23 Dec 2016 #7
    Join Date : Aug 2014
    Forever West
    Posts : 3,922
    Win10 Home and Pro, Win10 Insider Preview, Win7 Home, Linux Mint

    I have a shortcut on my Win10 desktop that says Roxio Easy CD & DVD Burning but it was created and placed there by the installation routine for the program.
      My ComputerSystem Spec
  8.    23 Dec 2016 #8
    Join Date : Oct 2013
    A Finnish expat in Germany
    Posts : 12,949
    Windows 10 Pro

    I have no issues in using & in file and shortcut names anywhere on my system.
      My ComputerSystem Spec
  9.    23 Dec 2016 #9
    Join Date : Aug 2016
    S/E England
    Posts : 4,488
    10 Home x64 (1709) (10 Pro on 2nd pc)

    Quote Originally Posted by mikolajek View Post
    Yes, you're right - well, almost... I'm using True Launch Bar which is effectively another taskbar toolbar/folder and the problem occurs there as I don't really keep any shortcuts on my desktop.
    Ah! then it must be True Launch Bar that's interpreting & as the place marker for the keyboard shortcut character, not Windows 10 itself. That explains why I can't reproduce the effect.

    There's a similar problem in using % inside a batch file. It's a control character and cannot be used as a character in its own right. The way it works there is that one % is seen as a control, but if you type %% it says the control you want is to use % as a character.

    Try putting && in the link where you want a single & to appear.
      My ComputersSystem Spec
  10.    23 Dec 2016 #10
    Join Date : Sep 2014
    Warsaw, Poland
    Posts : 62
    Win 10 Pro 64-bit (Creators 1703)
    Thread Starter

    Quote Originally Posted by Bree View Post
    Try putting && in the link where you want a single & to appear.
    Wow, this one has done the job as expected!!! Many thanks for your help!
      My ComputerSystem Spec

 
Page 1 of 2 12 LastLast


Similar Threads
Thread Forum
"Boot Device Not Found" - but hitting "Enter" afterward PC boots fine
I had to buy a new (SSD) HD and had trouble booting from a disc until I enabled Legacy Mode and disabled Secure Boot in BIOS. Now whenever I boot up I get a "No Boot Device Found" message until I hit "Enter" at which point i'm allowed entry into my...
General Support
Solved Unable to create or save files in "Documents" and "Pictures" folders
Hi, as with many I have upgraded to Windows 10 today and it is going well except for the fact I am unable to save any files or create new ones in the Documents and Pictures folders or any sub-folders within these folders, and I have no idea why it...
General Support
Remove "Paste shortcut" and "Undo delete" from right-click desktop men
Greetings. So, I would like to remove "Paste shortcut" and "Undo delete" from the right-click desktop menu. Wasn't able to locate either in the registry.
Customization
Solved delete "saved password" and "form data" from microsoft edge manually
Hello how can I delete "saved password" and "form data" of microsoft edge manually ?! after too much search in google .... I trid to delete some value of the following registry address HKEY_CURRENT_USER\SOFTWARE\Classes\Local...
Browsers and Email
Solved "Error (0x800F081F) - DISM Unable to find source" & "sfc /scannow"
I have upgraded 5 machines and clean installed 3 machines. Experienced an issue with one machine with continuous corruption problems After the 3rd attempt I discovered that even with a Clean Install of Win 10 I get unrepairable errors - Sorry...
General Support
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 01:58.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums