Win 10 Pro - Constant Admin access denied and problems!

  1. Posts : 10
    Win 10 pro x64, Multiple Win 7 Pro x64

    Win 10 Pro - Constant Admin access denied and problems!

    Win 10 Problems
    I’m having Constant Access is denied (and related problems….
    I have googled/searched a Lot for this problem, and find most solutions suggest use “Run as Administrator” or change(manhandle ACL/premissions). Yes this sometimes provides a work around, but leads to an ultimately UnManagable nightmare ( and an Unreliable machine)!

    Quickly, I am an active (and certified) Ms .Net platform developer, currently developing/supporting production, mission critical application systems with/from Win 7 pro stations.
    I’m trying to set up a Win 10 pro workstation that can pick up and reliably carry the Load.
    I have all the hardware and software necessary to get the job done
    I need (and have tried) to set up a workstation with following:
    Win10 Pro x64, Office 2016 pro+, IIS, Sql Server 2016 and multiple versions or Visual Studio.
    My Win 7 machines carry this basic Ms developer machine load Perfectly!!!
    But I can’t get Win 10 Pro to even get started to run these products successfully…
    ( I have all these products, legally, and can/do clean load and install them repetitively until I either get it right or positively prove Win 10 is a Bust! So far it aint goin well…

    So far I can get good clean installs of Win 10 pro & seen/active the LAN .
    IIS will install as a feature and starts iisstart.htm – OK – but when I try to add a simple index.htm above it the problems start, access denied! (and im logged in as a user being a member of admins group). I can work around this with notepad, run as administrator, and /or start changing permissions and ACL’s – but that’s just the start of problems (and an unacceptable hack fix). Continuing on I also can get Visual studio installed and working in a crippled way. Can’t create, debug or publish(deploy) from or to a virtual web (without manhandling the file system {that’s not the way it’s supposed to work!}). Crippling ACL hacks and run as admin can get a task to work but then just creates another problem – like manually move/copy a file to a virtual web and then IIS can’t open the web cause I created the file(page.aspx) originally and IIS gets access denied!!! Crippled every where I turn…
    The last straw, I installed SQL Server 2016, the product installed successfully, I can login as sa, all basics function, but I can’t login with my Windows acct (winauthencation) even being in the admins group or as running Sql Mgt Studio as run as Admin ( and yes SQl was installed with Mixed sql and Win authorization), and I just can't get around this!!!

    Sorry for the long spew, just some background for my questions, so on with the questions…
    1. Has anybody here set up a smooth, good running Win 10 pro x64 as a full Ms Dev/Test/Deployment machine? (and hands on experience with current dev products? I say current products cause I’ve been advised by Ms to first get current products sql 16, vs2015 running. [old vs08,10,12 & sql 08,12 might have compatibility probs)
    2. Is there a (single) Security profile, Setting, or Local Policy I can add, change, or create that will make members of the Admin group truly an Admin much as it is in Win7 and Win Server systems?
    In Win 10, a member of the Admin group is simply not and Admin! – cause ya have to Run as Admin even when the ACL of the resource explicitly allows full access to the Admin group – and sometime even that doesn’t work!
    3. Is anybody else having these constant Problems?
    Any good advice here…

    Thanks in Advance, Bob
    Last edited by RPLewis; 08 Dec 2016 at 12:02.
      My Computer

  2. storageman's Avatar
    Posts : 1,020
    Windows 10 Pro 20H2 19042.572


    I can't address your problems directly, but more information is needed. Can you describe your hardware configuration and tell us the Windows 10 Version and OS Build your running. This will certainly help. There are a lot of talented people here and I'm sure we will get it resolved.
      My Computers

  3. Posts : 10
    Win 10 pro x64, Multiple Win 7 Pro x64
    Thread Starter

    Ya mean all of em! Have tried Win 10 pro three times now for software development/prod support work now, none successfully.
    1. Brand New Dell I7-xxxx 32G mem, 1T HHD, warranty with service tag, hardware techs came and got it - never saw it again.
    2. I5-2500, Asus P8H67-M LE, 16G, Intel 720 SSD & 1T HHD, all integrated, vid, usb3, GigLan, etc... (recoverable back to Win 7)
    3. FX-4300, Asys A5A78L-M + USB3, 8G mem, Intel SSD, Asus vid(?) Asus vid, integrated GigLan & sound...

    All 3 machines haven't lasted 2 weeks, all die with black screen and blinkin single white blinking cursor, sometimes with a message to insert boot media ... (and I put the Win 10 install cd, and try to recover or repair and get the ole Drive with Windows installed is Locked, Unlock the Drive and Try again...) . None were ever recoverable with Win 10 recovery/repair/reset procedure . I say my nice #2 Intel I5 recovered, but that wasn't with win 10, it was with a bootable Win 7 recovery and a Win7 backup image copy on a Synology NAS DiskStation on the LAN... Ah Yes, Win 7 is not only rock solid for dev/debug/support work, but Proven Reliable per Win 7 BackUp and Recovery! (by Me!) . So problems don't seam to be hardware related, and for our discussion lets use my product verification/acceptance box, #3 the AMD Fx-4300 Asus box. It's a proven rock solid Win 7 machine (actually quite quick with the Intel SSD) for both dev work and User Demonstration/Acceptance testing. If what we develop( Web and Desktop Apps) wont run on this corp mid-range workstation clients and customers machine usually wont like it either...

    Oops, gotta go for now, I'll get back... (I actually have succeeded in installing products ( Win 10 pro, Feature IIS, SqlServer 2016, VS2015ProU3), and they try to function a little - I actually created C# .Net Wep App, built, debugged and published! However after publishing once, I Was Done - After publishing and closing VS, I couldn't even load the solution again - getting a rude alert popup box "You are not authorized to Access ......"
    More later...
      My Computer

  4. Posts : 10
    Win 10 pro x64, Multiple Win 7 Pro x64
    Thread Starter

    Fri Morn 2016/12/16
    Got Win 10 running again with repeated insert boot media and repair/rest/recover & retries. Don't really know exactly what brought it back, but unpluging the WD 1T HDD sometimes brings it back also. Am running a simple machine with 1 Intel SSD, WinVer Version 1607, OS Build 14393.576, Win update says Your device is up to date. Last checked: today, 7:35 AM ( which by the way is not consistent the Update settings Active Hours (7am to 7pm) that should not allow Win updates during active hours {which again only allows a 12hr active schedule(???) - which again is unrealistic for a box that needs to available 24/7/365 !!! - Windows Update needs the ability to be strictly scheduled and selectable...}) Oh, well, I'm keepin notes....

    Right now the box is running WIN 10 pro x64, with IIS, Office, SqlServer & VS2015, All Installed.
    As mentioned all the way here I have always had to run everything "as Administer", (even though I an logged with an acct with hat is a member of the Administers group). Goin with the new flow here, I've got a newly created VS .net Web app, built, debugged & tested with the default development web server(IIS express), then advanced the solution/project to IIS with creation a Virtual directory, Published the web app to a File! (only, so I deploy the web anywhere(any machine, any MS IIS host) - and now I'm totally crippled, cant debug on IIS, cant publish again, get Access denied even when "run as Admin"), plus a new popup "You are not Authorized!!!" - I'm just totally Blocked, dead in the water here... (plus there's other stuff, crippling, overly cumbersome, TimeConsuming and just plain Redundantly Repetitive and Unreliable going on with Win 10"s supposedly new security/permissions model).

    These problems start immediately (or become apparent) upon activating the IIS feature. Any developer (worth their salt) will immediately after activating of a feature, Test it! First bring a browser test "localhost" or machine name. (Oops, Edge doesn't see MachineName, gotta use IE, but oh well, later., and more). My Win 10, out the box, does fire up IIS with the default IisStart.htm in inetpub/wwwroot. The next simple test and implementation is to create a simple index.htm in wwwroot which displays a simple Welcome to the Web on ThisMachine!. Right Here!, when accessing wwwroot and attempting to save a simple.htm file ya get slapped with Access is denied! OK, Drill down with FileMgr, (left click for context menu), float over NEW and only Folder selection is Available(Bad indicatior here, your logged acct group as Admin isn't recognized). Right here is where the "run as admin" and/or start changing Permissions(ACL's) madness begins. Simply your logged in context of being and member in the Admin group doesn't apply! And continuing to us run as admin or changing permissions just keeps snowballing till your either blocked (or even worse , now you the Owner of the files you created and Nobody else (including the System or IIS) has permission to even read em!

    Am I missing something, or is this the way Win 10 development is going to be (Constantly run as admin and changing permissions/acl's, and sys, iis and product configs) just to get tasks completed ?

    OK, and another concern I've run into: Win 10 Backup an Recovery...
    This Tues, after I got all products installed, I tried a Backup and Restore:
    From Control Panel, Backup and Restore (Windows 7) , Back up and restore your files screen.
    I set up backup, all users and a system image of system drive(c), and ran it to successful completion.
    With backup files created and verified, I then tried a restore from previous image.
    All started out ok, selected restore from previous image, machine rebooted and the select previous image selection found the most current image just like is should.
    I clicked to start the recovery, the recovery progress bar started progressing for about a minute, Then: whammo...
    "The system image recovery Failed!
    The version does not support this version of the file format."

    What??? Win 10 just created this Backup and Win 10 reading its own backup and format and giving this excuse!
    Failed! Bad News! Win 10 pro, right out the box, cant restore itself - Now that's really, really bad!

    Not only that, box wouldn't start! Who knows, the recovery did start, I saw the disk light activity start blinking for a while. Evidently the recovery started , failed, leavin the disk unusable... OK... Drop in the ole Win 10 and clean install start over again....

    My Windows 10 Product and Acceptance tests aren't doin too well.
    This stuff is right out the box, Am I doin something wrong?
    (Yes the current test machine is a little weak, but its only common sense not to use a good mission critical box when experience has shone Win 10 can Whack em with No recovery!)
      My Computer


  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 19:58.
Find Us

Windows 10 Forums