Computer wouldn't boot after cloning to SSD

  1. NavyLCDR's Avatar
    Posts : 15,583
    Windows 10 Pro
       #1

    Computer wouldn't boot after cloning to SSD


    I've seen a lot of threads of people who have migrated to an SSD and the SSD would not boot, and here's the solution I found:

    Upgraded my daughter's laptop to SSD. I wanted to clean up the partition layout and resize some partitions (especially since the SSD was 20GB smaller than the HDD). I used MiniTool Partition Wizard to copy over the partitions I wanted to keep, one at time, put them in the order I wanted on the SSD, and resize them. Installed the SSD in the laptop, and at boot I got the Windows startup repair BSOD. Hmmm....the EFI System partition was the first partition I copied over.

    Booted into Kyhi's Recovery Tools, ran Macrium Reflect, selected the fix Windows startup problems utility. It found the Windows installation on the SSD, but no system partition to write the boot files to. Ran AEOMI Partition Wizard and the first partition was the FAT32 EFI partition, but it was not marked as an EFI System partition - it looked like just any other partition. The partition ID that made it an EFI System partition did not copy over.

    The fix: open a command prompt with admin rights. Run:
    diskpart
    select disc 0 (select the SSD you need to work on. List disc if you are not sure)
    select part 1 (select the FAT32 partition that is supposed to be EFI System. List part if you are not sure)
    setid=C12A7328-F81F-11D2-BA4B-00A0C93EC93B override
    exit
    exit

    Then just to be sure, I ran Macrium Reflect Fix Windows starup problems again just to be sure, this time it showed the EFI System partition, wrote the boot files to it, and computer booted just fine from SSD.
      My Computer

  2. Cliff S's Avatar
    Posts : 25,649
    Win10 Pro, Win10 Pro N, Win10 Home, Windows 8.1 Pro, Ubuntu
       #2

    nice one.
      My Computers

  3. TrustMe's Avatar
    Posts : 324
    Windows 10 Pro
       #3

    Thank you, I'm going to save this.
      My Computer

  4. linw's Avatar
    Posts : 1,915
    win 10 Insider
       #4

    Yep, thanks, got it saved.

    Had a no boot after clone to SSD once, but, in that case, Macrium fixed it. Got lucky!!
      My Computers


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 20:39.
Find Us




Windows 10 Forums