I am trying to find a way to debug and resolve a Sleep/No-wake issue with Satellite Laptop, Haswell i7, fresh new Windows 10 x64 home ed on a new SSD. My guess is the issue is most likely being caused by either/both a USB wireless mouse [tried 2 different ones: GE and Logitech] or an External HDD. The user, a bookkeeper, walks away to attend to other duties, returns to find it comatose. Only way to get working again is the hard way.

I have worked on it too much and have resolved all the typical device driver issues. I see nothing remarkable either in the Events logs or Device manager, though I have not taken the labor to open EVERY SINGLE sub-device in the system to look at logs of its individual installation. In my shop, I did not test with the same/similar USB devices the customer uses, but never saw it go into the coma. I have fetched it while it was in the coma-state, and it told no tales: it wouldn't awaken; a single-press of the power button had no effect, the 'power on' led was lit steady. The usb wireless mouse device was in. There were errors in the log tracking the unexpected power fail, but nothing related to devices that I could see. I have tried it in various power scenarios but the result is the same regardless [unless we prevent sleep altogether - which is not a good solution]

If the USB mouse transceiver is left in its port, it typically will be inoperable when the system restarts. It must be removed, reinserted to get coherent. What is that telling us?
please help. Microsoft can't solve it. been there

one thing that bugs me: Under USB devices in Dev Manager, the top-listed hub device is set with a generic Microsoft Driver, circa 2006. I would expect to see an Intel Composite 3.0 Device there, of current vintage driver. Removing it goes nowhere - it will load the generic driver and no update is found suitable. ????
Am I grasping straws?

thank you for collective wisdom