Rotation Lock / Rotation Sensor Not Working (Lenovo Yoga 2-in-1)

Page 1 of 2 12 LastLast

  1. Posts : 12
    Windows 10 Pro

    Rotation Lock / Rotation Sensor Not Working (Lenovo Yoga 2-in-1)

    I've got a Lenovo Yoga 700-11ISK that I've reformatted and reinstalled with Windows 10 Pro. I've been unable to get the rotation lock / rotation sensor working, which seems to be a very common problem. However, none of the common solutions has seemed to fix the issue. Below is a detailed list of everything I’ve learned. Note that whenever I refer to "Tent Mode," I mean the device's screen is physically rotated (‘folded back’) more than 180 degrees. Don’t confuse this with "Tablet mode," the software-based switch available in the Win10 Action Center; when I say "Tent Mode," I refer only to *physically* folding back the screen.

    First, let's establish how it behaves on the factory image (i.e. the copy of Windows that comes with the system). These are the desired/expected behaviors, which I’m listing point-by-point for comparison to how it mis-behaves on my fresh Windows 10 Pro install:

    1) In Tent Mode, "Rotation Lock" is available in the Action Center; otherwise, it's greyed.
    2) In Tent Mode, "Lock rotation of this display" is available in System->Display settings; otherwise it's greyed.
    3) In Tent Mode, the “Allow the screen to auto-rotate” checkbox in the Display control panel is available; otherwise it’s greyed.
    4) In Tent Mode, the physical rotation lock button works; pressing it shows a “auto rotate on/off” OSD. Otherwise the button has no effect.
    5) In Tent Mode, registry key HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\AutoRotation has Enable=1; otherwise, Enable=0. Even if you set it manually, it gets overridden to this value on reboot, etc.
    6) In Device Manager, detecting changes to and from Tent Mode seems to be handled by "Human Interface Devices/GPIO Laptop or Slate Indicator Driver" & "System Devices/Intel® Serial IO GPIO Host Controller - INT344B." Removing either stops it from detecting Tent Mode changes.
    7) In Device Manager, detecting actual screen rotation (when in Tent Mode) seems to be handled by "Human Interface Devices/I2C HID Device" (9D60), "Sensors/HID Sensor Collection v2," and "System devices/Intel® Serial IO I2C Host Controller - 9D60." Disabling any of these 3 disables rotation-sensing / rotation lock options (when in Tent Mode).
    8) If you disable the "YMC" service, rotation lock becomes available in 1-4 above, regardless of Tent Mode (aka it's always available).
    9) If you disable the "SensrSvc" service, aka "Sensor Monitoring Service," all of the rotation lock options 1-4 above become unavailable/greyed, regardless of Tent Mode (aka it’s always unavailable).

    Again, it's only Tent Mode (aka physical rotation of the screen) that makes rotation lock work; toggling "Tablet Mode" in the Action Center or answering “Yes” when prompted to switch to Tablet Mode is irrelevant.

    Now for direct comparison, here’s how it behaves on my fresh-installed copy of Windows 10 pro:
    1-5) Regardless of Tent Mode, these options are all greyed, the button has no effect, and the registry key has Enable=0.
    6-7) Each of these drivers are installed & working in the Device manager, and are of the same date & version as in the factory image.
    8) With the YMC service running, moving the laptop into Tent Mode it will prompt you to change to Tablet Mode – indicating that its “Tent Mode” sensor is functioning. If you stop the “YMC” service, rotation lock remains unavailable in 1-4. NOTE the difference: on the factory image, stopping YMC makes all the rotation lock options become available; here, they always remain unavailable regardless of this service.
    9) SensrSvc is set to Automatic, and running. Stopping/restarting seems to have no effect.
    10) The 'Sensor List' app (installed from app store) shows the Inclinometer properly reading changes to the system orientation.

    Notice in particular that stopping “SensrSvc” on the factory image essentially makes it behave like my new/problematic system: whereas all the “Rotation Lock” stuff is supposed to be available while the tablet is physically in Tent Mode, it always remains unavailable. However, all the relevant drivers seem to be installed and of the same versions; all the services in question seem to be installed and running; and all the sensors are provably “sensing.” There are 2 sensors involved: 1) The one that senses when we switch to Tent Mode and 2) The one that senses screen rotation. I know #1 is working because when YMC is running, Windows prompts to enter Tablet Mode. I know #2 is working because ‘Sensor List’ can read orientations from the Inclinometer.

    I’ve spent a crazy amount of time on this and seem to be up against a wall. If anyone can tell me how to get this rotation sensor working (aka how I can get the “rotation lock” options in 1-4 not to remain greyed when I enter Tent Mode), I’d be very appreciative.
      My Computer

  2. Posts : 459
    Windows 8&10

    Your detailed description takes a while to get through. But it appears you have tried Tent Mode, which is what I used to make the option active, and it does no good. I remember which I first got this machine, 3 days ago, I decided to not let it switch the screen around and answered lock when asked, but my Unlock does become active in Tent Mode.

    I have quite a few additional drivers on this system I have not seen before. Many of there are for Sensors, so perhaps you just haven't loaded the correct ones yet... sorry I can't help with your specific model. Try turning it on end and see if the button becomes active. It seems like mine appears to go back to the locked mode every time after I select unlock.
      My Computer

  3. Posts : 12
    Windows 10 Pro
    Thread Starter

    Saltgrass said:
    I have quite a few additional drivers on this system I have not seen before. Many of there are for Sensors, so perhaps you just haven't loaded the correct ones yet.
    I've gone through every driver in Device Manager (including with hidden devices shown), which is how I isolated the 5 described above as the ones seemingly tied to the sensors. All are installed & working on my re-install. I've also removed everything available from Add/Removed programs on the factory image; rotation lock remains working. Finally, since both sensors do seem to be functional on my reinstall, it seems to me that a driver can't just be missing - otherwise, the sensors wouldn't be readable at all. At least that's how it seems...

    Saltgrass said:
    Try turning it on end and see if the button becomes active. It seems like mine appears to go back to the locked mode every time after I select unlock.
    Lock/unlock options are never available, regardless of orientation, tent mode, etc (on the Win Pro install).
      My Computer

  4. Posts : 459
    Windows 8&10

    When you look at the Display settings do you have an Orientation option with Landscape and Landscape (flipped) and Portrait and Portrait (flipped) available? I can select those options with the Rotation Lock on but nothing happens.

    Edit: whoops, I was wrong. If I choose another orientation and apply, the screen does change.

    Have you checked the Display Adapter drivers for options and status?
    Last edited by Saltgrass; 16 Nov 2016 at 16:24.
      My Computer

  5. Posts : 12
    Windows 10 Pro
    Thread Starter

    Manual rotation via the display settings & via the keyboard hotkeys (i.e. ctrl+alt+up/down/left/right) does work; the issue is just that auto rotation via the sensor doesn't (and of course, auto rotation lock is always unavailable).
      My Computer

  6. Posts : 459
    Windows 8&10

    If you right click the start button, do you show a Mobility Center on the menu? That seems to have some settings, including Rotate the screen.. I suppose it may be a Dell utility.
      My Computer

  7. Posts : 12
    Windows 10 Pro
    Thread Starter

    Yeah, there's Mobility Center. Again though, that's manual rotation - not rotation lock or autorotation based on the inclinometer...
      My Computer

  8. Posts : 459
    Windows 8&10

    I obviously don't have much info which could help. But maybe a found a place in the Registry which seems to change values when I enable or disable autorotation. If you want to mess with the registry, on my system with autorotation enabled, the SlateEnable had a value of 0. If I turned if off, it have a value of 1.

    I suppose you could say enabling SlateEnable turned off Autorotation. Below is the listing which goes with the Registry Key..


    Enable 0
    LastOrientation 0
    SensorPresent 1
    SlateEnable 0

    Good luck with this, considering how many folks are losing their installs after updates, if we can't get the Autorotation back by reinstalling, we are in trouble.
      My Computer

  9. Posts : 12
    Windows 10 Pro
    Thread Starter

    Those are the registry keys mentioned in point #5. All the values matched between the 2 systems (factory image & current image), except for 'Enable,' which behaved as described - but no manual edits fixed the issue.
      My Computer

  10. Posts : 459
    Windows 8&10

    If the SlateEnable setting is 0 and still not working try changing it to 1 to agree with the current setting. Give it some time to see if you can change it back later.

    For all I know, you may have to do some calibration which might be very involved or may just need you moving your system into different orientations so the sensors can self calibrate...

    I have a new drive coming for this system. If I decide to try a clean install, I will let you know what happens. I may do not this immediately so don't expect it too soon, if at all.
      My Computer

Page 1 of 2 12 LastLast

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 01:05.
Find Us

Windows 10 Forums