Windows 10: Help-User Account Control Problems if you develop your own software

  1.    12 Nov 2016 #1

    Help-User Account Control Problems if you develop your own software

    Hi I am quite new to Windows 10 but it has not been a happy experience and has wasted at least 4 days so far.

    Since buying a new Windows 10 computer I have had to turn all UAC off. Otherwise I keep getting pop up task if I want to run it!
    There must be a way to have outside security without these pop ups.
    I have written telescope automation software which are a number of exe files in one folder. Since I am the originator and the administrator why does it keep asking if I want to run the program? (If UAC is on)
    Some of my software cannot see the required files in other directories if they are not set as administrator.
    Never had this problem with Vista or Windows 8?

    Any solutions (apart from reloading Vista from an old machine)

      My ComputerSystem Spec

  2. Posts : 20,251
    Win10 Pro, Win10 Pro N, Win10 Home, Win10 Pro Insider Fast Ring, Windows 8.1 Pro, Ubuntu
       12 Nov 2016 #2
      My ComputersSystem Spec

  3. Posts : 20,251
    Win10 Pro, Win10 Pro N, Win10 Home, Win10 Pro Insider Fast Ring, Windows 8.1 Pro, Ubuntu
       12 Nov 2016 #3

    Sorry I just posted the link and ran a little bit ago, I was busy at the moment, but wanted to make sure to post something that might help you.

    Is that what you were looking for?

    Also there is a developer mode in Windows 10, but I believe(not sure) that's for creating UWP(modern) apps:
    Enable your device for development
    Click image for larger version. 

Name:	image.png 
Views:	1 
Size:	55.3 KB 
ID:	109866
      My ComputersSystem Spec

  4.    12 Nov 2016 #4

    UAC seems to have all sorts of implications?

    I don't use Visual Studio. It will not run on my version of Windows 10.

    I have used a GUI builder tool set from the medical business. Very nice clean apps.
    However, I even had problems with that because Windows had changed some #DEFINES somewhere in the compiled subsystems and now there was a conflict. Color_MenuBar was a conflict. So I have changed it everywhere in my dev environment to Colour_MenuBar -That fixed it.

    I have had problems getting the pop up to ask if I wanted to run my exe files??
    I only have one user account:

    However, Still having to mess about with admin rights of individual exe files because the cannot execute other exe files.
    But some pop ups still happened so turned of all UAC.

    Everything is now running and able to do a complete compile and system build to link with all the hardware and other software servers in the system. But, have to put UAC off!

    Not really good?
      My ComputerSystem Spec

  5. Posts : 20,251
    Win10 Pro, Win10 Pro N, Win10 Home, Win10 Pro Insider Fast Ring, Windows 8.1 Pro, Ubuntu
       12 Nov 2016 #5

    The tutorial link I posted(my first post) doesn't help?

    Oh, wait!
    I just found one here in Ten Forums, I guess the author, @Brink has imported it.
    Check here: Elevated Shortcut without UAC - Create in Windows 10 - Windows 10 Forums


    1. When you open an application file with Run as administrator, you will get a UAC prompt for approval before the app is allowed to run with elevated rights.

      In addition, Windows will not allow elevated apps to run at startup by default.

      If you want to run an app as administrator (elevated) without getting a UAC prompt or at startup, then you can create an elevated task to run the application as a workaround to do so.

      This tutorial will show you how to create a shortcut of an elevated task to run an app as administrator without getting a UAC prompt in Windows 10.

      You must be signed in as an administrator to be able to create and use the elevated shortcut.

      My ComputersSystem Spec

  6.    12 Nov 2016 #6

    Ok I have looked at the other PC that runs another observatory with the same software.
    It is Windows 10 Home 10586 build. This version does not produce Popup asking if I want to run app.
    So what did Microsoft change that messed up the operation of my software?
    PC config looks similar. Local Account login, Administrator.
    My software is not running as administrator.
    Very odd.
      My ComputerSystem Spec

  7. Posts : 20,251
    Win10 Pro, Win10 Pro N, Win10 Home, Win10 Pro Insider Fast Ring, Windows 8.1 Pro, Ubuntu
       13 Nov 2016 #7

    Hi John, I sent one of the other software developers I know, a private message to take a look here,
    maybe he can help, as he understands these things.

    I thought you just needed a way to start the program without the UAC, that's why I linked you to that tutorial(which you have yet to comment on, if it's what you want or not)

    You might want to think of adding the program(and any associated .exe's) to start at boot, and to run from the system tray, that way you will, not need to start it every time.
      My ComputersSystem Spec

  •    13 Nov 2016 #8

    If it works in a previous build, then the app. is not to blame... also strange that the constants were affected by system language.

    My apps however (and I do use VS) do not exhibit that behavior with the latest Windows builds - thus I can't replicate it.
    (yes, I use app manifest to embed privileges - so they automatically run as Admin)
      My ComputerSystem Spec

  •    13 Nov 2016 #9


    I think Microsoft Windows 10 Home version 1607 is so full of problems- I just tried to install my HP Printer..
    I can't and is says Need Administrator Rights?? I have a local administrator log on to this PC?
    I tried loading the disc onto the desktop and running the setup as Administrator......Same problem.
    I have checked my logon about 100 times and it still says ADMINISTRATOR!
      My ComputerSystem Spec


    Related Threads
    Ever since I got the Anniversary Update for Windows 10, more often than not when the User Account Control popup comes up when installing software or whatever, it comes up behind the windows open on my desktop. Since I can't click the windows to...
    User account Control migraine in User Accounts and Family Safety
    After I switched to Win 10 I decided I wanted to turn off my sign in at start up and somehow I went threw netplz and I unclicked something and that's where it got annoying. From then on I have not been able to make any changes to the system...
    I have not found anything like my problem on any forum or thread. In my Administrator Account the Windows Store opens and I can install Apps. I expected those same Apps I just installed to appear in my User Account, they did not. Both my Admin and...
    User Account Control in General Support
    I used to run W7 with a hdd supplemented by a Sandisk 32gb Readycache. It ran automatically on bootup, there was a desktop icon to check up on it. W7 is now running from an ssd and the Sandisk is now with the old 80gb hdd for W10. Every time that...
    How to turn off User Account Control in AntiVirus, Firewalls and System Security
    I am finding it very hard to find all the settings. the PC Settings tab has very little on it. I would love to have my Control Panel back, but the first thing I want is to turn off the useless User Account Control. It does nothing but waste time...
    Our Sites
    Site Links
    About Us
    Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

    Designer Media Ltd
    All times are GMT -5. The time now is 20:01.
    Find Us