Windows 10: Search Indexer Always Resetting Solved

Page 1 of 2 12 LastLast
  1.    03 Nov 2016 #1

    Search Indexer Always Resetting


    Hi, so I noticed that my Search Indexer keeps resetting and starting from scratch. It gets to a very big number of indexed files a few hours later, then resets back to a low number whenever I check it. I went to the Event Viewer and I found what is crashing it:

    The search service has detected corrupted data files in the index {id=4810 - onecoreuap\base\appmodel\search\search\ytrip\common\util\jetutil.cpp (604)}. The service will attempt to automatically correct this problem by rebuilding the index.

    Where is "jetutil.cpp" located at? I want to delete this file. If Windows 10 doesn't like that, then I will to sfc /scannow. Please help me find where this file is located.
      My ComputerSystem Spec

  2.    03 Nov 2016 #2

    Hi, suggest you run
    chkdsk p: \F

    on your drives, where p is an arbitrary drive letter.

    jetutil.cpp isn't on my PC: If you use a search utility such as Ultrasearch (free), let it index, then search ('instant' find as you type) you should find it.

    Freeware tools such as Ultrasearch, Locate32 (which I habitually use) and the better known Everything (I prefer the others) are much less problematic. However Windows search is necessary in some instances, and does index textual content.

    You can also try the search index troubleshooter.
    Windows 10 Search Not Working Fix
    Option 3

    If you search the web for jetutil.cpp there are quite a few references- a quick scan showed nothing helpful - you may like to spend more time on that.
      My ComputerSystem Spec

  3.    03 Nov 2016 #3

    Ok I did: chkdsk p: /F
    Computer restarted and did that process, and restarted again.

    I went to that site you posted, I've already done all these steps previously when I searched the internet on how to fix this. So now I'm just hoping that a few hours later from now, I will check up on the Search Indexer and hope it is no longer indexing files (which means that it has completely with no error).

    But a question to programmers... where is this location at: "
    onecoreuap\base\appmodel\search\search\ytrip\common\util"
    There's no folders on the computer with that directory. This must be somewhere else on the computer. Help me find it so I can exclude this "oncecoreuap" folder from being indexed.

    Thanks
      My ComputerSystem Spec

  4.    03 Nov 2016 #4

    I've indicated how to search for the file- have you tried that? (Unless it's in a folder with special permissions so it can't be accessed normally).

    Make sure you don't have search set to index something it will have trouble with- like the search index?

    Here's how to see chkdsk results after a restart:
    How do I see the results of a CHKDSK that ran on boot? - Ask Leo!
      My ComputerSystem Spec

  5.    03 Nov 2016 #5

    yes i've tried using other programs to find that file, yet that directory doesnt exist anywhere, hence the file doesn't exist. I found a few onecoreuap.dll, and I think that inside the dll is where that file is. Can anyone clarify which onecoreuap.dll I need to delete?
      My ComputerSystem Spec

  6.    03 Nov 2016 #6

    Reading the error message again
    The search service has detected corrupted data files in the index
    - I think it's telling you the search index is corrupted. Not sthg that's being indexed.

    You'll get more info from the event log:

    E.g.
    Error: (09/20/2015 03:45:03 PM) (Source: Windows Search Service) (User: )
    Description: The Windows Search Service is being stopped because there is a problem with the indexer: The catalog is corrupt.


    Details:
    The content index catalog is corrupt. 0xc0041801 (0xc0041801)

    Error: (09/20/2015 03:42:53 PM) (Source: Windows Search Service) (User: )
    Description: The search service has detected corrupted data files in the index {id=4810 - base\appmodel\search\search\ytrip\common\util\jetutil.cpp (203)}. The service will attempt to automatically correct this problem by rebuilding the index.


    Details:
    0x8e5e0210 (0x8e5e0210)

    Error: (09/20/2015 03:42:52 PM) (Source: ESENT) (User: )
    Description: SearchIndexer (5080) Windows: Error -1811 (0xfffff8ed) occurred while opening logfile C:\ProgramData\Microsoft\Search\Data\Applications\Windows\edb007BC.log.

    from
    Problem starting windows 10 - Page 3 - Windows 10 Support
    #33
      My ComputerSystem Spec

  7.    03 Nov 2016 #7

    The reason why it got corrupted and had to delete and reset is because of the corruption in that file. I've seen it many times in the Event Viewer. This .cpp file IS the reason why it's resetting. Can you please only help me find this file?
      My ComputerSystem Spec

  8.    03 Nov 2016 #8

    Look in the example I've quoted. I think you have to look as per that post to identify what's being indexed.

    Look at how they got that info.
      My ComputerSystem Spec

  9.    03 Nov 2016 #9

    I tried looking for that log file in the folder. There isn't any. I tried opening all the other files in Notepad (except for the big edb file, which is the indexed searches file) and I cannot find anything in those files.

    I just hope I can narrow down the location of that one file. I've seen files with that name in
    Windows/syswow, system32 and winsxs. I'm gonna use old school reliable logic (tedious, takes much more time but practically guaranteed) and exclude those locations one-by-one-by-one or so to narrow down the location of that file and I guess exclude the folder that contains that file. =S

    How come no one else is experiencing this? This started happening a few days ago. I haven't downloaded any new apps or installed anything new. It just started happening by itself. Maybe from some Windows Updates?
      My ComputerSystem Spec

  10.    03 Nov 2016 #10

    I found the general location of where this file is; it is located in the WinSxS folder within Windows. I Excluded the WinSxS folder from being Indexed. Now the Search Indexing Options is complete, and not re-/creating the Index like it always was doing. Also, it's useless to have WinSxS indexed anyways; there are no personal files in there that would have a possibility for me to look for them.

    Cool. I nailed it.
      My ComputerSystem Spec


 
Page 1 of 2 12 LastLast

Related Threads
Since the last Win 10 update my Google Toolbar won't list any search suggestions as I type and there is no search history listed. The Google tool bar will allow a search, but after a few searches no search history shows and no "clear search" button...
High processor usage by indexer in Performance & Maintenance
Hello, My computer tends to use a lot of resources for indexing items. I checked under "Indexing Options" and the message "Indexing Complete" will appear. But, the next time I wake my laptop, the process will be highly active again. I have turned...
Microsoft Windows Search Indexer process its eating 10-15% of CPU and I think this is the reason why HDD temperature its always over 122°F (50°C). I have disabled Cortana but no luck, hope someone has a fix for this or I will return to Windows 8.1...
There is a problem resetting your pc in Installation and Upgrade
its almost two days that I'm trying to reset my pc but I am getting an error "There is a problem resetting your pc". The reason why I am resetting are due to browsers (ie, chrome, Mozilla, opera) cant connect thru the internet and skype cant login....
Is there a way to do this in windows 10? Indexer Backoff - Enable or Disable in Windows 7 - Windows 7 Help Forums
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 21:48.
Find Us