Intel RST Service Not Running

  1. andythebeagle's Avatar
    Posts : 9

    Intel RST Service Not Running

    I keep running into this and it is affecting my overall performance. It slows to a crawl at times, mostly when playing videos. Because videos are what I do, it is a problem.

    I've been chasing this for a while and can't find reliable information. Neither Acer or Intel have an answer and Windows support just gives me a blank stare. Quite frequently I will see my CPU maxed out and System Explorer shows performance as a brite red smear. All that has brought me here to bow at the feet of the Win 10 gods. And, help will be deeply appreciated.
      My ComputerSystem Spec

  2. Posts : 169
    Windows 10 Ent, Pro & Home

    Go to Task manager and click more details/startup tab. Disable everything for now. Restart computer. Try running videos, to see if you still have the problem. If the problem is solved, now try turning back on Startup items that you still want to startup, when Windows starts.
    Also, what video card are you running and do you have the latest drivers?
      My ComputerSystem Spec

  3. AddRAM's Avatar
    Posts : 2,573
    Windows 10 Pro x64

    If it still gives you issues, uninstall it, you don`t actually need it.

    As long as you have Intel drivers for your Intel sata ports, you are fine.

    I have done many experiments/tests etc, with and without it over the years.

    Can I uninstall Intel Rapid Storage Technology? |Intel Communities

    What is Intel Rapid Storage Technology? Do I need it? Solved - Windows 7 Help Forums

    Do I need IntelĀ® Rapid Storage Technology Software? - Storage

    IRST driver and Windows 10, is it needed?
      My ComputersSystem Spec


Related Threads
"Print Spooler service isn't running" in Drivers and Hardware
For some reason, my printer doesn't show up in applications such as Microsoft Word or Libre Office, although I'm sure that it's connected properly to the computer because it still lets me scan documents. When I troubleshoot the printer, I get this...
Hi - Having lots of trouble here and very frustrated. On login, I get the message "Failed to Connect to a Windows Service. Windows couldn't connect to the Group Policy Client service. This problem prevents standard users from signing in. As an...
My first new thread and pictures speak louder than words: 31400 Windows Defender is shown both running AND disabled. I have no third-party security or firewall. I am unable to select this service here (msconfig)-(but rightly set as 'Automatic' in...
Solved Weird process running - "Monitor Virutal Wlan Service" in AntiVirus, Firewalls and System Security
I was checking my system configuration and happened across this weird one! 45650 Note the spelling: "Monitor Virutal Wlan Service" - "Virutal" rather than "Virtual" but either way, I can see no reference to such a process on the net. Searching...
So I've gotten fed up enough with the terrible windows search system. I went into services.msc and disabled the windows search service; then restarted my computer. However, "Cortana" is still listed in my task manager taking up 50mb of memory....
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 08:31.
Find Us