Fix for cnmscc~1.dll error? Solved

  1.    #1

    Fix for cnmscc~1.dll error?

    Computer is a ASUS laptop, SSD, 8 GB memory, 64 bit, running free upgrade W10 version from W7. No problems with computer after the original clean install of the free upgrade in January. Problems all commenced with version 1607 in August. First a networking problem, repaired with different networking adapter. Following that fix, and after a couple of other upgrades tail end of September, I get a popup window shortly after boot up or reboot, advising "there was a problem starting C:\Users\Bob\cnmssc~1.dll. C:\Users\Bob\cnmssc~1.dll is not a valid Win 32 application". No effect on the machine which runs fine otherwise. But it's a major irritation which I'd like to eliminate. Anyone have any suggestions?

    In checking Microsoft support there seems to be spotty fixes. The problem seems to be related to Canon software. I run a Canon printer on the network. Some have managed a fix by uninstalling the software and reinstalling, but others, like me, have done that a couple of times with no effect on the problem. I've uninstalled, 'cleaned' the computer, and reinstalled to no effect. I've gone through the Users part of the registry but can locate no file as described above. I was just going to delete that reference, but I found none. Haven't gotten through the rest of the registry.

    I'm surprised this problem hasn't been posted here as there seems to be quite a bit of the same problem posted @ Microsoft and Tom's Hardware.

      My ComputerSystem Spec

  2.    #2

    Hey bob,
    Try checking the startup tab of task manager for any Canon printer software. If you see any, try disabling it.
      My ComputerSystem Spec

  3.    #3

    Thanks for the suggestion, but I've been there. Nothing on it. I've pared the startup down quite a bit on that machine. I only have 4 items on it now. No joy.
      My ComputerSystem Spec

  4.    #4

    Hey, try opening the run dialog (windows+r) and going to shell:startup
      My ComputerSystem Spec

  5.    #5

    CONGRATULATIONS AND THANKS! How simple and easy! You should go around to all the threads I've visited, and also advise Microsoft whose 'support?' group is stumped. Appreciate and thanks again!!
      My ComputerSystem Spec

  6.    #6

    To fully remove it
    Go to Start/Search and type Regedit and press enter.
    In the Windows Registry Editor, In the Toolbar, Make sure Computer is highlighted, then go to Edit/Find. In the Find What dialog box type in cnmssc~1.dll and press enter. It will search the registry and stop. 1. Press the Del key to delete this file, 2. press Enter to confirm, the deletion and 3. press F3 to continue searching. Do these last 3 steps each time until it stops and says Finished Searching the Registry. Restart the computer.
      My ComputerSystem Spec

  7.    #7

    Thanks, but I did that multiple times. Found nothing. Then started to go through the several branches in the Registry. Went through all the branches individually in the Users branches, both the one with my name, and the other with no user's names, and it too found nothing. That was tedious but it still found nothing. Was going to go through the rest of them individually till this particular successful 'fix' was suggested, then 'EUREKA!'. I don't care if it's still in the registry as long as I can't see it!

    Incidentally, I also did the regedit thing using only 'cnmssc' and 'cnmssc *" and again nothing.

    I 'clean' the Registry with Ccleaner frequently and I cleaned multiple times but I'd guess it's still somewhere. I'd love to know in which hive or branch that little bugger was, but it's harmless now. Didn't have it on two other desktop machines on my network, all also with clean installs of W10 and all updated to version 1607. I've also done the suggested successful 'fix' on those with no detrimental effect on function.

    Thanks anyway!
      My ComputerSystem Spec


Related Threads
anyone run this one before? I am not currently using a WIFI device. Error 16393 Log Name: System Source: Microsoft-Windows-Bits-Client Date: 12/8/2015 3:05:05 PM Event ID: 16393 Task Category: None Level: ...
Solved Random BSOD error Page Error in Non Paged Area in BSOD Crashes and Debugging
Hi, I have started getiing random BSOD atlaest 5-7 times today on my laptop. It just says Page File error in non paged area evrytime. The laptop is fairly new and used very mildly. Please guide what to do.
During Windows backup, which wants to backup the 'C' drive and my games drive 'E' (for some reason), I get the following error message after the 'C' backup has completed but not the 'E': 'The backup operation that started at... I have tried what I believe to be everything at this point. Clearing out the update download folder and retrying the update does not help whatsoever. Forcing the update through a command prompt just gets the...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 06:49.
Find Us