No boot device available

  1.    23 Oct 2016 #1

    No boot device available

    My girlfriend's desktop computer has broken down and gives me the message "No boot device available". Before that screen it shows me something about RAID volumes which I don't fully understand. It's a Dell Dimension something, at least 5 years old. I tried resetting defaults in BIOS because I read somewhere that CMOS battery runs out of juice it could cause this sudden behavior.

    I opened the chassi and there are 2 HDD's. When I go into BIOS it says that the drive located at SATA-2 is not detected. Could it have something to do with the 2 drives running in RAID that when one drive goes "offline" the other is dependent on the not-functional drive?

    And one Windows-related question. This PC had Windows 7 installed on it when bought. My girlfriend upgraded to Windows 10 for free. If I would need to do a clean install of Windows 10 on the non-botched drive, how would I go about that? I may have some image from MSDNAA, but can I use her old Windows 7 key, knowing she did upgrade in the free year?

    Thank you.

    Attached Thumbnails Attached Thumbnails DSC_0033[1].JPG   DSC_0034[1].JPG   DSC_0035[1].JPG   DSC_0037[1].jpg  
      My ComputerSystem Spec

  2. jimbo45's Avatar
    Posts : 6,348
    Windows / Linux : Centos, Ubuntu, OpenSuse
       23 Oct 2016 #2

    Hi there

    Chances are that you need to load the RAID driver before Windows boots in order to see the HDD otherwise you'll get the message "No boot device" or some message like that.

    I believe at Windows re-install time you CAN load the RAID driver - somewhere in the install there is a process to install driver from external source.

    My system allowed me to integrate the RAID driver before starting the install (HP Gen 8 proliant microserver -- used the driver from W2012 server was on the HP server on an internal chip -- works fine for W10 too).

    You'll need to google a bit more on this so -- getting RAID drivers integrated into W10 install isn't always easy.

    Sorry I can't be a bit more helpful here.

      My ComputerSystem Spec

  3.    23 Oct 2016 #3

    Can you just turn RAID off in UEFI/BIOS, set the SATA controllers to AHCI and use the drives as individuals?
      My ComputerSystem Spec

  4.    23 Oct 2016 #4


    When I go into BIOS it says that the drive located at SATA-2 is not detected.
    That's the root of the problem. Check the SATA cable connections, swap the drive connection around to see if the problematic drive moves with it etc.

      My ComputersSystem Spec


Related Threads
No boot device available in BSOD Crashes and Debugging
Whilst starting up, Dell logo appears. After a while a black screen comes up saying: no boot device found. Please help.:shock:
Inaccessible Boot Device in Installation and Upgrade
Sir, I had upgraded my Acer Aspire Laptop (CORE i5 - 4GB RAM) from Windows 8.1 to Windows 10 recently. As it was running very slow, I decided to do a 'clean reset'. By mistake, the recovery partition also cleaned. It then went to a blue screen...
Hi guys first post here , BIOS Version/Date Phoenix Technologies, LTD ASUS M2N-E SLI ACPI BIOS Revision 0801, 25/04/2007 This is an older MB and I have installed Windows 10 as a fresh install now and its running nicely . The Question is...
Soo... things have gone from bad to worse. My problem started after windows 10 updated when I shut down my laptop for a quick restart. Windows explorer would crash every second, reopen, then crash again without stopping. I tried a system restore...
Inaccessible Boot Device in General Support
I ran into a problem this evening with my laptop, Lenovo B575. The laptop kept restarting because of inaccessible boot_device. I am not sure how to fix this problem. I know it's too new for everyone with Windows 10. Mine is Windows 10 64X Home...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 06:32.
Find Us