Windows 10: Lost access to drive - "Access is Denied"

Page 5 of 6 FirstFirst ... 3456 LastLast

  1. Posts : 332
    Windows 10 64-bit home
    Thread Starter
       14 Oct 2016 #41

    Wynona said: View Post
    Agreed on the cables; for some reason, when I first opened this thread, there were only two pages, but now there are four, so it looks like I may be a little late to the party. :)

    Good on freeing up a couple of hard drives; if I were doing it, I think I'd go for the newest one (mainly to rule out a [possibly] failing hard drive). Secondly, I would remove every device connected to my computer; all the way down to a flash drive, in order to rule out interference by anything else.

    If I've read correctly, you're running Windows 10; however, I haven't seen which version. Are you running the Anniversary Update (Build I think)?

    When I see a company like your Icy guys doing the right thing, it makes me know they're one of the good guys, and in this instance, they seem to be the exceptional guys.
    Yup, the Anniversary update installed itself a couple weeks ago on it's own. Before that I had a clean install from my retail Windows 10 (64bit) thumb drive. Of course I have all my software installed as well. My PC updated again the other day so I would say it's fully up to date.
      My ComputerSystem Spec

  2. Posts : 332
    Windows 10 64-bit home
    Thread Starter
       14 Oct 2016 #42

    I talked to Gigabyte (my motherboard manufacturer) earlier over the phone to see if they had anything to suggest. He highly doubts it could be a Windows 10 fault. He said it could quite possibly be an incompatibility issue between my enclosures and the 100 chipset used by the motherboard. He said that chipset is standard now on all motherboards, but that the enclosures, especially being older, likely would not have been tested on them, so compatibility could be spotty. He thinks the idea of the green drives being at fault may be going down the wrong path, but didn't rule it out since he's unfamiliar with that particular issue. Icy Dock is strongly leaning in that direction. I'm going to mention the 100 chipset to Icy Dock and see if they can verify that their enclosures are tested and compatible. Maybe these enclosures just don't play nice with this chipset, though if that was the case I would have thought I'd be finding that out in these forums.
      My ComputerSystem Spec

  3.    15 Oct 2016 #43

    rivre, did you also changed the Motherboard? I think your enclosures were working fine in W7 and I was assuming it was the same Motherboard with the 100 Chipset.
    Anyway, all my 5 external Drives were working fine in W8.1 and just 1 went bad in W10 ver 1511, no Hardware changes here, only OS was changed, and I have no 100 Chipset. From that 5 Drives , 2 of them are in Icy Box and 1 went bad.
    All sort of issues with Drives was arising with W10.1607 update and I doubt all the people had a 100 Chipset and a Icy Box or a WD Green, many cases they were even internal Drives.
    MS recognized there were a "small number" of people suffering from that problem with Drives. Well, 1% of 350 Million is still a huge number.

    As I said before, just as a precaution measure, I put the Icy Box away. Background thought was If there is a bad soldering point, with time it will get worse until the day comes were the resistance will be so high that voltage will drop and that could lead to the failure of disconnecting Drive in middle of operation. The error I had was in middle of System Backup.
      My ComputerSystem Spec

  4. Posts : 332
    Windows 10 64-bit home
    Thread Starter
       15 Oct 2016 #44

    My entire PC is new. I built it with all brand-new parts and a retail Windows 10 install thumb drive. So my old Windows 7 PC didn't have the 100 chipset. It was approaching 6 years old and didn't even have USB 3 ports - I needed to use a USB 3 card for my old Windows 7 PC. Of course my new motherboard (Gigabyte Z170x Gaming-7) has built-in USB 3.0 support so I no longer need the USB card. I did try touse the card at first to expand the number of ports but the card did not work at all on my new PC - I noticed the MOLEX power port was cracked on the card somehow and I don't think the card was getting power - I may have cracked it when moving it to my new PC.
      My ComputerSystem Spec

  5. Posts : 332
    Windows 10 64-bit home
    Thread Starter
       18 Oct 2016 #45

    I passed on the information about my chipset to Icy Dock today. Gigabyte thought maybe it could be an incompatibility with these enclosures with the Intel Z170 chipset. So Icy Dock said they will look into that as a possible issue. Meanwhile I'm basically stuck right now. I don't dare turn on any of my enclosures with my drives inside until I finish clearing some data so I have a couple test drives. That's what I've been working on.
      My ComputerSystem Spec

  6. Posts : 332
    Windows 10 64-bit home
    Thread Starter
       19 Oct 2016 #46

    Well I received a response back from Icy Dock today. I'm not too happy honestly. They provided me a list of what I have to do before they send out a new unit for testing. Note that they are now telling me the unit is for testing only and that I must ship it back to them when I'm finished - I cannot keep it. This is the first time they disclosed this important bit of information to me. Here's what I need to do:

    - register my existing unit on their site
    - file an RMA for the unit on their site
    - fill out an Advance RMA agreement that they attached in their email
    - fill out a credit card form they attached in their email

    They wrote, "There will be a pending charge on the card, however, you do not have to pay this charge provided that we receive the unit back after testing. Once we have received the two forms along with the online RMA request, we can send out the MB174U3S-4SB with the new firmware to test. If you need any assistance with the RMA forms, feel free to send us an email."

    Their unit corrupted two of my hard drives and these are the hoops they put me through. Not happy. I do not like the idea of a pending charge for around $100 sitting indefinitely on my card until I return the unit. And I'm guessing I would have to pay for return shipping? They don't say one way or the other about return shipping being covered by them.

    These are a lot of hoops to jump through just to get to "test" their firmware and not even get to keep the unit considering the trouble I've already gone through. If they are going to go through this much trouble, why can't they just let me download the new firmware and try it myself on one of my existing units? And keep in mind that the new firmware only disables the WD green drives' Intellipark features - that's it. They keep focusing on that as the issue, even though I have been using these same exact green drives in the same exact enclosures for over 2 years on my old PC. Gigabyte strongly suggested that it was an incompatibility with many of these older enclosures and the Intel Z170 chipset on my new motherboard. If that's the case, then all of this credit card authorization and shipping the unit back will all be a waste of time. Shame they are going to put me through so many hoops just to temporarily try out the unit. Seriously, I have already bought 3 of these in the last 2 years. Would it kill them to ship one out and write it off considering the grief their unit put me through?

    I'm almost at the point where I'd rather just buy another manufacturer's enclosure and try it myself and keep it if it works, but there aren't many choices out there for 4-bay enclosures that are affordable. About the only other one out there that doesn't get terrible reviews is the Mediasonic USB/esata enclosure, and that has been available for years. I doubt if they have changed anything since it first hit the market, and their USB 3 flat-out didn't work at all on my old PC's USB 3 card. Maybe it will work better now on my new PC?
      My ComputerSystem Spec

  7. Posts : 332
    Windows 10 64-bit home
    Thread Starter
       19 Oct 2016 #47

    I noticed on Amazon under a different enclosure review, somebody else had the same error message I've been getting:

    'I am, however, getting Event 158 warnings. Those are "Disk 4 has the same disk identifiers as one or more disks connected to the system. Go to Microsoft's support website [...] and search for KB2983588 to resolve the issue." I was getting the same warnings under the shipping firmware."

    It's a different enclosure than mine but this suggests that these enclosures are causing a lot of problems for some people. Is it a power option that is causing issues? Chipset incompatibility? Windows 10 issue? USB driver issues? I don't know, but I"m starting to worry that I may never get to the bottom of this. I don't know what I'm supposed to do if I can't even use enclosures for storage on my new PC.

    Also there's an older thread on this forum from last year about this message but there was no resolution to the issue:

    Event ID 158 - disk identifiers duplicate

    I'm starting to wonder if this is a Windows 10 issue after all. I can't believe nobody seems to know anything about this issue.

    Would changing any RAID settings in the BIOS help? Maybe my Gigabtye motherboard need to have a RAID option set in the BIOS to recognize multiple drives correctly in external enclosures?
      My ComputerSystem Spec

  8. Posts : 332
    Windows 10 64-bit home
    Thread Starter
       19 Oct 2016 #48

    My apologies for the multiple posts but I'm doing my best to try and track down this issue. I think I may have stumbled upon something that may be key here. I found this on another review of that ORICO enclosure review I linked to above:

    "Also, if you're on Windows 8.1 or Windows 10, there are some registry changes that are largely undocumented that you should know about. This enclosure along with many other new ones don't run under "USB" drivers in new versions of Windows. UASP is what gives these things such great speed. Windows natively supports this, but the USAPStor driver was written in 2006 and has never been updated. It currently has power management enabled, and it can't be shut off. A common symptom of this (despite making any changes you want to the registry and power management window) is when drives randomly drop out and don't reappear. I've been running Windows Storage spaces using 5 drives. Couldn't figure out for the last month why (using three different docks) I kept loosing my array of drives. I'd walk in and find the enclosure off. There's a line that's added by the UASPSTOR driver called "EnableIdlePowerManagement" under the StorPort registry key for each drive you add. Setting EnableIdlePowerManagement to 0 (I added the dword32 value to each device in addition to the hub) fixes this problem.
    I know - that was really geek and you have no clue what I'm talking about... But if you're lucky, someone with more time than I have (having lost months of my life researching this) will understand what I've done here, and get stupid MS to update their drivers."

    Could this be tied into my issue? The Icy Dock enclosures I have specifically mentions "Supports UASP function for even faster performance" under the specs of my enclosures.

    I took a peek into regedit just to see if I see any EnableIdlePowerManagement entries under storport, and thee are several listed under different device parameters, but I'm not comfortable making any changes to any of those entries without being certain that it won't have any negative effect, especially since I don't know which drives those entries are for.

    But, this does make me wonder then, since there may be an issue with these UASP enclosures and Windows 10, - could I avoid this issue by using an enclosure that doesn't support UASP? My older Mediasonc enclosures specifically say on their site that they don't support UASP. Perhaps I need to do some testing with my current Mediasonic enclosures. this would point back at the Icy Docks as being the problem here (well, Microsoft, really, but Icy Docks since their enclosures support UASP).

    This does make some sense, since my old Windows 7 PC didn't support UASP, so the Icy Docks wouldn't have run into this issue on my Windows 7 PC. Now that they are running on my Windows 10 PC, the UASP power management issue may be coming into play?

    Any thoughts? I realize this is very technical but that's what this forum is for, right? I'm wondering if the UASP support in the Icy Docks are to blame. If so the answer would be to use enclosures that don't support UASP like Mediasonic. This sounds like a major screw-up between the device manufacturers that use UASP and Microsoft, since many of the newer enclosures do seem to support UASP now.

    Can I disable UASP support in Windows 10, to force the enclosures to use the USB 3.0 drivers in BOT mode like Windows 7 instead of UASP?

    And here's a link to a description of UASP from a different enclosure manufacturer:


    Gigabyte suggested this morning I try the enclosures over my front USB 2.0 ports since that would obviously avoid using UASP since UASP is over USB 3.0 only. Also note I have now disabled "Allow the computer to turn off this device to save power" under power options of all USB drivers listed in device manager. Would that disable the UASP problem with disks spinning down and losing connection? Maybe I've already fixed the issue and don't know it because I haven't done any more testing yet?

    Also, remember that reading from my Icy Dock was fine, as I first zipped some files up from my Icy Dock to my internal drive, and the zipping process went fast and flawless. It was only when I tried to copy some files over to the Icy Dock that the drive got corrupted and I got locked out of the drive. Reading to the Icy Dock was fine, writing caused corruption.

    Another clue that UASP may be at the heart of all my grief here: I found out on another forum that I can check to see if UASP is being used for any currently connected USB drives. When I insert my USB 3 thumb drive, and check device manager, the driver shows USBSTOR.sys is in use. If UASP was being used, it would say UASPStor.sys. I have no problems reading and writing to my USB thumb drive.

    I also read this:

    "UASP standards solidified near the end of USB 3.0 development so most USB 3.0 storage products are not UASP compatible. Some buggy chips were produced so some products claiming UASP support have been blacklisted."

    Last edited by rivre; 19 Oct 2016 at 14:21.
      My ComputerSystem Spec

  9.    19 Oct 2016 #49

    I think you are probably onto it. I see entries in my registry with enableidlepowermanagement set to '1'.

    It may just be that the driver writers and hardware vendors have not got all the loose ends tied up yet. Pretty bad news, though, for those affected.
      My ComputerSystem Spec

  10. Posts : 332
    Windows 10 64-bit home
    Thread Starter
       19 Oct 2016 #50

    Thanks for following this thread. I know it's a lot to take in, and hard to describe in forums.

    Well I talked to Icy Dock about my USAP theory today. They will "look into it". He told me the Black Vortex doesn't support USAP, but I told him I think he is wrong. On their product page it says in several places that it does support USAP. I don't expect anything to come from my talking with Icy Dock. Their enclosure corrupted my drives and it's still under warranty but I'm supposed to let them put a hold on my credit card for $100 just to test some firmware they've cooked up that I don't even think will address my issue because they are focusing on the fact that one drive is a green drive. I think it's far more likely that it's a USAP issue.

    Like you said, that's bad news if this is the case, since all I can do is buy enclosures that don't support USAP. Too bad because the cooling solution is better on these Icy Dock drives than some of the other enclosures I've seen. I started a new thread here

    to see if there's a way to disable USAP in Windows 10. I doubt it though. It's also sad that I have to stumble onto this issue the hard way - with corrupted/lost data. They are selling these things with USAP support. If USAP is unstable and can corrupt data due to dropping drives in USB enclosures, then the enclosure manufacturers shouldn't be supporting USAP. Or at least offer a way to bypass it. They are supposed to be the experts , and we trust that they test their products. I was going to test the Icy Dock on my USB 2.0 port but from what I read USAP can even be supported over USB 2. Not that I want USB 2 speeds, but at least I could try to rule out USAP or pinpoint it if it's really the issue here. I may have to break down and buy a Mediasonic enclosure with USB 3 support and see how it works for me (if at all). I know the Mediasonic I'm looking at doesn't support USAP.

    I'm very nervous about touching those enableidlepowermanagement entries in my registry since I don't know which drives those entries are for, and I shouldn't need to do that anyways. Strange how I could read from that enclosure but the moment I tried writing it froze and led to corruption.
      My ComputerSystem Spec

Page 5 of 6 FirstFirst ... 3456 LastLast

Related Threads
hello new to PCs in general. Wanted to change some setting in order to get a game running (at the end of video)- Prince Of Persia 2008 : How To Set Resolution And Fix The Loading Problem - YouTube but when going into /C drive where the game is...
My problem in short: With Remote Desktop Connection I Get the error: “the requested session access is denied” with enhanced mode trying to login into my non-admin account on a VM. I can connect fine using non-enhanced mode. So I am running...
So I bit the bullet and "upgraded" my laptop from Windows 7 to 10. I expected to find a few things that didn't work anymore, but not so soon as this. I keep it in sync with my desktop PC (running XP) by net-sharing its hard drive, with...
ERROR MESSAGE Access Denied You don't have permission to access "" on this server.Reference #18.b1f31502.1439008845.47ab9a03 Hello there, I use steam. So basically what's happening...
Unable to delete folder, unable to change permissions, and unable to get One Drive to read to Documents folder correctly. I have attempted five times and each time it fails. So I try to delete the One Drive folder so I can reboot and try again,...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 10:13.
Find Us