1. Joined : Jun 2016
    Posts : 170
    Windows 10 64-bit home
       27 Sep 2016 #1

    missing file - ASPI32.sys


    I opened autoruns tonight on my 64-bit Windows 10 PC and noticed it lists a file missing:

    C:\Windows\System32\Drivers\ASPI32.sys

    It is however in my SysWOW64 folder.

    My PC is new but I've been installing all my software (and un-installing a few along the way) and I'm wondering if I need to worry about this or not? Should this file be present? Does this have anything to do with disc drives? My new PC has been acting a bit odd with a couple older Audio programs (like Exact Audio Copy) like detecting DVD drives. Newer software seems to run fine. Should I worry about this missing file? Is it there by default with a new install and it somehow got deleted? Or did some piece of old software install it and when I uninstalled the software it removed the unneeded file?
      My System SpecsSystem Spec


  2. Joined : Jun 2015
    Posts : 138
    windows 10
       27 Sep 2016 #2

    This kind of error can happen when Windows or software starts or shuts down, or maybe when you are using the computer or software.
    If ASPI32.sys missing, you will not able to run some software, system may work very slowly and not follow your command. Your important files will be in danger.
      My System SpecsSystem Spec


  3. Joined : Jun 2016
    Posts : 170
    Windows 10 64-bit home
       29 Sep 2016 #3

    Can somebody verify the above statement? That sounds pretty doom and gloom. My PC is brand new and I installed Windows 10 64bit myself from a retail thumb drive. I've been installing software on it over the past few weeks but otherwise I haven't even used it yet.

    ASPI32.sys is located in my SysWOW64 folder but not my system32 folder. I understand this can cause confusion as sometimes some files are in one folder but not the other.

    I also understand that since autoruns is 32bit it doesn't properly see some files and reports missing files when they aren't missing - something about folder redirection. For instance it also reports
    wow64.dll, wow64cpu & wow64win as "not found" in syswow64 even though they are in the system32 folder where they belong (I looked this up).

    Should Windows 10 have
    ASPI32.sys in the sytem32 folder? I'm thinking at some point during software installation I installed an older piece of software (which I did - for instance I installed the old disc burning software "Burrrn" and then uninstalled it when I realized it didn't run properly on Windows 10 since the software is ancient), and that software must have installed ASPI32.sys in the system32 folder and then removed it when I uninstalled it. Just my guess on what has happened. If somebody could verify where ASPI32.sys should be in Windows 10 64-bit I'd appreciate it.

    If ASPI32.sys is supposed to be in my system32 folder, wouldn't sfc /scannow detect this issue and fix it?
      My System SpecsSystem Spec


  4. Joined : Oct 2013
    Newport, South Wales, UK
    Posts : 1,215
    Windows 10 Pro x64 - XP/Vista/Win7/Win8.1 in VM for testing
       29 Sep 2016 #4

    Have a look here, it's not all doom and gloom

    Aspi32.sys Windows process - What is it?

    On way out but will check back later
      My System SpecsSystem Spec


  5. Joined : Jun 2016
    Posts : 170
    Windows 10 64-bit home
       29 Sep 2016 #5

    Thanks - that's so funny, I was literally just reading that very link.

    According to that, it's a WINASPI Driver. From some reports I've read it seems it's depreciated since Windows Vista or 7? I'm confused. I checked my old Windows 7 PC and that file is in my sytem32\drivers folder. I double-checked autoruns on my Windows 10 PC and it still says:

    "File not found: C:\Windows\System32\Drivers\ASPI32.sys"

    The file is in syswow64\Drivers but not system32\Drivers. The file description says "ASPI for WIN32 Kernal Driver".

    So, does this file get installed by some older software maybe, and possibly got uninstalled when I removed the software? It must have been in my system32\Drivers folder at some point recently for autoruns to list it as being missing now, right? Like I said I've been installing and uninstalling lots of software recently getting my new PC set up and but I don't know now which software could have been involved with this file. I don't want to delete the entry in autoruns and mess anything up since the file does exist in my syswow64\Drivers folder.

    I ran sfc /scannow on my Windows 10 PC and it reported no integrity violations.

      My System SpecsSystem Spec


  6. Joined : Aug 2015
    Posts : 13
    Windows 10 Pro
       29 Sep 2016 #6

    Well I've checked my 3 Win 10 desktops and aspi32.sys isn't on any of them and nothing has complained about it being missing. probably left behind by some older software you've removed I would think.
      My System SpecsSystem Spec


  7. Joined : Jun 2016
    Posts : 170
    Windows 10 64-bit home
       29 Sep 2016 #7

    Thanks for checking. So you don't have the file at all, even in your syswow64\Drivers folder?

    So what is Whatphoeb above talking about with his doom and gloom scenario?

    What should I do about Autoruns saying the file isn't found? Do I leave the yellow entry alone? I'm hesitant to delete it because the file does exist in my SysWOW64\Drivers folder, probably put there by some software I installed as you said. I also wasn't sure if this has something to do with Autoruns not seeing some files properly, like wow64.dll, wow64cpu & wow64win like I mentioned above. But that seems to be the opposite of what's happening here with ASPI32.sys.

    There's no way to track down what software put it there, is there? I wish there was a way for Windows to look back at files and see what program put it there.



      My System SpecsSystem Spec


  8. Joined : Oct 2013
    Newport, South Wales, UK
    Posts : 1,215
    Windows 10 Pro x64 - XP/Vista/Win7/Win8.1 in VM for testing
       29 Sep 2016 #8

    I would suspect that the old burner software you installed and un-imstalled is to blame for this issue. It's quite likely that although it removed the files it created when you un-installed it was unaware of the virtual file in the wow64 folder so left it in place. The entry in autoruns is I think safe to remove. Removing the file itself could cause issues so is best left where any system entries may find it
      My System SpecsSystem Spec


  9. Joined : Jun 2016
    Posts : 170
    Windows 10 64-bit home
       29 Sep 2016 #9

    Thank you. I also posted a similar thread about a few other missing .dll files in autoruns (codec files I think).

    autoruns reports missing files

    Can you take a look at that thread for me? One suggestion someone offered was to do a repair install but as I said in there I'm very nervous about doing that with my brand new PC after weeks of getting my software set up perfectly. I'm afraid too many other pieces of software may break after setting everything up so meticulously. A repair install seems rather drastic doesn't it, for a few missing .dll codecs that may or may not be an issue? Any advice there?
      My System SpecsSystem Spec


 


Similar Threads
Thread Forum
presentationfontcache.exe error - missing file?
I'm trying to run an older piece of software (cinema craft encoder) for the first time on my Windows 10 64-bit PC and I'm getting the following error: PresentationFontCache.exe - Application Error The application was unable to start correctly....
General Support
Solved CD drive missing from File Explorer
I'm trying to burn an audio CD yet the application doesn't recognise any CD drive. Checking further, the CD drive is not listed in File Explorer until a CD media is inserted that holds valid data. The drive disappears when the media is ejected....
Drivers and Hardware
Solved Missing DLL File
Cannot figure out just where or why this error is happening. I replaced my printer which was a HP 6700. I used the control panel and removed it from devices and printers. I then installed the new one which is a HP 7610. It is working fine. But...
Installation and Setup
AVG mfc100u.dll file missing
I'm using Windows 10 (64 bit) and have recently installed AVG Zen but upon opening it I get the following error message. http://i67.tinypic.com/2mpn1j6.png Any ideas on how to fix it?
AntiVirus, Firewalls and System Security
Missing shell32.dll and WININET.dll file
My computer just shut off on my, and once i turned it back on it said that i had a missing shell32.dll and WININET.dll file. I was never messing with any files, just playing a video game. I cant open anything besides documents. I tried looking stuff...
General Support
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 05:10.
Find Us
Twitter Facebook Google+



Windows 10 Forums