1. Joined : Jul 2015
    Posts : 39
    Windows 10
       13 Sep 2016 #1

    Post 1607 update start menu/apps not working


    Pulling my hair out...
    I have updated several computers to the Windows 10 anniversary update and all went without a hitch until the last computer I updated. The start menu button will not work, and when trying to open windows apps like Edge and Store the app will momentarily flash open then close.

    I have searched and searched and tried several fixes to no avail. I ran the start menu troubleshooter and it revealed that the shellexperiencehost and cortana shell were not installed correctly and couldn't be fixed automatically. I tried manually re-installing these via powershell commands but that didn't work either.

    I really REALLY don't want to have to restore windows on this machine.

    Any ideas?
    Thanks in advance.
      My System SpecsSystem Spec


  2. Joined : Jul 2015
    Posts : 39
    Windows 10
       14 Sep 2016 #2

    I ended up rolling windows back (to 1511) and uninstalling the Anniversary update, and now the start menu and windows apps all work as normal. Why would the Anniversary update break the start menu and apps when it was working fine under 1511?
      My System SpecsSystem Spec


  3. Joined : Aug 2016
    S/E England
    Posts : 1,131
    10 Home x64 (1607), Pro x86 (1511 & 1607)
       14 Sep 2016 #3

    Apparently modern windows apps (or metro apps as W8 called them) flash briefly like this when there's a problem with their installation. I saw this when the AU came out. I tested it as a clean install on a spare drive before returning my original drive and upgrading that. The clean install had some permissions missing on the hidden WindowsApps folder in C:\Program Files (and some places in the registry). I never needed to get to the bottom of it as putting the original drive back in and upgrading that had no such problems.

    Re-registering all the built-in apps may resolve the problem. @Brink has a tutorial for that.
    Apps - Reinstall and Re-register in Windows 8 and 10
      My System SpecsSystem Spec


  4. Joined : Jul 2015
    Posts : 39
    Windows 10
       14 Sep 2016 #4

    I tried the powershell re-register thing a few times. Each time I received an error saying something like a new version was already installed and the powershell command failed.

    I have read a few reports that this sort of thing happens more often on machines that have a primary SSD and a separate HDD for files etc. That is what I have in my computer, a 120GB SSD for the OS and programs, and a 1TB HDD for files. Perhaps I'll try again, removing the HDD before installing the anniversary update. Maybe that will help the apps and start menu register/install properly.
      My System SpecsSystem Spec


  5. Joined : Jul 2015
    Posts : 39
    Windows 10
       20 Sep 2016 #5

    Can anyone please help me with this? I have tried every "fix" I can find according to google. The latest thing I've read is to try and create a new Admin account...but I can't open the proper settings screen to do even that. I click on add a family member and something flashes on the screen but no window pops up.

    This is insanely frustrating.
      My System SpecsSystem Spec


  6. Joined : Jul 2015
    Posts : 39
    Windows 10
       21 Sep 2016 #6

    After trying all the various fixes I could find using google search and Microsoft help (which wasn't much help at all), I came across tweaking.com Windows Repair. This is a little 3rd party utility that boots the computer into safe mode and then runs some checks and fixes things that are out of whack. At first I was very reluctant to try something like this (security concerns etc), but the next step in fixing this problem was going to be a full windows clean install which would have wiped out all my programs and data. So I felt I didn't have anything to lose.

    The short of it is that tweaking.com windows repair fixed everything. My start menu is back and all the Microsoft apps open now and function as normal. I'm a Windows guy through and through, but seriously, why can't Microsoft fix things like this or offer any solutions like this third party did?
      My System SpecsSystem Spec


  7. Joined : Sep 2016
    Posts : 1
    Windows 10
       24 Sep 2016 #7

    joelshort said: View Post
    The latest thing I've read is to try and create a new Admin account...but I can't open the proper settings screen to do even that. I click on add a family member and something flashes on the screen but no window pops up.
    This is insanely frustrating.
    I spent over 3 hours going through the recommended steps, from running Start menu troubleshooter, Powershell scripts to attempting the same thing you mentioned above (adding user). ALL TO NO HELP!
    I then decided to do a Restore (with preserving the documents, and removing all apps and settings). To my shock, that did not help, and the start button was still not working and select apps not opening exactly as before. Only a full CLEAN WINDOWS 10 Install worked. Painful!!!!

    To test things, I then proceeded to upgrade to latest Windows Updates including
    Windows 10 anniversary update (Update Version 1607). Keep in mind this is a clean version of Windows with nothing else installed. To my shock, right after the upgrade - BAM! My Start Menu stops working. At this point I'm not even sure what to do, and thinking of simply reformatting again, and blocking that update, but then I continue to google, and stumbled upon this post. Joel, I cannot begin to tell you how thankful I am to you!!!

    That Windows Repair tool is MAGIC! It fixed things which nothing else could, and I simply gave up.
    Note to others: Go to Step 1 which will get you to Safe Mode. Then you can skip all optional steps as they don't help. You can take a backup (Step 4), I didn't. Step 5 - Repairs is what does the magic. It takes about 35 minutes to run btw. Then when you boot to windows and you are good to go!
    Click image for larger version. 

Name:	tool.png 
Views:	2 
Size:	70.6 KB 
ID:	102888,
      My System SpecsSystem Spec


 


Similar Threads
Thread Forum
Start menu Windows apps action pane not working
One day when i turned on my pc and clicked the start menu it is not working. when in opened edge it shows up the splash screen and closes and action pane is also not working etc... I have tried many things like reinstalling windows apps from...
General Support
Store, start menu, taskbar, and apps like calc not working
I originally wanted to completely disable the UAC as the admin permission messages that popped for almost any/everything i wanted to do were very annoying. I dont remember exactly what i did, but it was something in gpedit or something similar to...
Software and Apps
Windows 10 Pro (build 10240) Start Menu and Apps not working.
Hi, Any help would be appreciated, I upgraded my PC from Windows 8.1 to Windows 10 Pro (build10240) via the free upgrade. Everything worked fine until last week, when I was sitting at the PC and the Windows 10 Apps shortcuts vanished from the...
Software and Apps
Start menu, Notifications and Apps stopped working.
So yesterday I was just watching some videos on youtube and then the screen flashed for a second and started everything started acting up. I restarted my computer and since then, the start menu, notifications and all apps like the xbox app and store...
General Support
Start menu, cortana not at all working, Metro apps return with error
Ever since 10130 came out I've had this problem where you simply cant access the start menu or Cortana. Running edge or the store returns with an error from explorer.exe claiming that it's an invalid value for the registry. Looking in other places,...
General Support
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 18:39.
Find Us
Twitter Facebook Google+



Windows 10 Forums