1.    26 May 2015 #1
    Join Date : May 2015
    Posts : 15
    WINDOWS 10

    90% RAM usage while nothing is open


    I just upgraded from windows 7 and I haven't installed any extra programs and I have done a full virus scan with Malwarebytes however windows 10 sits on 90% RAM usage allot of the time, can someone help me please??!

    screenshot \/
    http://gyazo.com/0485e53f80e374f769a087ea6a2c6a0b
    Last edited by enviouz; 26 May 2015 at 03:52.
      My ComputerSystem Spec
  2.    26 May 2015 #2
    Join Date : May 2015
    Posts : 15
    WINDOWS 10
    Thread Starter

    dont worry guys I fixed it, turns out It had something to do with a nvidia and memory pool leak in my ram or something
      My ComputerSystem Spec
  3.    26 May 2015 #3
    Join Date : Mar 2015
    Posts : 616
    Windows 10

    The site you posted gave me an alert on Malwarebytes, so...
      My ComputerSystem Spec
  4.    26 May 2015 #4
    Join Date : May 2015
    Posts : 15
    WINDOWS 10
    Thread Starter

    Quote Originally Posted by fracking4oil View Post
    The site you posted gave me an alert on Malwarebytes, so...
    Probelm on your end, I'm running malwarebytes premium and I know nobody else that has that problem
      My ComputerSystem Spec
  5.    26 May 2015 #5
    Join Date : Oct 2014
    Posts : 17,942
    Windows 10 Insider Preview Build 16281

    Quote Originally Posted by enviouz View Post
    Probelm on your end, I'm running malwarebytes premium and I know nobody else that has that problem
    I think what he meant was that Malwarebytes alerted him about the site you linked to. He probably clicked on it and Malwarebytes said, "I wouldn't do that if I were you!"
      My ComputerSystem Spec
  6.    26 May 2015 #6
    Join Date : Mar 2015
    Posts : 616
    Windows 10

    Quote Originally Posted by Wynona View Post
    I think what he meant was that Malwarebytes alerted him about the site you linked to. He probably clicked on it and Malwarebytes said, "I wouldn't do that if I were you!"
    Yup, this...
      My ComputerSystem Spec
  7.    27 May 2015 #7
    Join Date : May 2015
    Finland, Vantaa
    Posts : 424
    Win 10 pro, creators

    check if you have process called bcastdvr.exe running on - thats a problem that i had on 10122. it gave critical errors at worst and crashed the computer - it started with a HUGE fps drops for few seconds and it was usually third or 4th time it crashed the whole computer.
      My ComputerSystem Spec

 


Similar Threads
Thread Forum
Solved Windows 10 memory usage on Asus T100
Hi everyone, I've finally finished installing a fresh copy of Windows 10 on my Asus T100. First impressions are great. If I'm not mistaken, it doesn't use as much disk space as Windows 8.1. I have 20 gigs of memory free out of the 29 available....
General Support
WD USB Drive -High CPU Usage using WMPlayer
Operating System : Windows Technical Preview Build 10122 : Problem - I own a WD USB Hard drive, and when I use Windows media player the CPU usage is between 10% and 20%, when it should be about 2% (Processor Intel(R) Core(TM) i7-4700MQ CPU) when...
Drivers and Hardware
Solved Massive RAM usage
Hi everyone, I don't know if this is the right place to put this but it's been a while since this is happening: This PC currently have 8 GB of RAM after playing/watching a few videos/browising the ram suddenly goes up to 85-95+% (70-75% the lowest)...
Installation and Upgrade
RAM usage W8.1 versus W10
I have compared the RAM usage of 8.1 and 10 in exactly the same (virtual) system. They are quasi identical. 12452 12453
General Support
Windows 10 resource usage
One of the good things is the small footprint of Windows 10. In my installation it uses only 8.5GB on the C partition and less than 500MB of RAM. I am sure that willl grow somewhat with the RTM edition, but it is a good start. 72517252
Installation and Upgrade
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 12:43.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums