Windows 10: Settings search not working and start bar not clicking setting options Solved

  1.    07 Sep 2016 #1

    Settings search not working and start bar not clicking setting options

    This is really getting on my nerves now, I have been trying to fix both issues for hours now and no avail.
    Lets start with the first issue, if I try to search in settings, it just says "search results aren't quite ready yet". As soon as I type anything in fact, it doesn't even take the time to search in Settings, it just immediately says that.

    I have tried the following solutions:

    1- "sfc /scannow", "Dism /Online /Cleanup-Image /ScanHealth" and "Dism /Online /Cleanup-Image /RestoreHealth". Neither of these 3 commands gave any errors

    2- Indexing: I have rebuilt indexing several times and made sure that the integral parts of the C drive are selected. Note that I have set indexing to go to another drive (H) however I have reset this back to "C:\ProgramData\Microsoft" and this made no difference.

    3- Some people have said that it is because my language should be set thoroughly to 'United Kingdom' and that you need to download the UK speech pack so I have set all my language/region/speech to 'United Kingdom'. This however brought up another issue - if I open up the start bar and search for anything related to the settings options such as "Cortana" or "Display settings" or "windows update settings" (basically anything under settings heading), I can't click on any of those options... If I switch my language back to "United States" then the setting options in the start bar are clickable again.

    Now here is the really funny part, when everything is set back to "United States" and click on Cortana settings in the start bar, there is no "United States" option to set Cortana's language to be, only "United Kingdom, Canada, Australia, etc". If I select "United Kindgom" in Cortana settings, it states that the region is different to Cortana's language (Because the system is configured as United States and Cortana language is United Kingdom).

    4- A Microsoft moderator mentioned to create a new Admin User Account and test if the search in settings works, I have done this and I can confirm that it does not work either, it still says "search results aren't quite ready yet". Creating a new account however does solve the start bar issues I have having in step 3. So when I create a new account, the language is set to "United Kingdom" and I can search in the start bar for any setting options and click on any of them.

    I have had this issue for a while now, I think since I migrated from Windows 7.

    Does anyone have any ideas at all!? Short of formatting (Not something I would like to do), I can't think of any other solutions.

    Thank you for any help.

    (Screenshot of Cortana language being different to system language)
    Click image for larger version. 

Name:	1.png 
Views:	2 
Size:	71.0 KB 
ID:	100283
    Last edited by rezelute; 07 Sep 2016 at 04:23.
      My ComputerSystem Spec

  2. Posts : 20,994
    Win10 Pro, Win10 Pro N, Win10 Home, Win10 Pro Insider Fast Ring, Windows 8.1 Pro, Ubuntu
       07 Sep 2016 #2

    You coulöd try the Search and Indexing troubleshooter, in Control Panel/Troubleshooting/View All(top right column)/Search and Indexing
    It only offers these options though, but wouldn't hurt to try:
    Click image for larger version. 

Name:	Image 001.png 
Views:	27 
Size:	10.4 KB 
ID:	100281
      My ComputersSystem Spec

  3.    07 Sep 2016 #3

    Thanks Cliff, I have tried that too, it didn't bring back any errors or issues.
      My ComputerSystem Spec

  4.    09 Sep 2016 #4

    After testing, I have figured out that (In indexed locations) if I have everything indexed apart from this: "C:\Users\MyUserName\AppData\Local\Packages\windows.immersivecontrolpanel_cw5n1h2txyewy\LocalState\I ndexed\Settings\en-GB"

    Then setting search works however it is alittle slow (obviously because indexing is turned off), however after checking that option again and searching it just says "search results aren't quite ready yet". I have a laptop with a freshly installed WIn 10 on it (after a format) and the settings with indexing worked fine. So I have copied the folder contents of that laptop "C:\Users\MyUserName\AppData\Local\Packages\windows.immersivecontrolpanel_cw5n1h2txyewy\LocalState\I ndexed\Settings\en-GB" but it still does not work. It does seem to me like something is broken with indexing the settings but I have no idea what....

    Click image for larger version. 

Name:	Untitled.png 
Views:	21 
Size:	29.3 KB 
ID:	100546

    Any suggestions?
      My ComputerSystem Spec

  5.    09 Sep 2016 #5

    That error message in your first post is typical of a mismatch in language configuration as has been discussed on a good many occasions here. I've experienced it. And of course indexing was complete.

    Have you changed your display language to UK English?

    If so, you must also download the UK speech pack. Then there are region and timezone settings.

    Usually Cortana tends to offer somewhat helpful messages relating to this.
    Try Windows key + S.

    One way to completely reset language settings is to do an in-place upgrade repair install, and on one occasion when I couldn't untangle this, that's what I did. Of course I was then back to US English, but I could try again.

    Check these:
    Click image for larger version. 

Name:	Snap 2016-09-09 at 13.29.17.jpg 
Views:	1 
Size:	55.4 KB 
ID:	100569Click image for larger version. 

Name:	Snap 2016-09-09 at 13.29.48.jpg 
Views:	20 
Size:	42.3 KB 
ID:	100570

    The repairs you have tried won't fix this.

    What is downright stupid is
    a. MS's totally misleading message
    b. That MS has not provided a robust wizard-based way of changing language to guide users thru the steps to lead to a consistent state.

    Feedback Feedback Feedback...!
      My ComputerSystem Spec

  6.    09 Sep 2016 #6

    Thank you Panda, I have tried all the suggestions you posted about Cortana (She always gives the opposite languages in the drop down as what I have set in the region) so I have pretty much given up on her.

    The indexing issue however is really annoying because I do search in settings and I have tried an in place repair of Windows 10 which did not actually reset the indexing nor did it reset the language back to US. I have no idea why when I turn on the indexing on that "LocalState\Indexed\Settings\en-GB" folder it just stops working completly.

    Short of a complete format, I am at a loss here (And formatting just to get settings search working seems a tad overkill)
      My ComputerSystem Spec

  7.    11 Sep 2016 #7

    Since nothing has worked for me I have just done the following as a solution for now (otherwise it would be a clean install which means I would lose all my programs), in indexing I have disabled "C:\Users\MyUserName\AppData\Local\Packages\windows.immersivecontrolpanel_cw5n1h2txyewy\LocalSta te\I ndexed\Settings\en-GB" which means that settings takes 1-2 seconds to search when I type (better than not working at all) and then enabled indexing for anything else that I need.
      My ComputerSystem Spec

  8.    11 Dec 2016 #8

    After bugging me for months, I have finally figured out what the issue was and why indexing was acting so strange on the C drive in folders and in System searches.

    A few months ago I had migrated my C drive (Windows, program files etc) to a new SSD. The old drive (H) which had Windows on it was then used as a Media Library drive (Pictures, Music, Documents etc). I am not sure how but Indexing Options kept thinking that the H drive was the current Windows drive (even though it didnt have any windows files on it) and was therefore nothing was getting indexed on the C drive. The H drive also had partitions such as Healthy (Recovery) and Healthy (System etc) which added to my suspicions about the indexing getting mixed up.

    To solve this I completly wiped the H drive, formatted and renamed it then put all the media libraries back on it. Now Indexing options actually indexes the C drive properly and searches are working fine everywhere including System searches.

    I thought I would share this in case anyone else has the same issue.
      My ComputerSystem Spec


Related Threads
Sometime in December, 2015 my keyboard Windows button and my task bar Start menu and Search stopped working and without the ability to START I lost all the tiles. I have followed suggestion after suggestion about how to fix this apparently...
Hi i notice that overtime, my star menu, search bar, and/or right click taskbar doesn't work unless i restart the computer or restart Windows Explorer in task manager. I have a feeling standing by my pc is causing this. Any1 know why this is...
Good day, good people. My windows 10 left click menu doesn't bring up the menu tray anymore since after I shut down my system using the alt+f4 combination keys. Likewise, neither the running apps tray nor the network one opens up on left click. I...
I performed a reinstall of Windows 10 build 10532. Since then, Start menu search shows no results. Attached a pic, showing DC++ pinned to start, but still not showing during search. Please help This is really frustrating
Start Menu Search not working in General Support
When I start my computer, my Start Menu Search sometimes gets stuck in a start up or searching loop. The start menu itself works if I am just using my mouse to click icons. The issue is hitting the Windows button on my keyboard and typing. What...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 02:02.
Find Us