Pressing '0' (zero) yields 'q', regardless of keyboard and layout

  1. Posts : 7
    Windows 10

    Pressing '0' (zero) yields 'q', regardless of keyboard and layout

    I'm running Windows 10 on a Surface Pro 4. I have made a custom keyboard layout in Microsoft Keyboard Layout Creator.I have 2 keyboards. One with norwegian physical layout.

    Using any of the two keyboards, and any layout/language input method in Windows 10 (English US, Norwegian, my own custom one), when I press '0' (zero), I get 'q'. Pressing Shift+'0' yields 'Q'.

    Pressing 0 on either keyboard in Linux yields 0.
      My Computer

  2. Posts : 15
    Windows 10/OS X 10.11 ADP

    Your custom layout has swapped the character q with 0.

    Go back to Layout creator and manually reassign that key individually. The fact that you have not mentioned that pressing the 'q' key gives you an '0' makes me think that it's simply an assignment error.
      My Computer

  3. Posts : 7
    Windows 10
    Thread Starter

    It doesn't appear like my layout swaps the two keys:

    Pressing '0' (zero) yields 'q', regardless of keyboard and layout-arenivr.png

    Pressing 'q' yields 'q'.

    And as I said, this happens regardless of which layout is used in Windows. My custom layout is called "atomic layout".

    Pressing '0' (zero) yields 'q', regardless of keyboard and layout-2fzb9it.png
    When "Norwegian keyboard" is selected, it clearly writes using Norwegian layout, and not "atomic".

    PS: Using KeyCodes3.exe, this is the output I get when I press the 'q' and '0' keys, respectively (couldn't copy):

    Pressing '0' (zero) yields 'q', regardless of keyboard and layout-axcshqz.png
      My Computer

  4. Posts : 15
    Windows 10/OS X 10.11 ADP

    Your top row should contain numbers. You have special characters there, but it is likely that because they require modifier keys (specifically Alt) to be pressed to create them, only the rest of the combination is created by pressing the button.

    It should look like this:

    Pressing '0' (zero) yields 'q', regardless of keyboard and layout-aa9b80f458.png
      My Computer

  5. Posts : 7
    Windows 10
    Thread Starter

    I don't use my top row for numbers. Instead, I programmed my keyboard to send Num Pad keycodes on some keys that I use for numbers. The symbols up to '[' are deliberate, and they all work. The bullet and forth were just to see if I could produce those keycodes with my keyboard. So I suppose if '0' would work properly, pressing '0' on my keyboard would give a bullet in the 'atomic' layout, and just a '0' in the Norwegian or English US layouts. I just tested with a '0' instead of a bullet (by "Project -> Test Keyboard Layout...") and '0' still doesn't work.

    However, I don't understand what my custom layout has to do with the problem, since I have the same problem using any layout. Not sure what you mean with the modifier keys - I don't need to press any modifier keys to get the symbols I want (except 0 which doesn't work).

    Edit: I can also use the custom layout in the virtual keyboard. Now, I changed zero to be '?', which it ought to be, rather than the bullet. In the virtual keyboard, I can press that button fine and get a questionmark:
    Pressing '0' (zero) yields 'q', regardless of keyboard and layout-eboqwch.png.
    Last edited by lala; 05 Sep 2016 at 12:55.
      My Computer

  6. Posts : 7
    Windows 10
    Thread Starter

    Bumping. I need the key to work.
      My Computer

  7. Posts : 7
    Windows 10


    You don't say which physical key you used for the "zero" that turns out like a "q". What key is it on the U.S. standard keyboard (the one shown by StarEmpire)? I don't know Norwegian nor the Surface, but I see the following possibilities:

    – Could you have assigned a non-assignable key, like the backspace?
    The backspace can be reassigned, but sometimes with really strange results.

    – The Surface has a virtual embedded numerical keyboard that is activated when you press Fn. I think you can reaffect the numerical keys in Keyboard Creator, and I know you can do so on a standard computer with an extended keyboard (just reaffect those keys on the numerical keypad). And I know from personal experience that you will get unpredictable results if you have configured the keyboard while the Fn key is depressed. So either check your keyboard map carefully while Fn is activated and not activated to make sure that you have digits on the virtual numerical keyboard and letters, digits and symbols on the normal one. Or save the file and install it on a standard computer with an extended keyboard, and check that everything is as it should be.

    – Dead keys are used in many languages like French for accented letters. For example, to type "", one needs to type "^" followed by "u". In this case, the "^" is a dead key, which means nothing happens until the next character is typed. So an improbable one: could you have assigned that zero on a dead key?

    – Last but not least, there might be a glitch in the keyboard file you have programmed. Put a standard keyboard as the default one, remove your personalized layout (Control Panel –> Programs –> Uninstall), and restart the system. What happens will tell you if the problem lies in the configuration file or elsewhere.
      My Computer

  8. Posts : 7
    Windows 10
    Thread Starter

    Hi, and thanks for the reply.

    When I uninstall my layout, I still have the problem. Does this mean we can rule out my custom layout and Keyboard Layout Creator?

    The rest of the this post is maybe irrelevant if that is the case.

    As for which key exactly that I use for '0', in the Norwegian layout, it's just the '0' button. This button is the same in US layout too I think. (If you're wondering since I said I don't use top row for numbers, I intend to use '0' for question mark, but for now I just need that button it to work and not send 'q').

    Attachment 100081

    I don't have an Fn button, I think. And I'm pretty sure I haven't touched dead keys.
      My Computer

  9. Posts : 7
    Windows 10
    Thread Starter

    Bumping again. But I just read that I have free access to "Answer Desk" support for 90 days. It's not open right now though. If nothing works, I guess I will need to reinstall Windows if that's possible.
      My Computer

  10. Posts : 7
    Windows 10
    Thread Starter

    Problem solved in the latest windows update.
    I assume that it isn't due to the update itself, but rather, the update made the Surface restart 'for real' (rather than hibernate kernel) and reset some things... please correct me if I'm wrong.
      My Computer


  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 17:52.
Find Us

Windows 10 Forums