1. Joined : Jun 2016
    Posts : 170
    Windows 10 64-bit home
       24 Aug 2016 #1

    aspi for win32 is not installed correctly


    Getting a weird error with an old piece of disc software on my Windows 10 64-bit PC. It says, "aspi for win32 is not installed correctly". aspi32.sys is in my sysWOW64 folder but not my system32 folder.

    From a quick search it seems ASPI is something from long ago. Is this normal that the file is not in my system32 folder on Windows 10? I also have issues with "exact audio copy" and Nero CDSpeed not seeing my disc drives correctly and was wondering if that's also ASPI related?
      My System SpecsSystem Spec

  2.    24 Aug 2016 #2

    Here's something from Adaptec that might be relevant: keeping your ASPI layer up to date. According to what I see there, this goes back to Windows NT, 2000, XP and 98. Hard to believe it's still called for. Here's a 2005 Dell support forum item that addresses the same topic: aspi for Win32 not installed correctly.
    Let us know how this one turns out: I'm curious!
    HTH,
    --Ed--
      My System SpecsSystem Spec


  3. Joined : Jun 2016
    Posts : 170
    Windows 10 64-bit home
       24 Aug 2016 #3

    EdTittel said: View Post
    Here's something from Adaptec that might be relevant: keeping your ASPI layer up to date. According to what I see there, this goes back to Windows NT, 2000, XP and 98. Hard to believe it's still called for. Here's a 2005 Dell support forum item that addresses the same topic: aspi for Win32 not installed correctly.
    Let us know how this one turns out: I'm curious!
    HTH,
    --Ed--
    Well I found something called the Adaptec ASPICHK utility. I'll run it on my old Windows 7 PC and see what happens. I also grabbed the XP version of the Adaptec ASPI from the link above. I'm scared to install it on my new Windows 10 PC though. I hate to think I might break something. It seems ancient so I'm wondering why I should need to worry about that. Maybe since the software I'm running is older it still relies on it?
      My System SpecsSystem Spec


 


Similar Threads
Thread Forum
Build 10130 DVD gives "setup.exe not a valid win32 app"
I have several machines with same hardware albeit v old! The all originally ran XP Pro. I was slowly upgrading them to 7 32 bit when 10 came along. To save time I tried the 32 bit build route however the machines running XP 32 bit won't run...
Installation and Setup
Tablet mode keyboard doesn't display with Win32 apps
In Win 8.x when using win32 apps in tablet mode, there was an icon to force the keyboard to display, this is gone in Windows 10, anybody know how to get the keyboard to display?
General Support
Screen not adjusting correctly
HP 500 desktop, wins 10 Auto adjust and manual adjust not working on the monitor. Westinghouse 40 in on standard pc port. It's too far to the right. Any patches or updates for that? Worked fine on wins 8.1 Updated my video card...
Graphic Cards
Desktop/Win32 apps missing from Start Menu "All Apps" and search
Hi, I'm having an issue and I'm wondering if anyone else has any ideas on what to do about it. Some desktop apps are missing from the "All apps" section of the Start menu. Most programs are there, but I'd say 10-15% are missing. Apps that are...
General Support
Is DX12 working correctly..?
.. is DX12 working correctly? - one would have assumed backwards-compatibility, as with earlier versions.. (?)
Software and Apps
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 08:38.
Find Us
Twitter Facebook Google+



Windows 10 Forums