Boot failure after restart - error code 021 seems to be trying to load

  1. Posts : 48
    10 1709

    Boot failure after restart - error code 021 seems to be trying to load

    Upgraded from 8.1 to 10 a couple of weeks ago. Running reasonably well. Today I powered down the machine and it will no longer boot. No changes were made before powering down. It starts booting and goes to a BS with error code 021. I tried a couple of times and I got a screen that let me choose the OS. I chose "other OS" once, and WIn 10 on a second try.

    Note: after the Win 10 install two OS choices appeared at boot time. It did not seem to default to 10. The second was 8.1. Apparently MS left it there in case I wanted to go back. I tried it once a bit after I installed 10 and 7 did not work.

    When it boots, the symbol on the screen is, I believe, the one for 8.1. My guess is that for some reason the boot record has been changed. But no idea how to do anything about it. With the machine running I have no way to even look at the UEFI boot record. I just can not seem to make it boot 10.
      My Computer

  2. Posts : 4,224
    Windows 10

    If you have a bootable installer for Windows 10, you can try repairing the boot information on your PC. Check the tutorials under the "Installation Guides" heading and you should find just what you need to get yourself back in action. The section on "Repair Install Windows 10 with an In-Place Upgrade" tutorial should provide some useful insight. You don't need to do the whole thing: you can just pick the Repair option early on, go to Advanced, and ask it to repair your boot environment.
      My Computers

  3. Posts : 48
    10 1709
    Thread Starter

    Thanks for the links. Unfortunately, after a bunch of reading through, they are all pretty much predicated on having the system operable. The only one I saw that seems to be applicable for an unbootable machine scares me. The system has gone through a "repair" it decided to do on one of the failed boots. Spent some time and said it did not accomplish anything. I am leery of the update while saving apps and files. I tried that in a much earlier problem in getting from Win 7 on MB A to 7 on MB B, then to Win 8, then 10. It kept clearing things like network connections and home groups. I still have not gotten the home groups to work correctly.

    I am now trying to find something to boot from a USB drive that can edit the boot record; presuming that I am correct in concluding that is the problem. I don't have a recovery USB. I was unable to get the proper version installed and while working on that this blue screen happened. I don't know if it was a background update from MS that did it. I really hate the new "your computer is ours to screw around with in any way and any time we choose". And what we do may break the machine: tough. I dread the anniversary update. I don't have it on my other machine yet.

    Do you have any suggestion for an easy package to boot from USB that lets me alter things on the Windows drive (like boot records). I am no where close to being an expert.
      My Computer

  4. Posts : 48
    10 1709
    Thread Starter

    Things have advanced but still not working.

    I got Win10 running just fine. No issues, apps worked. Then one day I rebooted and it will no longer boot. No error codes, just an offer to reinstall Win10 and telling me something is broken in Win.

    I built a new c drive on a different device from an older Win10 backup. Booted just fine. Did what it is supposed to do.

    I noted that MS soon installed something. Rebooted: BSOD with no codes. Just like what happened when the original C drive boot failed. I have now had two different drives with earlier iterations of Win10, that have done exactly the same thing.

    Something in that update is killing the system. The machine is unbootable.

      My Computer


  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 22:00.
Find Us

Windows 10 Forums