I was having an issue with office 365 not being able to launch - when trying launch word, excel, etc, I would get and error saying:

Microsoft Office cannot verify the license for the this product. You should repair the Office program by using Control Panel.

So I tried the various built troubleshooting options - nothing worked. I figured, let's just give a reboot a try and see if that does anything. Upon shutting down, I noticed there was an update, so I selected the 'update and restart' option.

The update got to 97% and then stated it could not complete and it was undoing changes.

So changes gets undone (I guess) and I end up back at the login screen. I enter my pin and it attempts to login for a fair bit longer than normal (say a minute or 2) and then spits out the following error:

"The gpsvc service failed the sign-in. The universal unique identifier (UUID) type is not supported"

(everything I could find on this talks about domain issues. This is a personal computer and not part of a domain.)

I click ok and then it signs me out.

I try sign in again and this time it lets me in, but my screen is black (I can only see the cursor) I fiddle a bit connecting to a second monitor and my desktop appears.

However, something is not right:
1. I don't have my desktop background (it is just black). I do see program shortcuts and can launch them fine.

2. clicking the windows icon and search icon on the task bar does nothing.

3. right clicking on desktop and selecting 'Display settings' gives me this error (I get a similar error when selecting 'personalize' as well):
This file does not have a program associated with if for performing this action. Please install a program or, if one is already installed, create an association in the Default Programs control panel.

4. If I try launch windows explorer (window key + E) or by the short cut I have on my task bar), I get: The server process could not be started because the configured identity is incorrect. Check user name and password.

I am sure there are other issues. I am able to bring up the Run prompt and if I click browse from there, I can get windows explorer to open and can navigate my one drive files and other programs and such.

I tried opening the account setting from the run command, but get an error:

Class not registered

And to further add to the confusion, just before I posted this, I figured I'd try one more reboot - it still took a couple minutes to login and my screen went black, but again after fiddling with a second monitor I was able to get things to display and this time everything was normal and everything noted above (1-4) worked fine.

I then tried another reboot and I again have the same issues noted above - except I now never get the gpsvc error when I sign in.

Does anyone have any thoughts as to what happened and what I can try to do to resolve? Aside from attempting a windows repair (and not sure if that will do anything given it seems I have some sort of account/permission issue) or a re-install, I am at a loss.


Edit: I just tried signing out (ctrl-alt-delete) and, again, like signing in it took about 2 minutes to sign-out. Not sure if this is indicative of something or not.