Windows 10: Remote procedure call failed

  1.    08 Aug 2016 #1

    Remote procedure call failed


    Towards the beginning of the year I started experiencing problems with the Start Menu. When I right clicked on some entries, I received an error 'The remote procedure call failed' (see attached image for full information). These errors occurred when selecting 'Programs and Features', 'Power Options', 'System' and 'Control Panel'; other selections seem to be OK. On occasion the Start Menu button has also failed to respond to left or right mouse clicks. At that time I did some investigation. The normal SFC and DISM commands failed to find any issues. Every now and then I'd be surprised to find that the right click on, say Control Panel', would actually display the window. Closing the window and trying again would bring up the error dialog again, unfortunately. In the end I just put up with it. Yesterday, I happened to look at my Windows Update and found all updates had been failing since at least July. Research pointed the finger at the Windows Firewall (WF) being disabled - I use Kaspersky IS and this disables the WF, so there was no way of activating the WF without uninstalling KIS. This led me to download and install the W10 (anniversary) update. Once I'd installed it I tried all the options on the Start Menu's context list - they all worked fine. Until today, that is. Now it's back to how it was and the same error message. Anyone have any ideas what is causing this problem and how to fix it?

    Images are for Control Panel (CP), System (SYS) and Programs and Features (PF).

    Windows 10 x64 Pro. 10.0.14393.0
    Attached Thumbnails Attached Thumbnails Error_CP.jpg   Error_SYS.jpg   Error_PF.jpg  
      My ComputerSystem Spec


 

Related Threads
Remote Procedure Call Failed in Software and Apps
Hi guys I tried to open my music thru Groove Music in windows10 But it shows me something like this 84037 I checked my services RPC service is on 84038 Any help?
Hi i've looked around and can't seem to find any help on the remote procedure call failure when opening video. I have tried some of the fixes that people have used when opening pictures and that hasn't seemed to work. Changing the default app to...
Hello community, I have a really frustrating problem with Windows 10 N (fresh installation, no upgrade from 7) and I'd really appreciate your help! I'm getting this error:52527 ... when I try to open any picture (jpeg, gif). I have...
Remote Procedure Call (2) in General Support
Ever since downloading the updates for 10130 on my Surface Pro 3 (after a clean install) the Service Host: Remote Procedure Call is going crazy, running constantly at 50%+ CPU, as a result of which the device is constantly running hot and battery...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 08:19.
Find Us