1.    04 Aug 2016 #1
    Join Date : Aug 2016
    Posts : 3
    Windows 10 Professional

    Service is Started on Restart but Service Set to Disabled


    Service is Started on Restart but Service Set to Disabled

    I am new to WIN10, and I find this behavior puzzling. I have set the service "Microsoft Office Click-to-Run Service" to Disabled because I can't stand using OneDrive and OneDrive (Office 2013 version) will autostart. So, I use a utility program (SC) to (1) Enable ClickToRunSvc service, (2) Start the Service, and (3) Disable the service (sc config ClickToRunSvc start= disabled).

    Then I start the Microsoft programs as usual (Office365). When finished, I shut down the computer using the Windows menu item "Start", Power, Shutdown.

    When I turn the computer back on and log in, the ClickToRunSvc is running again even though the service status is DISABLED?

    It's as if the shutdown is not a true shutdown but in fact a hibernate or a "shutdown.exe /s /hybrid".

    However, if I stop the ClickToRunSvc before shutting down, it is still stopped on the next boot -- but if it is running (started) when I shut down or restart, the restart allows the ClickToRunSvc to be running again.

    Can anyone explain why this behavior in WIN10 is different than WIN7 ? In WIN7, I could leave ClickToRunSvc running at shutdown and it would not be able to start itself until my batch file started it up (enable, start, disable).
      My ComputerSystem Spec
  2.    08 Sep 2016 #2
    Join Date : Aug 2016
    Posts : 3
    Windows 10 Professional
    Thread Starter

    Resolved. The default "Shutdown" button was performing a hybrid shutdown only, vs. a CMD shutdown.exe command.

    To turn off the default of hybrid "Shutdown", reverse the instructions viewed at this link: Enable This Setting to Make Windows 10 Boot Up Faster
      My ComputerSystem Spec
  3.    05 Sep 2017 #3
    Join Date : Sep 2017
    Posts : 2
    Windows 10

    Microsoft Office Click-to-Run Service / Cortana frustrations


    After running services.msc, I open "Microsoft Office Click-to-Run Service" properties and apply DISABLED. At some point, and I haven't determined what triggers it, because I check after turning on laptop after an overnight shutdown and it will still show as DISABLED -- for a while -- but at some point it will turn itself back to being AUTOMATIC. HOW does it override my direct instructions of DISABLED over and over? Similarly, I must play whack-a-mole ending Cortana within my Task Manager every new start of my HP Pavilion laptop. Frustrating.
      My ComputerSystem Spec

 


Similar Threads
Thread Forum
Failed to Connect to a Windows service - Groupd Policy Client Service
Hi - Having lots of trouble here and very frustrated. On login, I get the message "Failed to Connect to a Windows Service. Windows couldn't connect to the Group Policy Client service. This problem prevents standard users from signing in. As an...
General Support
msconfig-- service running but disabled?
My first new thread and pictures speak louder than words: 31400 Windows Defender is shown both running AND disabled. I have no third-party security or firewall. I am unable to select this service here (msconfig)-(but rightly set as 'Automatic' in...
General Support
Windows 10 Service Host: Local Service eating all the RAM SOLVED!
Hey guys! First post for me. :) Been taking up the problem of system and service host: local service eating all the ram. So I've been clicking some stuffs at the settings when suddenly I solved my problem unexpectedly! So here's how you do it. :) ...
General Support
Windows 10 Service Host: Local Service (Network Restricted)
Hello forum, Hello guys I've had this issue that has really been getting on my nerves for the past couple of weeks now ever since upgrading to windows 10 from windows 7. For some odd reason at random times this Service Host: Local Service...
Performance & Maintenance
Solved Disabled Windows Search service... Cortana still running?
So I've gotten fed up enough with the terrible windows search system. I went into services.msc and disabled the windows search service; then restarted my computer. However, "Cortana" is still listed in my task manager taking up 50mb of memory....
General Support
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 12:23.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums