Page 4 of 5 FirstFirst ... 2345 LastLast
  1.    06 Dec 2016 #31
    Join Date : Dec 2016
    Posts : 1
    Windows 10 Pro Anniversary

    Just wanted to pipe in, made account to let everyone know that making both CLSID and APPID's owner an Administrator then deleting the APPID, then opening component services again (or for the first time) fixed the problem as stated previously in the thread. When i opened component services again it pointed out that an APPID was missing, wanting to know if i'd like to recreate it. I said yes, checked the registry and the APPID in question throughout this thread was recreated but with the proper default value. I would assume you could just give yourself access and edit the default value but i find it being recreated automatically the cleaner route.
      My ComputerSystem Spec
  2.    28 Jan 2017 #32
    Join Date : Jan 2017
    Posts : 1
    Windows 10 64bit

    12. Type dcomcfg and <enter>

    Its dcomcnfg not dcomcfg
      My ComputerSystem Spec
  3.    28 Jan 2017 #33
    Join Date : Jun 2016
    Posts : 1,468
    Win10 1607

    Quote Originally Posted by anonymal View Post
    12. Type dcomcfg and <enter>

    Its dcomcnfg not dcomcfg

    You are correct , I thought I had edited that already but it must have been on the other Thread I mentioned.....I will check it now.

    *** I see now you mean @borgus Post no# 10 is incorrect still not my Post no#22 where I already reposted the corrected command and some extra instructions...


    Thanks.

    KB.
      My ComputerSystem Spec
  4.    28 Jan 2017 #34
    Join Date : Jul 2015
    Posts : 101
    Dual-boot Win 7 & 10, both Pro 64-bit

    Strange warning when try dcomcnfg


    Hey lads - I got a strange warning when I tried dcomcnfg just now. See attached Word doc with a screen shot of the warning. I will also try to paste the screenshot below.
    Asks me if I wish to "record" something. What should I do? By the way, I'm on Win 7 Pro 64-bit right now, but I've been following this thread for this thread's issues on my Win 10 Pro 64-bit as well.
    Dcom warning 1-28-17.doc
    Click image for larger version. 

Name:	Dcom warning 1-28-17.jpg 
Views:	60 
Size:	19.8 KB 
ID:	118900
      My ComputerSystem Spec
  5.    28 Jan 2017 #35
    Join Date : Jun 2016
    Posts : 1,468
    Win10 1607

    Was this after a restart of Comp and DCOM ?

    if so it is telling you it found an unregistered App I believe so say yes/OK.

    this is from Post #22, not sure if it is the same thing?

    "So the fix here is to just delete the Key instead after Exporting it for Safety, and then on reboot open Dcom again and you will be prompted to update a missing entry, (Say Ok) . Thereafter the AppID reappears in the registry and its default is listed as CDP Remote Text Handler and No further edits/additions need be made to that entry in Dcom or the Registry."

    note this thread is about a particular Key/AppID which is different that you have above but the instructions do work for other Keys I have found.


      My ComputerSystem Spec
  6.    28 Jan 2017 #36
    Join Date : Jul 2015
    Posts : 101
    Dual-boot Win 7 & 10, both Pro 64-bit

    Kbird - thanks for fast reply. I just elected to say "Yes" and rebooted. If I don't come back here, either everything is OK or the PC exploded.
      My ComputerSystem Spec
  7.    07 Feb 2017 #37
    Join Date : Jan 2017
    Posts : 13
    10 Pro 1607 x64, 7 Ultimate x64, Zorin, Ubuntu

    Quote Originally Posted by f14tomcat View Post
    @Kbird

    To clear the event logs, look at Shawn's tut:

    Event Viewer - Clear All Event Logs in Windows - Windows 10 Forums

    ----------------------------------------------------------------------------------------------------------------

    CAPI2 error can be fixed by running this command with Admin Command line. NOT Powershell! NO spaces. One continuous line.


    Code:
    sc sdset MSLLDP D:(D;;CCDCLCSWRPWPDTLOCRSDRCWDWO;;;BG)(A;;CCDCLCSWRPWPDTLOCRSDRCWDWO;;;SY)(A;;CCDCLCSWRPDTLOCRSDRCWDWO;;;BA)(A;;CCDCLCSWRPWPDTLOCRSDRCWDWO;;;SO)(A;;LCRPWP;;;S-1-5-80-3141615172-2057878085-1754447212-2405740020-3916490453)(A;;CCLCSWLOCRRC;;;SU)S:(AU;FA;CCDCLCSWRPWPDTLOCRSDRCWDWO;;;WD)
    Here is the supporting link:

    Error source CAPI2 id 513 - Cryptographic Services failed while processing the OnIdentity() call in the System Writer Object



    Excellent information and thank you also everyone else that helped.

    I have these in event log for Windows 10 Pro 64

    I did not have these in event log for 10 64 N one difference I can remember over the past few days setting 10 up is on N install I deleted it was getting thrown so many driver errors from my galaxy phone connection to pc and not being able to install drivers for it without media features I just wiped it.

    On this Pro install defaultuser0 slipped my mind till now

    I wonder if this is a factor?Click image for larger version. 

Name:	Pro-defaultuser0-tenforums.JPG 
Views:	2 
Size:	90.3 KB 
ID:	120240
      My ComputerSystem Spec
  8.    07 Feb 2017 #38
    Join Date : Jun 2016
    Posts : 1,468
    Win10 1607

    Not sure OdinSon ?, I am not aware of DefualtUser0 , or it's implications, as I do not have it listed like you do in the pic above.

    sorry I can't be more help.

    KB
      My ComputerSystem Spec
  9.    08 Feb 2017 #39
    Join Date : Jan 2017
    Posts : 13
    10 Pro 1607 x64, 7 Ultimate x64, Zorin, Ubuntu

    Quote Originally Posted by Kbird View Post
    Not sure OdinSon ?, I am not aware of DefualtUser0 , or it's implications, as I do not have it listed like you do in the pic above.

    sorry I can't be more help.

    KB

    btw tried the method 1st round actually getting x2 the error lol instead of 1 on reboot now has 2

    It is mentioned all over searches and in tenforums too

    tenforums: defaultuser0 site:www.tenforums.com‬‏ - بحث Google

      My ComputerSystem Spec
  10.    06 Apr 2017 #40
    Join Date : Dec 2015
    Athens, Greece
    Posts : 140
    Windows 10 Pro x64

    To resolve the EventID 513 CAPI2 errors, when making a backup or creating a restore point,
    In an elevated command prompt:

    1. Run: SC sdshow MSLLDP
    You will get an SDDL similar to that:
    D:(D;;CCDCLCSWRPWPDTLOCRSDRCWDWO;;;BG)(A;;CCDCLCSWRPWPDTLOCRSDRCWDWO;;;SY)(A;;CCDCLCSWRPDTLOCRSDRCWD WO;;;BA)(A;;CCLCSWRPWPDTLOCRRC;;;SO)(A;;LCRPWP;;;S-1-5-80-3141615172-2057878085-1754447212-2405740020-3916490453)

    2. If it's not exactly the same as this one (it'll most probably be), make a note of your SDDL by copying and pasting the string you received.

    3. Apply an extra permission for the NT SERVICE\CryptSvc, by adding the string: (A;;CC;;;S-1-5-80-242729624-280608522-2219052887-3187409060-2225943459) to the existing MSLLDP, right after the (A;;LCRPWP;;;S-1-5-80-3141615172-2057878085-1754447212-2405740020-3916490453) block

    4. To do that you should run the following command, making sure that there are no spaces or line breaks:
    sc sdset MSLLDP <Your SDDL>(A;;CC;;;S-1-5-80-242729624-280608522-2219052887-3187409060-2225943459)

    or in our example:
    Code:
    sc sdset MSLLDP D:(D;;CCDCLCSWRPWPDTLOCRSDRCWDWO;;;BG)(A;;CCDCLCSWRPWPDTLOCRSDRCWDWO;;;SY)(A;;CCDCLCSWRPDTLOCRSDRCWDWO;;;BA)(A;;CCLCSWRPWPDTLOCRRC;;;SO)(A;;LCRPWP;;;S-1-5-80-3141615172-2057878085-1754447212-2405740020-3916490453)(A;;CC;;;S-1-5-80-242729624-280608522-2219052887-3187409060-2225943459)
    That's it! No CAPI2 errors.
      My ComputerSystem Spec

 
Page 4 of 5 FirstFirst ... 2345 LastLast


Similar Threads
Thread Forum
Local Permission Hang - Plz Assist me
Am on Win 10 (64 Bits) and whenever I am using IE it suddenly stops responding and then sometime I can close via task manager and everything works and sumtimes whole computer freezes with most icons on taskbar missing - then I have to restart the...
General Support
Solved Need Administrator Permission
I'm trying to replace calc.exe in the System 32 folder with a version from XP, but keep getting a notice that I don't have permission. I'm in as the Administrator, what more do I need to do? Thanks!
Performance & Maintenance
I do not have permission????
I created a new user profile in windows 10 with administrator permission. Now when I try to access a file on drive f, I am denied permission to even open the folder. l hate windows permission, since I am the only one that has access to my...
General Support
Permission Issues
Windows 10 seems to have developed an issue for me that is causing UAC-like prompts suggesting that I need Administrator permission. I should probably mention that I am actually using the real Administrator account (this was an upgrade installation...
General Support
Solved Activation woes - Windows needs activation to personalize
Hi there anybody else got this -- trying to personalize PC -got you need to activate windows before you can personalize PC. Now what do I do !!!!!?! Is this normal (I did an UPDATE rather than a new install BTW). Cheers
Windows Updates and Activation
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 04:48.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums