Windows 10: Windows.old won't delete after todays update. Solved

  1.    03 Aug 2016 #1

    Windows.old won't delete after todays update.


    I selected remove previous versions of windows in disk cleanup and it deleted everything in window.old but one folder chain C:\Windows.old\WINDOWS\System32\DriverStore\FileRepository\nv_dispi.inf_amd64_87aa927b5db9eb5e

    It tells me I need permission and this account is admin on my pc, how can i delete this?
      My ComputerSystem Spec

  2.    03 Aug 2016 #2

    Hi there

    Try again after a reboot.

    If that fails a decent way is to load a Linux Live distro and then delete the file using the Linux file manager. These are called Dolphin, Nautilus, Midnight commander - depending on what Live distro you are using -- Linux Mint is a decently like "Windows" one if you aren't experienced in Linux.

    A reboot in Windows though should release the file if it's not being used anywhere.

    Cheers
    jimbo
      My ComputerSystem Spec

  3.    03 Aug 2016 #3
    Last edited by Brink; 03 Aug 2016 at 09:13. Reason: updated link for the same here
      My ComputersSystem Spec


  4. Posts : 142
    Windows 10 x64 Pro Build 15063.250
       03 Aug 2016 #4

    I renamed, moved to new location and deleted.
      My ComputerSystem Spec

  5.    03 Aug 2016 #5

    Nice solution
      My ComputersSystem Spec


  6. Posts : 42
    Win 10 Pro 64-bit (Anniversary 1607)
       03 Aug 2016 #6

    It's the drivers issue - some devices still use drivers located in the post-installation folders.

    A useful trick is to track the affected device, disable it for a while, delete the folder and re-enable it. It will use the proper driver (meaning located in the correct folder) since then.
      My ComputerSystem Spec

  7.    03 Aug 2016 #7

    hi guys, thanks for responding. I tried the disk cleanup method and it didn't work, then I tried renaming it and moving it into my downloads folder and now its just saying I require permission from IT/Michael (pc name/my name). I'm willing to try the linux thing suggestion but I don't really understand it, if someone could explain in more detail possibly.
      My ComputerSystem Spec

  8.    03 Aug 2016 #8

    I have a Linux Mint installation disk. I booted up with that and deleted the folder. This worked OK and no ill-effects noticed when booting into W.10 and running it.
      My ComputerSystem Spec

  9.    03 Aug 2016 #9

    Alright so I ended up using a program called EMCO MoveonBoot to delete the folder, it worked and don't have any issues to report so far. Thanks again for the replies.
      My ComputerSystem Spec


 

Related Threads
Does Update delete $WINDOWS.~BT before downloading the new one? Or does it just overwrite the existing files?
Since the update reboot Outlook is running in safe mode and though the reading panel is correctly set up it is closed every time Outlook is restarted. Add ones are all missing. I have no idea how to sort it short of removing all the updates. I have...
How do I delete windows 10 update in Installation and Upgrade
Hi Guys. Is there anyway I can stop this download 32112 thanks in advance
I have tried everything and finally I decided to to completely reset my Windows and reinstall win 10. It gave me the option of deleting the hard drive. Securley. I did. But if Windows 10 is on there how is it going to install? Plus my PC Ethernet is...
Insider updates from 10130 to 10158 to 10159 to 10162 in fairly quick succession, and tried to delete Windows.old. After an age at 98%, then having to manually skip a load of stuff, it still seems as full as ever. Is there an easy way to remove the...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 08:12.
Find Us