Windows 10: Cannot Access The Windows 10 Upgrade Pages From MS Solved

Page 1 of 2 12 LastLast
  1.    23 Jul 2016 #1

    Cannot Access The Windows 10 Upgrade Pages From MS


    I have been following these forums steadily over the past week and have not had to post, b/c have always been able to find what I was looking for, this is an amazing resource.

    OK, had to get that out there,
    My issue, All the links to the MS Windows 10 seem to be down, yet I don't see any info on this anywhere, making me think it is me. I have tried to link directly through MS, through their MCT and TechBench. Even the links from Ten Forums, all I get is a white page.

    No, I am not downloading multiple copies, Yes, I have d/l ONE copy from TechBench both Win 10 Pro, both the 32 and 54, and One Pro with MCT which I used to fix my original issue with the tutorials here on how to use sfc /scannow and Diam, and and in session repair. Took a but, but I did it.

    I'm not the most computer savvy, not the least, enough to get me into bigger holes it seems at times.
    Anyway, any info or ideas on the blank pages?
    I have restarted and in case it was a browser issue, same results.
      My ComputerSystem Spec


  2. Posts : 20,872
    64-bit Windows 10 Pro build 16199
       23 Jul 2016 #2

    Hello Lambert, and welcome to Ten Forums.

    The links in the tutorial below are currently working for me if you wanted to try them again. Do you have any add-ons or extensions installed in your browser that may be blocking or causing issue with this?

    https://www.tenforums.com/tutorials/9...-download.html

    If you still can't get them to work, then here's the Media Creation Tool from OPTION TWO above in a ZIP file below for you if you still need it.

    MediaCreationTool.zip
      My ComputersSystem Spec

  3.    23 Jul 2016 #3

    I just did a hard restart since I placed the post.
    I have tried that link numerous time successfully, just stopped about an hour or more ago. I just tried from your post and still goit the white screen.
    Yes, I have used the links many times, but only ever downloaded as I said above. I am one of those that I have to read and reread several time and views before I jump.
    My goal, I think I finally decided on,is to use Rufus to create a bootable USB for future loss protection.

    I do have the TechBench x64, so, I'm not desperate, but I went there to check the current version and to see if there was any new info. I cannot even get to the page where the downloads are, yet I can get to other pages in MS, and everywhere else. I was thinking maybe the servers may be overwhelmed since it's getting close to D-Day, 7/29.
      My ComputerSystem Spec

  4.    23 Jul 2016 #4

    just back from MS, and techbench. Attempted D/L, then it says to hit the D/L button, yet no D/L button is visible. Maybe b/c I already d/l them, yet thins has not occurred previously, yet I have not tried to D/L, but I cannot get to the pages I was at previously. Odd?
      My ComputerSystem Spec


  5. Posts : 20,872
    64-bit Windows 10 Pro build 16199
       23 Jul 2016 #5

    By chance, do you have a 3rd party download manager program installed?

    I had "Internet Download Manager" installed, and it caused the same thing for me until I uninstalled it.
    Last edited by Brink; 24 Jul 2016 at 00:05. Reason: typo
      My ComputersSystem Spec

  6.    23 Jul 2016 #6

    Just very odd, I do have a d/l but it's working, or, sounds like you said yours had been working, then stopped for a bit, maybe the traffic.
    I'm just glad they didn't stop it all early.
    But, amazing information here, I come here first, even before the MS forums, MANY thanks to all who contribute!
    If anyone else is having this issue it would be interesting to know.
    I think I am going to try to create the bootable vers tonight, that's for another thread though.....And I learned about Rufus from here as well.
    I may be able to become a mod after all of the tutorials and threads I have read, just one that maybe directs folks to the appropriate thread, and all the copy/paste has eaten up my memory, need to purchase more, thats a lot of copy / paste too.
      My ComputerSystem Spec

  7.    23 Jul 2016 #7

    I'm giving the Tech Bench link a try now. It says 10 minute's to D/L single language 10/ 64 bit.
      My ComputersSystem Spec

  8.    23 Jul 2016 #8

    OK its finished in about 8 minute's with no problem's at all.
      My ComputersSystem Spec

  9.    23 Jul 2016 #9

    Don't overcomplicate it. I upgraded two laptops (one Win7 one Win8.1) in the last two days and am about to do my desktop. Easy as pie with the MCT.
      My ComputerSystem Spec

  10.    24 Jul 2016 #10

    Well, I just checked the d/l link provided by Brink, and Shazam, it started up, I immediately shut it down, caught off guard. I sure do not want to overcomplicate this, just want to make a bootable USB stich so I can have as a just in case. My understanding was that Rufus was the way to go, maybe I should just give it a wip with the MCT. MCT worked for the image I used to repair my issue. For some reason, it's very late for me now, I thought there was issue doing this with mct, it wont capture UEFI? I need to dbl check on that.
    So, not sure why I couldn't access earlier, but, I can now.
    Whoop-Whoop!
      My ComputerSystem Spec


 
Page 1 of 2 12 LastLast

Related Threads
Common one this one, but in our case it wasn't a driver issue - it was a DNS issue! For us, this problem all seems to centre around DNS. Windows 10 seems to occasionally and randomly change which network adaptor it's going to route DNS requests...
Is everyone else getting blank pages at the Microsoft Windows 10 (and Windows 8) ISO download pages? Tech Bench Windows 10 Windows 8 ISO
I have a small network of 5 computers, one of them acting as 'server' to share a folder. This 'server's mapped folder was previously fully accessible to the other computers (Windows 7 Home and Windows 10 Home). Yesterday, I upgraded the 'server' to...
Hello, I updated from Windows 7 to 10 a few days back and I am having an issue with pages closing after :60 seconds. If If I go into DOS, the command windows will stay open. I've tried a clean boot and it doesn't help. Any suggestions?
Apologies if this has been addressed already but I haven't been able to find a post with this particular issue. Here's the background information: I have a Dell Vostro 3750 notebook which I upgraded from Windows 7 Home to Windows 10 using a...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 04:49.
Find Us