Screen does not always turn off according to Power & sleep settings


  1. Posts : 3
    Windows 10 x64
       #1

    Screen does not always turn off according to Power & sleep settings


    DESCRIPTION

    Please advise, I am trying to solve this puzzle.. Basically screen wont always turn off according to the settings set in Power & sleep. Sleep, on the other hand, works.
    Sometimes monitor will turn off correctly after a set time, say if I set a minute or two just to test then it works. But 15 minutes never work. Sometimes if I change additional power settings back and forth it starts to work, but only until next restart.
    I can't find a solution nor cause of this problem. Windows 7 power settings worked correctly.

    SYSTEM INFO

    Windows 10 is cleanly installed on HDD in UEFI mode and I am using/testing it only for a few days yet. Slow ring updates. No additional USB devices are connected except keyboard and mouse. PC is quite new, Skylake based (i5 6600, Asus Z170M-PLUS, R9 390).

    THINGS I HAVE TRIED AND RESULTS


    • Clean boot and Safe mode - same.
    • Updating BIOS - same.
    • Disabling USB selective suspend - same.
    • Booting without mouse - same.
    • Testing for wake armed devices with powercfg and disabling LAN adapter wake - same.
    • Using USB 3 instead of USB 2 to connect mouse & keyboard - nothing.


    "Some" results:


    • Generating powercfg /energy report. Report shows error "USB Suspend:USB Device not Entering Selective Suspend". Windows 7 did not show such error (hardware switch dual boot, easy to compare).
    • Disconnecting and reconnecting mouse while system is on - display turns off correctly after, but only until next restart..
    • Switching Power plans back and forth - again, starts to work, until next restart.
    Last edited by AeroJ; 16 Jul 2016 at 16:06.
      My Computer


  2. Posts : 3
    Windows 10 x64
    Thread Starter
       #2

    Any ideas what I should try next?
    I would like to move to W10 (due to DX12 etc.), but a few small quirks like this bug me for some reason
      My Computer


  3. Posts : 3
    Windows 10 x64
    Thread Starter
       #3

    Windows 10 update 1607 (Anniversary) fixed this issue! :)
      My Computer


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 05:18.
Find Us




Windows 10 Forums