After Installing Windows 10, Freezes At Random Times

Page 1 of 3 123 LastLast

  1. Posts : 25
    Windows 10 32bit
       #1

    After Installing Windows 10, Freezes At Random Times


    I installed Windows 10 fine on a computer that had Windows 7, clean install on a brand new hard drive. After the clean install, I made sure drivers were up to date and what not. Everything works great, except the computer freezes at some point while on any browser. At first I thought it was a browser problem with chrome, but then it happened on Microsoft Edge browser. I was hoping the community here maybe had an idea on what to do.
      My Computer

  2. philc43's Avatar
    Posts : 4,355
    64bit Win 10 Pro ver 1909 Build 18363.535 and W10 Insider Ver 2004 Build 19536
       #2

    Please fill in your system specs as much as possible so that we can help you.

    System Specs - Fill in at Ten Forums
      My Computers


  3. Posts : 25
    Windows 10 32bit
    Thread Starter
       #3

    Specs have now been filled out. Sorry about that!
      My Computer

  4. philc43's Avatar
    Posts : 4,355
    64bit Win 10 Pro ver 1909 Build 18363.535 and W10 Insider Ver 2004 Build 19536
       #4

    Thanks! Did you install the ASRock drivers for all the components? In many cases I have found that the drivers that W10 chooses are often fine. This is particularly so for the Intel Management Driver. You could try rolling back the driver and see if it makes a difference.
      My Computers


  5. Posts : 25
    Windows 10 32bit
    Thread Starter
       #5

    Yes, I believe I installed all the drivers. How can I check to make sure I got everything?
      My Computer

  6. philc43's Avatar
    Posts : 4,355
    64bit Win 10 Pro ver 1909 Build 18363.535 and W10 Insider Ver 2004 Build 19536
       #6

    Device Manager is the way (right click on your start icon). You can check the date and version of all the drivers for the various components. Double click each item to open the properties page and look in the driver tab.
      My Computers



  7. Posts : 25
    Windows 10 32bit
    Thread Starter
       #7

    Going through the Device Manager the first time, I just updated the ones that had little cautions by them which was only 1. However, now I am going through every single one and clicking update just in case.

    So far it has updated:
    Intel B85M LPC Controller
    Processor DRam Controller
    PCI Express Port #1
    PCI Express Root Port #4
      My Computer

  8. philc43's Avatar
    Posts : 4,355
    64bit Win 10 Pro ver 1909 Build 18363.535 and W10 Insider Ver 2004 Build 19536
       #8

    The ASRock drivers provided for your motherboard are listed here:

    http://www.asrock.com/mb/Intel/B85M/...nload&os=Win10

    Did you install any of these?

    It is not necessary to check everything in device manager but I would concentrate on the graphics and audio drivers.
      My Computers


  9. Posts : 25
    Windows 10 32bit
    Thread Starter
       #9

    I think only the Intel Management Engine driver because that was one of the ones that had a caution sign on it right after I installed Windows 10.
      My Computer

  10. philc43's Avatar
    Posts : 4,355
    64bit Win 10 Pro ver 1909 Build 18363.535 and W10 Insider Ver 2004 Build 19536
       #10

    Try the ASRock provided VGA driver and see if that makes any difference
      My Computers


 
Page 1 of 3 123 LastLast

Related Threads
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 21:05.
Find Us




Windows 10 Forums