Windows 10: How to replace system file? Solved

  1. Posts : 64
    Win 10 Pro X64, Win 10 Home X64, Win 7
       18 Jun 2016 #1

    How to replace system file?

    I have a major problem on my desktop Win 10 Pro X64 computer. I won't go into all the detail since I'm still problem solving on my own. However, I do need help with one issue so I can continue problem solving.

    Part of the problem is that my mouse is not working and it really hard to navigate. The device manager reports that the driver is unable to load and may be damaged. Looking at the drivers, file hidclass.sys is 0KB and I suspect that is the problem with the mouse (that file is 152KB on my laptop). I've tried to update the driver but Windows tells me that I have the latest edition. Removing the drivers and uninstalling the device from within Device Manager didn't correct the issue. I've tried to connect a different mouse on a different USB port and also tried a wireless mouse but all failed.

    Now I'm trying to manually delete the hidclass.sys file so a new version can be installed. However, I get a window telling me that I need permission from "TrustedInstaller" to do this. Every time I push "Try Again", end up with the same message.

    Any idea how I can delete or update this driver?
      My ComputerSystem Spec

  2.   My ComputerSystem Spec

  3. Posts : 64
    Win 10 Pro X64, Win 10 Home X64, Win 7
    Thread Starter
       20 Jun 2016 #3

    NavyLCDR said: View Post
    I followed the instructions in the link but when I click (pressing enter since the mouse isn't working) on the "change" link of the "Advanced Security Settings" window, the Advanced Security Settings window closes. The "Select User or Group" window doesn't open.

    I tried the same thing on my working laptop and it works as described in the link.

    Then I connected to my desktop from my laptop using TeamViewer so I could use a mouse remotely. That seemed to partly work. I was able to change ownership to the same name that owns my data files. That worked.

    Now when I try to delete the file, I get the message "You need permission to perform this action....". Pressing "try again" gives me the same result.

    I also tried to copy a new version of the file with the same result.

    -The owner name that I assigned to the system file is "" which is the computer logon ID and the owner name of my data files.
    -The "You need permission to perform this action" window says I need permission from "computername/username which is different from the logon id.
    (In case this isn't clear, I won't use real names but my logon ID is "". My computer name is ASUS/User2.
    -I tried to change ownership of the file to ASUS/User2 but it wouldn't accept that name.

    Any ideas?
    Last edited by dsscottage; 20 Jun 2016 at 09:47.
      My ComputerSystem Spec

  4.    20 Jun 2016 #4

    Change the actual security permission on the file to allow full access to "everyone".

    You can also make a USB flash drive or CD/DVD of Kyhi's recovery drive and boot the computer from that. That should give you mouse usage again and might be able to work more with the troubled file from file explorer on Kyhi's recovery drive.

    Windows 10 Recovery Tools - Bootable Rescue Disk - Windows 10 Forums
      My ComputerSystem Spec

  5. Posts : 64
    Win 10 Pro X64, Win 10 Home X64, Win 7
    Thread Starter
       20 Jun 2016 #5

    Thank you

    Thank you so much NavyLCDR

    I did as you said and gave "everyone" "Full Control" and was able to delete the file.

    After that, I moved a correct copy of "hidclass.sys" to the desktop, uninstalled the non working mouse hardware from device manager, then scanned for new hardware and the mouse is now working.

    Now, I'm able to more readily pursue my major problem on the desktop. (If i'm unsuccessful, I may be back for more help!)

    Thank you again. You are a star!
      My ComputerSystem Spec

  6. Slartybart's Avatar
    Posts : 3,506
    Win_8.1-Pro, Win_10.1607-Pro, Mint_17.3
       20 Jun 2016 #6

    I think it might be easier to run the System File Checker (SFC) to correct system files.
    I'm fairly certain that hidclass.sys is in the component database.

    Command Prompt (Admin)

    SFC /ScanNow
      My ComputerSystem Spec


Related Threads
system file checker in Performance & Maintenance
so my win 10 pc has found corrupt files but was unable to fix some of them. who knows how many. what is the best way to find and fix the corrupt files? I tried dism, but no source found. do we have good quick way of doing this? I upgraded from...
I have noticed Windows 10 has a path: This PC > Local Disk (C:) > Users > there In Windows 7 "there" was my first name. They have even added a path like this in my Documents folder that I have in an external back up hard drive. 1. What is...
I'm trying to copy a ripped movie file (iso) from my G drive to desktop. The file is 45GB. It gets to 99% then a message comes up saying the process can't complete because the System has the file open. I have nothing running and can't find anything...
file system in General Support
I have just updated to win 10. all looks good except I am unable to access my data files from win 8.1. The data was in c:\data and backed up to E:\data and to a thumb drive which shows as G:\data. File Explorer hangs when asking for the...
The File System in Windows 10 in General Support
I was just wondering whether there has been any mention of updates for NTFS. I remember some time ago they were thinking of changing away from NTFS but that never happened. So do we know if NTFS has been changed/modified in any way for Windows 10?
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 11:24.
Find Us