Page 1 of 2 12 LastLast
  1.    09 Jun 2016 #1
    Join Date : Jun 2016
    Posts : 7
    Windows 10

    Weird Problem with UEFI USB System Recovery


    Hello everyone, I'm not sure this is the right place to post this, as I'm new in the forums.
    First of all, let me start by saying this problem came up when I accidentally turned off the PC while it was loading the OS. Next time I tried to start Windows, it came up with an error on the Windows Boot Configuration Data (BCD). After a quick search on google I found out it was possible to repair it with a flash drive and a windows 10 ISO. After downloading the ISO from microsoft's page, I used Windows 7 USB/DVD tool to pass the ISO into the USB. I managed to boot with the USB in legacy mode, and it turns out that it can't access the main drive (which is UEFI). Therefore, I used Rufus to create an USB UEFI compatible with the system. When I try to boot it, it's not able to use the USB even tough it's already in UEFI. (It does appear on the boot priority as UEFI, the USB is in FAT32, and secure boot deactivated) All kind of feedback is appreciated and thanks in advance
      My ComputerSystem Spec
  2.    09 Jun 2016 #2
    Join Date : Jul 2015
    Posts : 9,551
    Windows 10 Pro

    Did you format the USB as FAT32? Rufus is completely unnecessary for making a UEFI bootable USB flash drive. All that is required is to format it as FAT32 and copy the files from the ISO file to it, like you would copy the files from a zip file.
      My ComputerSystem Spec
  3.    09 Jun 2016 #3
    Join Date : Jun 2016
    Posts : 7
    Windows 10
    Thread Starter

    I did, I'm going to try doing it manually and I'll tell you how it goes. Thanks for the help !
      My ComputerSystem Spec
  4.    09 Jun 2016 #4
    Join Date : Jun 2016
    Posts : 7
    Windows 10
    Thread Starter

    Okay, this is weird. After trying to do it manually I get the same results, it's not able to boot from the USB. I tried doing it in legacy mode (In the boot devices it appears as UEFI), and suddenly it's able to boot again. The problem now is, that while it's on legacy mode, it says that the drive is locked and that it can't repair it. Maybe I can use the command prompt in some way as to fix it, but I'm not sure
      My ComputerSystem Spec
  5.    09 Jun 2016 #5
    Join Date : Jun 2015
    Posts : 1,929
    Windows 3.1 to Windows 10

    you can not access a gpt/uefi disk in legacy mode...

    you will have to use the boot menu option F12 usually to select the uefi usb drive...

    the media should boot if the usb is formatted fat32 and the media has a bootmgr.efi file and an EFI folder...
      My ComputerSystem Spec
  6.    09 Jun 2016 #6
    Join Date : Jun 2016
    Posts : 7
    Windows 10
    Thread Starter

    If I can't access an uefi disk in legacy mode then that means the actual disk is not in uefi, the usb is in fat32 and it has the bootmgr.efi file along with the EFI folder. I'm still wondering if I can do something from the command prompt to fix it, but it seems it can't fix the UEFI drive if it's on legacy mode, and I can't boot unless it's on legacy mode. Thanks for the help.
      My ComputerSystem Spec
  7.    09 Jun 2016 #7
    Join Date : Jun 2015
    Posts : 1,929
    Windows 3.1 to Windows 10

    If I can't access an uefi disk in legacy mode then that means the actual disk is not in uefi format
      My ComputerSystem Spec
  8.    09 Jun 2016 #8
    Join Date : Jun 2016
    Posts : 7
    Windows 10
    Thread Starter

    Sorry for the wording, I meant that I could only access the usb disk in legacy mode, therefore is not in uefi format
      My ComputerSystem Spec
  9.    09 Jun 2016 #9
    Join Date : Jul 2015
    Posts : 9,551
    Windows 10 Pro

    This is what I do and has been proven to be the most reliable method of booting from USB, installing Windows 10, and fixing other computer problems. Download the newest Media Creation Tool:
    Windows 10

    Use the options in the Media Creation Tool to allow it to make the Windows 10 installation USB flash drive for you.

    Then download Kyhi's recovery drive:
    Windows 10 Recovery Tools - Bootable Rescue Disk - Windows 10 Forums

    Now go the sources folder on the Windows 10 installation USB flash drive created by Media Creation Tool. Rename the boot.wim file there to boot.bak. Copy the boot.wim file from Kyhi's recovery drive ISO to the sources folder on the Windows 10 installation USB flash drive.

    Boot the computer from the USB flash drive. It will boot into Kyhi's recovery drive. Using MiniTool Partition Wizard free you can prepare your hard drive/SSD for a clean Windows 10 installation by deleting all the partitions from it. Then either initialize or convert the hard drive or SSD to GPT for UEFI install or MBR for legacy install. Leave the drive completely unallocated - no partitions on it. Go to file manager and run setup.exe from the Windows 10 installation USB flash drive.

    NOTE: The Media Creation Tool creates a Windows 10 installation USB flash drive that is bootable both in legacy BIOS mode and UEFI.
      My ComputerSystem Spec
  10.    09 Jun 2016 #10
    Join Date : Jun 2016
    Posts : 7
    Windows 10
    Thread Starter

    Thanks ! I'm going to use Kyhi's recovery drive (Seems like an awesome tool) and I'll tell you how it goes.Also, forgive my ignorance, but wouldn't deleting all the partitions erase the data on the drive ?
      My ComputerSystem Spec

 
Page 1 of 2 12 LastLast


Similar Threads
Thread Forum
Solved Boot Trouble, system partitions and UEFI
Hi, So I thought I'd sling a new disk in my system. And then the OS wasn't seeing it so instead of looking in disk manager I just swapped the cables for my D: drive and powered on. The boot config was missing and Win 10 wouldn't boot. Somehow my...
General Support
Weird FPS problem..
Hi! I'm new here and I'm not exactly sure if here is the right place to ask this but here I go... I have 2 games in which I am having problems with: => League of Legends - FPS starts out great... 140 fps when the game starts - 60 fps when...
Gaming
Ideas to reduce DPC latency and weird system pollings
So, I updated my machine from i5 with 8gb to i7 6700K that I run at 4.5Ghz with 16GB of 2600Mhz RAM and a VNAND drive right on the motherboard. Asus Maximus 8. With hopes of speeding up the system of course. Well, it ain't working. The system...
Performance & Maintenance
Solved Hi experts - how can I install on RAID 0 non UEFI system
Hi there Any experts out there I've rescued an old small server(working with Red Hat enterprise -- but I can't have the OS as it's licensed by the office) from our office --was being chucked out but looks quite good to me. 4 SATA bays...
Installation and Upgrade
Partition Question - First UEFI system
So I just completed a clean install on my new Pavilion X360 laptop. I've been building computers and working in IT for 20 years, but I've come across something I haven't dealt with before. I'm always used to using diskpart to set up my drives...
General Support
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 05:49.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums