Windows 10: Can a small hard drive converted to gpt & Can you format a virtual...?


  1. Posts : 1,551
    W7 32 bit, Linux Mint Xfce 18 64 bit
       03 Apr 2015 #1

    Can a small hard drive converted to gpt & Can you format a virtual...?


    Can a small hard drive be converted to gpt & can you format a virtual drive as gpt with secure boot on? It looks like Microsoft is going to require Uefi enabled not sure about secure boot though for upgrade. I think that why I am had issues with build 10049. I am not using windows 10 at the present in any form.
      My ComputerSystem Spec


  2. Posts : 12,393
    Windows 10 Pro
       04 Apr 2015 #2

    What on earth are you talking about? UEFI is not required, nor is secure boot.
      My ComputerSystem Spec


  3. Posts : 1,551
    W7 32 bit, Linux Mint Xfce 18 64 bit
    Thread Starter
       04 Apr 2015 #3

    I disagree Kari. A previous build worked without issue but for 10049 it wouldn't install or kept crashing after installed. Something has changed.
      My ComputerSystem Spec

  4.    04 Apr 2015 #4

    Hi there

    No problem changing a small HDD / SSD to GPT but there IMO is no advantage in doing that - especially if it's say a small SSD (120 to 256 GB). Having a small MBR boot drive gives you the maximum flexibility.

    A UEFI computer can boot an MBR drive though. SECURE boot is another thing entirely --currently it can be disabled (and should be if you are testing all sorts of OS'es)

    I'm not sure but if you still have W7 as a boot system I don't think that some versions will allow a boot from a GPT drive although it can of course READ and WRITE to other GPT drives. (Might be wrong on that but I'm sure W7 and GPT had issues as boot drive).

    Cheers
    jimbo
      My ComputerSystem Spec

  5.    04 Apr 2015 #5

    Not everyone is having issue's at all. The only issue's I've personally had using all the Windows 10 build's since October were as follows. 1. In the early builds running them in VirtualBox until February when I got a bigger ssd, kept hogging to much of my old 256GB. ssd with 10 & 8.1 on it. 2.This one was my mistake with configuring Rufus, I didn't set the 1st step to GPT, so EFI wouldn't show up for my flash drive and SecureBoot didn't get turned on. I fixed that one and everything is fine.What I have noticed in both Windows 10 TP 10041 & 10049 is that 3DMark Advanced doesn't score better in those 2 builds than Windows 8.1 Pro does. **SIDE NOTE** Don't use Microsoft's USB/DVD Tool if your pc has a UEFI, you'll never get the EFI option for your flash drive or a dvd, thus no SecureBoot.
      My ComputerSystem Spec


  6. Posts : 1,551
    W7 32 bit, Linux Mint Xfce 18 64 bit
    Thread Starter
       04 Apr 2015 #6

    I wish I knew why it keep crashing 10049 or not installing either by vm or actual hard drive. The last time I tried it took over two hours to install 10049, then after installed it booted and ran for awhile, it crashed. I couldn't get the error message it rebooted to quickly. Same thing happen with the 32 bit install as well.

    My hard drive is 500 gb but windows was installed on 125 gb partition? Should the partition be bigger? I am trying a experiment in vmplayer. I converted the virtual drive to gpt. 10041 installed without issue in the vm. Now, I will see if it crashes one upgrade to 10049.

    Updated
    Did install differently it is working so far. Haven't tried upgrading yet.
    Last edited by groze; 05 Apr 2015 at 09:44. Reason: Update
      My ComputerSystem Spec

  7.    05 Apr 2015 #7

    You may need to do a search for Mail, People & Calenadar. In both build 10041 & 10049 they don't work. You need to open PowerShell as administrator and enter the command you find in the search you did. Then open the non-beta Store and redownload the Mail, Calendar & People apps. As far as 10049 not installing disable your antivirus software. It can't be enabled during a os upgrade. Make sure your other software & drivers are up to date first, too.Also, make sure your ram timings are correct first in your uefi or bios.
      My ComputerSystem Spec

  8.    05 Apr 2015 #8

    If you already have Windows 10 build 10041 installed, the Mail, People & Calendar bug could be preventing the upgrade. Follow the instructions for PowerShell in build 10041, then redownload them in the store. Then retry the update to 10049. After 10049 is installed redo the PowerShell command and Mail, People & Calendar reinstall through the regular Store again.
      My ComputerSystem Spec


 

Related Threads
Hello i updated to this build ( which is really stable BTW). I tried to mount an iso but it didnt mount. Then tried with daemon tools but still no luck. I went to device manager and it shows a yellow caution mark beside my dvd drive and the...
As per title, i have this annoying issue. Having a 3TB hard drive in win7, after partitioning normally the first 2GB of it, i opted to use partition wizard to partition the remaining 1GB of the drive. It did so, i assume, by creating a permanent...
Solved partitioning hard drive in General Support
hi all this is a question about GPT UEFI and LEGACY partitions if I install in legacy mode on a 1 TB drive with no partitions will my laptop run ok I dont understand why GPT gives 4 partitions and I dont understand UEFI please explain all 3 options....
Solved Can't format external USB drive. in Drivers and Hardware
I am trying to format 2 partitions on an external 1TB USB3 drive. I had 2 ExFat partitions (partitions 6 and 7) which I have deleted and created 2 new ones using diskpart which I want to format NTFS. When I try to format them using disk...
What is the Best Hard Drive? in Windows 10 News
Read more: https://www.backblaze.com/blog/best-hard-drive/
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 13:50.
Find Us