1.    27 May 2016 #1
    Join Date : Aug 2015
    Posts : 5
    Windows 10

    Proxy Explorer window search function does not work


    As the title implies, the search function on the Explore window does not work but only when Explore is being used by another program to open a file. That is a if I were to open Explore by itself I can search just fine. If on the other hand I open up a program and the program has an "Open" function, which brings up Explore the search option within Explore, Explore does not work.

    This problem is only affecting the two video players that I have installed MPC-HC and VLC. I have tried uninstalling clearing "program data", "app data", and running registry cleaner, and the problem persist. There is no commonality with the programs being affected aside from both being video players.

    I can't pull up any information about this problem from web search engines because it always gets mixed up with Explore Search not working in general.
      My ComputerSystem Spec
  2.    27 May 2016 #2
    Join Date : Jan 2015
    UK, Midlands
    Posts : 11,115
    Win 10 Pro (1703)

    Hello, I think this may be because search in that context may be limited to which folders you actually have indexed (you can check/change that in Control Panel, Indexing Options).

    So, I find search as you say does nothing if the Open dialogue has a non-indexed folder open, but works if I choose one which is indexed.

    No one claimed Windows search is entirely rational. Another oddity, apparently, assuming what I've seen is consistent.
      My ComputerSystem Spec
  3.    27 May 2016 #3
    Join Date : Aug 2015
    Posts : 5
    Windows 10
    Thread Starter

    I checked that before asking here. The folder in question was indexed. I can also search that folder with other programs. I can't search other folders with the programs in question.
      My ComputerSystem Spec
  4.    27 May 2016 #4
    Join Date : Jan 2015
    UK, Midlands
    Posts : 11,115
    Win 10 Pro (1703)

    So I think you are saying that search from your open dialogue box from e.g. VLC player does not work even if the folder open has been indexed (whereas from most other programs it does). You have confirmed search in explorer (of the same folder) works. I find that search from an open dialogue box from VLC player does work provided the folder open has been indexed.

    Sorry, I can add no more. Perhaps someone else may have an idea.
      My ComputerSystem Spec
  5.    27 May 2016 #5
    Join Date : Aug 2015
    Posts : 5
    Windows 10
    Thread Starter

    After rebuilding the index cache, which did not solve the problem, I found a some what ok solution. The Open window has a dialog for file type, which is set to video files in both VLC and MPC HC. If I set it to "All files (*.*)", the search function works properly. I tested this out in other programs, some of them have the dialog set to "All files (*.*)" by default, but some of them don't and they still work.

    Well regardless of that, this has sort of clued me in to what might be going on.

    Programs register their file type usually on installation, which is something MPC does not do, I think. I have MPC set as my default video player, and VLC as back up. MPC has a an option to register all file types that it can play. This includes audio files. I don't want windows to default to MPC when playing audio files, so I usually opt out of associating all file types. This means that MPC is not registering all of it's known file types. MPC's Open window defaults to "All Media" file type. but index does not recognize all of MPC file types. VLC is my back up so I don't associate file types with it.

    I am rebuilding index cache right now, hoping this will be solved.

    UPDATE:
    Not working, however setting the dialog to specific file types other than "All Media" seems to work. Which I am guessing means "All Media" includes a specific file type which is not registered.
      My ComputerSystem Spec
  6.    28 May 2016 #6
    Join Date : Jan 2015
    UK, Midlands
    Posts : 11,115
    Win 10 Pro (1703)

    Hi, strange, I know I tried that before; trying it again with vlc player, search works in any folder- indexed or not- in the open dialogue, provided as you say All files is selected. Which is actually reasonable.

    Note that defaults are not set from within programs (from Win 8). VLC player is one of the very few that gives a warning about that.
    This can be very confusing e.g. for people coming from win 7.
      My ComputerSystem Spec
  7.    28 May 2016 #7
    Join Date : Aug 2015
    Posts : 5
    Windows 10
    Thread Starter

    Quote Originally Posted by dalchina View Post
    Note that defaults are not set from within programs (from Win 8).
    Yeah I have known about this. However programs are allowed to register their file type used to generate a global list, which the index program uses. I am guessing that it is related to that, or alternatively the file type dialog in the Open Explorer window, which seems to be generated by the particular program that uses it.

    There is an open ticket for file association in Windows 10 in the MPC HC forums, although none about search function.

    Does the "media files..." options in the file type dialog of Open for VLC work when you try to search? I am referring to the option highlighted in red BTW.
    Click image for larger version. 

Name:	Untitled.png 
Views:	2 
Size:	2.4 KB 
ID:	82057
      My ComputerSystem Spec
  8.    28 May 2016 #8
    Join Date : Jan 2015
    UK, Midlands
    Posts : 11,115
    Win 10 Pro (1703)

    Yep- I get the expected drop-down with All files at the bottom.

    (And if a registered program is installed that can open extensions whose association is already established, that gives rise to the extraneous 'Open With' prompt which people understandably find annoying when they have already set the association).
      My ComputerSystem Spec

 


Similar Threads
Thread Forum
Solved 7-like alternative to windows 10 search function?
Hey guys, So a few months ago I updated from windows 7 to 10, and for the most part I've liked the transition. But one key problem that's been persisting since the upgrade is the search function. Windows 7 had a very clean search bar, where you...
General Support
Search function not working
Hello, When I type anything in the search, nothing shows up. really frustrating, what can I do to fix it? Thanks
General Support
Search The Web And Windows Function Not Working
I cannot enable the SEARCH THE WEB AND WINDOWS function on Windows 10. When I click on it, the hourglass icon flickers on and immediately disappears. Has anyone else experienced this problem?
General Support
Start menu and Search/Cortana do not function
Sometimes Start menu and Search/Cortana buttons become frozen and only after hard boot they work.
General Support
PC Search function after deleting Cortana
If I take ownership and delete Cortana from Windows/SystemApps will my search function on the taskbar still work (that is, search within the PC)?
General Support
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 17:11.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums