Windows 10: Notification area icon problems Solved

  1.    24 May 2016 #1

    Notification area icon problems


    Hey guys,

    A few days ago I started getting a pop up error message when I log in to windows.



    Aside from this error, which from what I understand says that it is having trouble loading the icon in the notification area, I also noticed that the icons for some other startup apps would fail to load eventhough the apps succesfully load up and run in the background.

    The ones I noticed are:

    Netdrives (The one giving the aforementioned error)
    Skype
    Displayfusion
    Steam (only happens sometimes)

    So what is puzzling me even more is that if I do a system restore to a date before this problem started, it would seemingly fix it. But after a restart or two, it would come back.

    So I'm not sure whether it is some update to one of these apps causing this or what exactly it is. But I'm not entirely sure where to start troubleshooting this other than just start uninstalling apps and seeing whether one of them is the culprit.

    So I'm hoping that the knowledgeable members on here would point me in the right direction.

    Thanks in advance for any assistance
      My ComputerSystem Spec

  2.    24 May 2016 #2

    Hi,

    Netdrives (Here) is well above version 1.0.4.0 now (Latest Windows is 2.6.9) & recommends users of Windows 10 to re-install after upgrading. Does this apply to you?

    NOTE for Windows 10 users: You may need to reinstall NetDrive when you are upgrading from previous versions of Windows.
      My ComputerSystem Spec

  3.    24 May 2016 #3

    That does not seem to be the same application

    This is the one I'm using

    hardcodet.net Simple Network Share Management

    It's only used to automatically map my network drives upon login since windows cant seem to do a decent job at it. It's a very old app that does not seem to be updated anymore but I havent found any alternatives so far. I'm open to suggestions.
      My ComputerSystem Spec

  4.    24 May 2016 #4

    I may contact the developer of the app to see if he may have any ideas but I don't think the underlying problem is due to netdrives since I have detected other apps that are also affected by it. This is just the only one giving an error message.
      My ComputerSystem Spec


  5. Posts : 23,589
    64-bit Windows 10 Pro build 16362
       24 May 2016 #5

    Hello MoogLe, and welcome to Ten Forums.

    You might see if reinstalling NetDrives may help if something is just corrupted with it.

    For the others, you might see if resetting the notifications area icons may help.

    https://www.tenforums.com/tutorials/5...dows-10-a.html
      My ComputersSystem Spec

  6.    24 May 2016 #6

    Brink said: View Post
    Hello MoogLe, and welcome to Ten Forums.

    You might see if reinstalling NetDrives may help if something is just corrupted with it.

    For the others, you might see if resetting the notifications area icons may help.

    https://www.tenforums.com/tutorials/5...dows-10-a.html

    thanks for the welcome!

    I will definitely try those suggestions!
      My ComputerSystem Spec

  7.    25 May 2016 #7

    So I tried the suggestions and it did not help.

    Here is exactly the order of what I did.

    I started by opening up the "Select which icons appear on the taskbar" list and noticed that some of the apps that are giving me issues were set to off in this list. So I switched them on but it did not seem to do anything.

    So I then uninstalled netdrives and followed the guide to reset the notification area and restarted.
    Ofcourse no more netdrives error since it is not installed, but problem still persisted with the other applications. I'm still not getting an icon for displayfusion, skype, steam etc

    I again opened up the "Select which icons appear on the taskbar" list and noticed that allot of apps were missing including most of the problematic apps.

    I decided to reinstall netdrives, restart and error message came back.

    So I'm pretty much in the exact same place I started.

    I also found a log file for netdrives and decided to post it up here since maybe that might make some sense to the more advanced members

    I don't know this seems to me like windows is somehow blocking access to the notification area to some applications. I've been using this app for 2-3 years with no problems and this really came out of nowhere.


    <Error> -- 25-May-16 5:25:36 PM --
    ********************
    25-May-16 5:25:36 PM
    Severity: Error


    Event ID = 0
    Priority = -1
    System.Windows.Markup.XamlParseException: Cannot create instance of 'TaskbarIcon' defined in assembly 'Hardcodet.Wpf.TaskbarNotification, Version=1.0.4.0, Culture=neutral, PublicKeyToken=null'. Exception has been thrown by the target of an invocation. Error in markup file 'NetDrives;component/Shared/Menus/MenuResources.xaml'. ---> System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. ---> System.ComponentModel.Win32Exception: Could not create icon data
    at Hardcodet.Wpf.TaskbarNotification.TaskbarIcon.CreateTaskbarIcon()
    at Hardcodet.Wpf.TaskbarNotification.TaskbarIcon..ctor()
    --- End of inner exception stack trace ---
    at System.RuntimeTypeHandle.CreateInstance(RuntimeType type, Boolean publicOnly, Boolean noCheck, Boolean& canBeCached, RuntimeMethodHandle& ctor, Boolean& bNeedSecurityCheck)
    at System.RuntimeType.CreateInstanceSlow(Boolean publicOnly, Boolean fillCache)
    at System.RuntimeType.CreateInstanceImpl(Boolean publicOnly, Boolean skipVisibilityChecks, Boolean fillCache)
    at System.Activator.CreateInstance(Type type, Boolean nonPublic)
    at System.Windows.Markup.BamlRecordReader.CreateInstanceFromType(Type type, Int16 typeId, Boolean throwOnFail)
    --- End of inner exception stack trace ---
    at System.Windows.Markup.XamlParseException.ThrowException(String message, Exception innerException, Int32 lineNumber, Int32 linePosition, Uri baseUri, XamlObjectIds currentXamlObjectIds, XamlObjectIds contextXamlObjectIds, Type objectType)
    at System.Windows.Markup.XamlParseException.ThrowException(ParserContext parserContext, Int32 lineNumber, Int32 linePosition, String message, Exception innerException)
    at System.Windows.Markup.BamlRecordReader.CreateInstanceFromType(Type type, Int16 typeId, Boolean throwOnFail)
    at System.Windows.Markup.BamlRecordReader.GetElementAndFlags(BamlElementStartRecord bamlElementStartRecord, Object& element, ReaderFlags& flags, Type& delayCreatedType, Int16& delayCreatedTypeId)
    at System.Windows.Markup.BamlRecordReader.BaseReadElementStartRecord(BamlElementStartRecord bamlElementRecord)
    at System.Windows.Markup.BamlRecordReader.ReadElementStartRecord(BamlElementStartRecord bamlElementRecord)
    at System.Windows.Markup.BamlRecordReader.ReadRecord(BamlRecord bamlRecord)
    at System.Windows.Markup.BamlRecordReader.ReadElement(Int64 startPosition, XamlObjectIds contextXamlObjectIds, Object dictionaryKey)
    at System.Windows.ResourceDictionary.CreateObject(Int32 valuePosition, Object key)
    at System.Windows.ResourceDictionary.RealizeDeferContent(Object key, Object& value, Boolean& canCache)
    at System.Windows.ResourceDictionary.GetValueWithoutLock(Object key, Boolean& canCache)
    at System.Windows.ResourceDictionary.GetValue(Object key, Boolean& canCache)
    at System.Windows.ResourceDictionary.GetValueWithoutLock(Object key, Boolean& canCache)
    at System.Windows.ResourceDictionary.GetValue(Object key, Boolean& canCache)
    at System.Windows.Application.FindResource(Object resourceKey)
    at Hardcodet.NetDrives.Util.AppUtil.InitSystemTray()
    at Hardcodet.NetDrives.ViewModel.AppController.MinimizeToTray()
    at System.Windows.Application.<.ctor>b__0(Object unused)
    at System.Windows.Threading.ExceptionWrapper.InternalRealCall(Delegate callback, Object args, Boolean isSingleParameter)
    at System.Windows.Threading.ExceptionWrapper.TryCatchWhen(Object source, Delegate callback, Object args, Boolean isSingleParameter, Delegate catchHandler)
    ********************
      My ComputerSystem Spec


  8. Posts : 23,589
    64-bit Windows 10 Pro build 16362
       25 May 2016 #8

    If you like, you might see if doing a repair install of Windows may be able to fix this without losing anything.

    Repair Install Windows 10 with an In-place Upgrade
      My ComputersSystem Spec

  9.    28 May 2016 #9

    Well somehow this problem seems to have fixed itself.

    Im guessing maybe one of my startup programs may have automatically updated which caused the error and now updated again to fix it. Eventhough I'm not aware of any of those programs that silently update in the background like that but it's the only thing I can think of.

    In any case, the problem is gone so I would just like to thank everyone that pitched in with the ideas.
      My ComputerSystem Spec


  10. Posts : 23,589
    64-bit Windows 10 Pro build 16362
       28 May 2016 #10

    Great news.
      My ComputersSystem Spec


 

Related Threads
As stated in title - no battery icon when not plugged in - and no battery/power icon when plugged in - also no locations icon. I do not care much about the locations one, but the battery one is pretty much vital. 26686 Going into "Turn system...
I searched to see if anyone addresses this issue and didn't find a thread for my exact problem, pardon me if I missed it... I used to have a bluetooth icon showing in my system tray/notification area, which was a nice convenience. It disappeared...
I cannot get the WIFI status tile to show in the Notification Area. There is no option in Settings - Notifications and actions - to turn this off and on.
From the Windows 7 forum. I have this exact same problem with my Windows 10 64 system. I was thinking that it started when I recently tried out Bitdefender IS, but am not sure. I have not found any solution yet. Is there an answer?
Solved Windows Defender notification area icon in AntiVirus, Firewalls and System Security
I like to see the Windows Defender notification area icon, so I've set my PC to show that item. However, is there a way to turn off the exclamation point item in that icon that says I haven't run a scan in a while? My last scan was 4 days ago and I...

Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 15:52.
Find Us